Jump to content

missed call notification to email doesn't work when hanging up quickly


joso
 Share

Recommended Posts

With the Audiocodes mp-118 and exchange w/ocs, i noticed that when i call in to the extension, ocs communicator shows the popup with the new call which is good, but if i hang up within the first or second ring before the voicemail prompt comes on it does not send an email with a missed call notification. if i wait until the exchange auto attendant comes on and hang up before the beep it sends the email.

 

Any idea what could be causing this.

 

joso

Link to comment
Share on other sites

Hello joso,

 

sounds familiar for me :) I guess what you described is per design. But let's clarify this a bit. Did you integrated Exchange UM to OCS or did you integrated AudioCodes to OCS and to Exchange UM in parallel?

 

Normally Office Communicator can place you a missed call notification in your outlook. If, you can see this in a underline, saying "send to you via Office Communicator".

 

;) Please recheck your Personal Information Manager settings in Office Communicator!

 

If a call reaches Exchange UM and you hangup or leaf a voice message you will see the underline " send to you via Exchange Server".

 

Best regards from Barcelona (Tech-Ed EMEA)

 

Jan

Link to comment
Share on other sites

Hello joso,

 

sounds familiar for me :) I guess what you described is per design. But let's clarify this a bit. Did you integrated Exchange UM to OCS or did you integrated AudioCodes to OCS and to Exchange UM in parallel?

 

Normally Office Communicator can place you a missed call notification in your outlook. If, you can see this in a underline, saying "send to you via Office Communicator".

 

;) Please recheck your Personal Information Manager settings in Office Communicator!

 

If a call reaches Exchange UM and you hangup or leaf a voice message you will see the underline " send to you via Exchange Server".

 

Best regards from Barcelona (Tech-Ed EMEA)

 

Jan

 

I integrated AudioCodes to OCS and to Exchange UM in parallel.

 

and it show that the notification was sent by exchange. how do i change this?

Link to comment
Share on other sites

If all of your users using Office Communicator you can simply follow the tip I posted here:

 

http://forum.pbxnsip.com/index.php?showtop...post&p=6593

 

Note: carefully read the articles on technet - when you do it first time, there are some pitfalls! Test it in a non-productive system or in off-time!

 

Please dont forget to disable the voicemail settings in pbxnsip user accounts at least!

 

Best regards,

 

Jan

Link to comment
Share on other sites

it looks like i got this to work with ocs.

 

the only glitch i found was when i dual fork my hard phone with office communicator, both ring at the same time, but when i answer the hard phone instead of communicator, i get an email with a missed call notification.

 

Joso

Link to comment
Share on other sites

Congratulations regarding the OCS - UM integration. :wacko:

 

But please double check if "Play On Phone" is working! btw. are you using a Tanjay (OCS) Phone. If yes, does it show the call-logs from Exchange 2007?

 

Does this missed call notify coming from OC-Client saying: "send to you via Office Communicator".

Or does it comes now from Exchange? " send to you via Exchange Server".

 

What version of pbxnsip are you running. Is your ocs-mediations server update.

 

Best regards

Jan

Link to comment
Share on other sites

that was my verdict :wacko: but it has nothing to do with your Message Button on a sip phone!

 

Play on phone is initiating an outbound call to a user provided Tel-number via UM Server in Outlook 2007 or Outlook Web Access.

 

Very useful if you dont want to play your voicemail to the whole office or CyberCafe via PC-Speakers. Simply provide your mobile number, or any you like for "PlayOnPhone".

 

For that your Exchange UM Webservices must work correctly. Your Exchange UM service must use a Certificate trusted by your OCS Server - or the TLS connection between them can not be created!

 

Configuration of UM certificate is only possible in Exchange PowerShell.

 

Please read carefully the Certificate related chapters here: http://technet.microsoft.com/en-us/library/aa996420.aspx

 

Best regards,

 

Jan

Link to comment
Share on other sites

I guess if you are running OCS2007 you got an internal PKI with a windows based Certificate Authority. Right? You can create a cert-request in Exchange Powershell for the Unified Messaging Role. Pass this to your CA and import and enable the given certificate to your Exchange UM server.

 

A selfsigned is a certificate which in that case is "selfmade by" Exchange Server (for this cert. Exchange is the CA). But this one will not work with OCS by default! But you can import this as trusted in the local computer cert-store on your OCS. Than it should work. Never tested this, but it was recommended by MS OCS Team in cases were no internal PKI is available.

 

A UCC certificate is not necessary for OCS - UM Integration. It is useful for the OCS Edge Server deployment. Because you can publish all your services (Access Edge, WebConf-Edge, A/V Edge, Exchange OWA, Exchange Autodiscover, your HTTPS-Webserver, etc...)

 

I know an UCC certificate looks expensive but with that you only need to maintain one certificate.

 

Best regards :)

 

Jan

Link to comment
Share on other sites

thanks for the info, we actually purchased a ucc certificate a few months ago from entrust and use this on our production exchange 2007 server. when i put ocs and pbxnsip in production, is this the cert i can use? or do i have to purchase another one for ocs. the key is, that i will be setting up an echange edge role and ocs edge in the dmz when i delpoy the phone system, this will be on one server with ocs virtualized (with windows 2003 32bit) and exchange edge role on the host windows 2008 hyper-v. Can is set it up this way? or does exchange and ocs have to be usign the same public ip for external access?

 

Joso

Link to comment
Share on other sites

  • 4 weeks later...

Hello Joso, :)

 

yes you can run Exchange Edge Server on a host machine and OCS Edge virtualized as a guest. But virtualization of Edge, SE and Meditation Server is not supported by MS. Background is the HOST / GUEST clock sync, is realy important for Audio/Video processing. Its only a rumour: Hyper-V has issues and VMware not.

We use Hyper-V virtualized Mediation and Edge with 15 users without problems.

 

Please keep in mind: as best practice dont join OCS Edge or Exchange Edge Servers to your domain!

 

OCS Edge and Exchange Edge dont need to (should not) share same public IP address!

 

You need a public routeable IP Address for the A/V Edge Server Role in your consolidated OCC Edge Server.

OCS Access Edge and Web-Conf Edge Roles can use natted IP addresses.

Please dont forget to deploy an OCS Reverse Proxy (Like ISA Server) - its not a OCS Role, but a web publishing of OCS SE

Virtual Directories via an Firewall (like ISA). Will be used for Live Meeting Content Download, Addressbook Download and OC Group Expansion Features.

 

Please review your Exchange Autodiscover Deployment and check your UC certificate for Autodiscover.YourMailDomain.com ! OC Client will use Exchange Autodiscover feature to connect to Exchange Web Services.

 

Best regards, :)

 

Jan

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...