Jump to content

Outbound calling problem with CALLCentric


natedev
 Share

Recommended Posts

I setup a SIP Trunk to CALLCentric using pbxnsip 3.0.1.3023 (Win32). The CALLCentric account has North America Unlimited and DiD - Personal Unlimited. My only domain is setup to use the Standard Dialplan. Default PnP Dialplan scheme is North America (3 digit extensions). The Standard Dialplan is very simple:

Pref=100, Trunk=Unassigned

Pref=100, Trunk=CALLCentric, Pattern=9*

 

The CALLCentric Trunk is setup for Inbound & Outbound. Global is set to yes. The Trunk shows "200 Ok" for the status.

My extension (100) is setup for Dial Plan = Domain Default.

I have Polycom SoundPoint IP 670 phones.

 

Whenever I try to dial 9 plus another US number, I get a fast busy signal. CALLCentric never logs that it got the outbound call from pbxnsip. This is what I have in my logfile:

[5] 2008/11/28 01:06:19:Dialplan Standard Dialplan: Match 12125551212@pbx.genilogix.com to <sip:12125551212@callcentric.com;user=phone> on trunk CALLCentric

 

So it looks like the dialplan is ok so it must be something else. Inbound calls to my CALLCentric number do get routed to my extension successfully so I'm thinking that it must not be a networking issue. The docs on CALLCentric's website were based on pbxnsip 1.5. I followed the info on the pbxnsip Wiki though it was pretty brief and may not be oriented towards 3.0.1.

 

Anyone have any suggestions?

Link to comment
Share on other sites

Thanks a lot for the reply! The fields on your Edit Trunk page look a bit different from mine. Which version of pbxnsip are you running? I'm on 3.0.1.3023 (Win32). The option to Rewrite Global Numbers isn't on my page at all.

 

I experimented following the settings we have in common and found that the one thing that was preventing outbound dialing was "Remote Party/Privacy Indication". Mine was set to "RFC3325 (P-Asserted-Identity)" which was the default for a new Trunk. The settings "No Indication" or "Remote-Party-ID" work. After looking through the Wiki, I see that this is mentioned. Wonder why it would default to an option that isn't recommended?

 

I didn't specify a Trunk ANI initially. This didn't seem to be the cause of the problem though because the behavior was the same with or without it. Setting it doesn't seem to have any effect though.

Link to comment
Share on other sites

Thanks a lot for the reply! The fields on your Edit Trunk page look a bit different from mine. Which version of pbxnsip are you running? I'm on 3.0.1.3023 (Win32). The option to Rewrite Global Numbers isn't on my page at all.

 

The latest and greatest (3.1.1). Okay, it is still no released...

 

I experimented following the settings we have in common and found that the one thing that was preventing outbound dialing was "Remote Party/Privacy Indication". Mine was set to "RFC3325 (P-Asserted-Identity)" which was the default for a new Trunk. The settings "No Indication" or "Remote-Party-ID" work. After looking through the Wiki, I see that this is mentioned. Wonder why it would default to an option that isn't recommended?

 

Every ITSP has it differently. The RFC3325 solves most problems with the Caller-ID indication when redirecting calls that's why we choose this as default.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...