Jump to content

SNOM + SRTP = White Noise

intParse (Medisys)

Recommended Posts

Facing a serious problem with Snom360 phones about the white noise being generated on calls after 3-4 minutes (sometimes shorter; 30sec) on an srtp connection.


I have tested and seen the same symptoms for srtp calls on both linux(SuSe) and windows (2000) machines. PBXnSIP v1.5.1.7 is running on Suse machine and v1.5.2.7 is running on windows2000 machine. All phones were upgraded to Snom360 6.5.10. I even upgraded them to snom360 7.1.9 version but couldn't get the phones make secure (srtp) calls on v7. (BTW v7 upgrade slows down the snom360 phones. Startup and registration was extremely slow. Keep away from v7 if you own snom360 phones.)


I have also tried the sip:xxx.xxx.xxx.xxx:5061;transport=tls line on the outgoing proxy and no luck.


In the PBXnSIP 1.5 release notes some of the srtp problems were mentioned as being solved but I don't know if they apply to this white noise situation.


I've read some of the threads mentioning this problem but couldn't find any solution to this problem. I am listing the threads I found in PBXnSIP and others forums below (namely asterisk forum thread about the snom white noise);


http://forum.pbxnsip.com/index.php?showtopic=93 <-- (Check the last answer or do a text search on "white noise)

http://bugs.digium.com/print_bug_page.php?bug_id=5413 <--- (do a text search on "white noise")


on the second thread it says "When chan_sip is starting a non crypto call, sending out an INVITE without any sdesc (_SIP_SRTP_SDES is unset), but the reply from the peer includes a sdes proposal, a crypto policy get set up and activated, without the local key being exchanged.


At least Snom 5.x always answer INVITE with a a=crypto line and "a=encryption:optional" in the sdp, calling one without setting _SIP_SRTP_SDES gives asterisk using srtp and the snom expecting unenctypted rtp, and nice white noise in the earpiece."


So here are my questions:


* Is this white noise being generated because of snom neglecting to add the a=crypto line on some of the sip messages while sending them to PBXnSIP?


* If it is, is there a work around for this? (w/o upgrading to PBXnSIP 2.0)


Any help greatly appreciated, thanks in advance.

Link to comment
Share on other sites

There was a problem with SRTP. The 1.5 branch works fine with the snom versions < 6.5.8 (they had the same bug). snom360/6.5.10 is doing it "right".


Options: (1) upgrade to 2.0 (2) downgrade the snom phones (3) we generate a new 1.5 version with a fix (what OS are you using?) (4) turn SRTP off

Link to comment
Share on other sites

There was a problem with SRTP. The 1.5 branch works fine with the snom versions < 6.5.8 (they had the same bug). snom360/6.5.10 is doing it "right".


Options: (1) upgrade to 2.0 (2) downgrade the snom phones (3) we generate a new 1.5 version with a fix (what OS are you using?) (4) turn SRTP off


Thanks for your prompt reply.


The phones are running snom360 sip-6.5.10, yes it is the version 6.5.10 doing it. There are nearly 300 phones and they are already running on 6.5.10, so, IMHO, downgrading them is not an effective solution.


This project is due to go live very shortly. There is a lot of custom developed SOAP based features and language customization we implemented based on 1.5.xxx hence we and the customer very reluctant to upgrade at this stage. We do have plans in place for further development for which will get underway as soon as we launch the current project. We are planning to start the new work with version 2, but for now, we will greatly appreciate if you can provide us the fix for SRTP problem so that pbxnsip 1.5.xxx works with snom360/6.5.10.


Our main server is running on SuSe and our test environment is on Windows. So If you could make the fix for Suse and Windows platforms we will greatly appreciate it. (Priority is SuSe though)


We are insisting on SRTP because that is one of the main requirements of the project. Although we have tested and used the phones running 6.5.10 successfully w/ srtp turned off, eliminating the srtp is not an option for the current project.


BTW, how well do AASTRA phones (new 53i/55i/57i) work with pbxnsip? any experiences - especially with SRTP?


Thanks again for your help and looking forward to the PBXnSIP 1.5 fix for Suse (and windows if you could) on your earliest convenience.


Best Regards.

Link to comment
Share on other sites

I see you prefer option 3... There is a Windows image at http://www.pbxnsip.com/download/pbxctrl- which might fix that problem. Could you install that image (following the procedure in http://wiki.pbxnsip.com/index.php/Installi...Manual_Upgrade) and check if it fixes the problem? Please also make a phone call that lasts longer than 22 minutes (so that there are more that 64K RTP packets being exchanged).


If Windows works, we can generate a SuSE image as well.

Link to comment
Share on other sites

Thanks for the quick update. As soon as I saw your reply with the new version, I upgraded the windows test environment to and started my tests with snom360 v6.5.10 phones. Unfortunately, on the 14min. mark the white noise made its appearance and deafened us to SRTP hell.


The srtp package count was;

RTP-RxStat: Dur=859,Pkt=42915,Oct=7553040

RTP-TxStat: Dur=857,Pkt=42907,Oct=7551632

Link to comment
Share on other sites

Okay, we were able to reproduce the problem. The problem was actually a stupid problem in determining what SRTP patch level we should use, for some strange reason were were checking if the version was bigger then 6.10, not 6.5.10!


It would be great if you can check the version at http://www.pbxnsip.com/download/pbxctrl-

Link to comment
Share on other sites

I've tested the new version with snom6.5.10 and it works (30 minutes of srtp call and no white noise).


Thanks for this update, greatly appreciated. When should we expect to get the SuSE version?


P.S. I know it's 4th of July so I am not expecting anything today. Have a safe 4th of July people and easy on the fire works...



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...