Jump to content

Grandstream HT802 won't provision from Vodia or from downloaded XML


Recommended Posts

I'm using Vodia 68.0.28 under Linux in the cloud (Azure).

I updated a customer's Grandstream HT802 ATA to the latest firmware ( When I try to provision it, Vodia thinks it worked:

[8] 10:49:50.739	PROV:	PnP: Extracted MAC 000B82123456 for file cfg000b82123456.xml
[8] 10:49:50.739	PROV:	Provisioning file cfg000b82123456.xml looking for MAC 000B82123456
[7] 10:49:50.739	PROV:	PnP: Loading file grandstream-ht80x.xml for 249@phonesystem.mydomain.com for 1 authenticated users
[9] 10:49:50.739	PROV:	PnP: Using the credentials of 249@phonesystem.mydomain.com for file grandstream-ht80x.xml
[9] 10:49:50.739	PROV:	Filter configuration file grandstream-ht80x.xml
[5] 10:49:50.740	PROV:	Generated file grandstream-ht80x.xml with size 2646
[8] 10:49:50.740	PROV:	HTTP: file cfg000b82123456.xml based on template grandstream-ht80x.xml is sent to

however the HT802 is not updated. My guess is the provisioning file is too big, or contains some syntax that HT802 does not like. I finally figured out how to view the dynamic provisioning file (loading in a browser doesn't work). At a Linux command prompt, this saved the file to the root of the PBX:

curl --request GET 'http://phonesystem.mydomain.com/prov/cfg000b8123456.xml' --header 'User-Agent: Grandstream Model HW HT802 V1.5B SW DevId 000b82123456' > /usr/local/pbx/HT802.xml 

Looking at the output file, I thought maybe the problem was the ampersand (&) in the web password, which in XML is converted to "&"

I tried manually setting the password in the HT802 to the same password that I set in Vodia. That failed. So the password is likely the problem.

After much trial and error, I noticed this line in the HT802 admin guide:  "Note: Provision admin password without special characters is supported." In other words, no special characters are allowed in the password. So in the HT802 web UI, I changed the admin password to one with no special characters. That worked. Then I tried manually applying the downloaded XML config file, with the new password. That still didn't work!

I give up. It's easy enough to manually provision an HT802. If someone has insight into why provisioning from XML doesn't work, I'd be glad to hear it.




Link to comment
Share on other sites

  • 3 weeks later...

Hmm. Well we can't do anything about the administrator choosing a password that includes special characters, and IMHO a device should be able to handle that. XML properly does it. But for passwords that the PBX generates, AFAI can see, it should not contain an ampersand unless you are on a really old version. Setting if through the web interface will not help much, because you will set the web or SIP password which is unrelated. What you could try if regenerate the MAC password, easiest would be to delete the MAC and add a new one, maybe just for sake of proving the hypothesis. Or edit the file for the MAC in the file system, take the encrypted parameter out for the password and put it there in plane text, then restart the service. 

Link to comment
Share on other sites

I think there may be some confusion over which password was causing the issue. The Grandstream "admin password" refers to the password one uses to log in to the HT802's UI. Specifically, the Grandstream provisioning XML contained something like this:

    <!--  Admin password for web interface -->

which the HT802 did not like. I agree, it should be able to handle special characters, but per the documentation, it cannot.

Yes, I created kR8*gCAc&tfwG!sa in Vodia as a nice complex password under Tenant > Settings > General Settings > Provisioning Parameters. Unfortunately if I simplify that to work with the Grandstream, I will have to reprovision all the other phones as well. This is where it is a drawback to have a common admin password for all devices. I'm making a note to avoid special characters on future installs.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...