Jump to content

New to Vodia: No Audio when using the vodia Apps (android, iphone) from an external Network


Recommended Posts

I am a new Vodia User. I did setup a test environment on a Win Server 2016. As long as I use the PBX from the internal Network everything is fine (I am able to autoprovision phones, I can make and receive calls from the trunk I did setup, also can make and receive calls to an Android phone in the Lan). However when I try to use the Vodia app to call an extension from android connected to the mobile network, the call arrives and I can accept it, but there is no audio. I tried a different Android phone, also an iphone, also a different moblle provder.

The Vodia PBX is version 68.0. The OS I installed is a fresh installed Server 2016 with all updates running in a VM. Connection to the internet is made a dedicated static IP.

I forwarded ports 80, 443, 123, 5060, 5061, 49152–64512 as documented here: Configuring your firewall for remote users | Vodia Blog,

The Server has only one tenant. I have installed a valid certificate, login using barcode includd in the welcome message works fine.

Also I tried instead of using the "private/public" variables in the IP Routing list I tried the actual IP adresses. No change.

I captured a session. I can see rtp packets originating from the phone inside the network going to the PBX. When I playback the packets they sound good. But nothing from the remote end. I enabled the call recording feature for both extensions. Again the recording of the phone inside the LAN is good, but the recording of the remote extension is empty.

No Audio, in either direction. Looks like something trivial I did oversaw or I do not know. I have another PBX (3CX) running on a different VM and on a different external IP. Works good since several years.

I have not setup any frewallrule for outgoing traffic. I did however restrict admin access to the management console to the local network.

Is there a switch I have to flip?

Thank you for an Idea.

Link to comment
Share on other sites

Turned out it was my fault:

A second view on the problem after a healthy sleep revealed I just made a typo in the router/firewall UI. Where I blindy typed the rtp port range from 49152 to 65535 the input was used to redirect a single port to another port. So, the STUN messags of the client never reached the PBX. I now made the correct setting in routers UI where  I can forward a port range, and immediately it worked as expected.

As a side note: the RTP port range in the link above seems to be outdated. instead of 64512 it should be 65535 (I found that in another howto).


Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...