Jump to content

"Block oubound caller ID" not working with Sangoma/Netborder PRI


Jon Heese
 Share

Recommended Posts

Running pbxnsip v3.4.0.3201 (Win32) with a single trunk going to Netborder Express (running on the same server as pbxnsip), which talks to an internal Sangoma A101 single PRI card. Plugged into the Sangoma card we have a PRI from Nuvox Communications.

 

Our issue is with blocking outbound caller ID.

 

Optimally, we'd like to have a "*67" kind of feature, where we could selectively block outbound caller ID on a call-by-call basis, but I understand that the *67 code is a POTS feature, and won't work with a PRI. Instead, we need the switch (i.e. pbxnsip) to generate the proper signal to tell the PRI to block outbound caller ID.

 

So, I'm testing the "Block outbound caller-ID" feature in the extension settings. When I enable that flag and watch the SIP packets, I see that there is an additional "Privacy: id" header added (if I'm using P-Asserted-Identity or P-Preferred-Identity) and an additional "privacy=full" added on to the end of the "Remote-Party-ID" field, if I enable that (I know, I know, it's a legacy option that shouldn't be used).

 

However, the outbound caller ID is NOT being blocked, as it shows up on the callee side as normal.

 

The Netborder logs show the same SIP headers for "privacy" turned on, but it still passes the ANI to the PRI (as it needs to in order for the call to be allowed by our provider).

 

So, my question is: I've got three different players involved here (pbxnsip, Netborder/Sangoma, and Nuvox)... How do I figure out where the problem is?

 

Thanks in advance for any help.

 

Regards,

Jon Heese

Link to comment
Share on other sites

What mode did you use on the trunk to indicate the Caller-ID? Maybe you can try "no indication" on the field "Remote Party/Privacy Indication".

I don't fully understand your first question (or are you talking about "Remote Party/Privacy Indication"?), and I've tried all the possible values in the "Remote Party/Privacy Indication" field, including "No Indication", all with the same results.

 

That's what I meant when I said this:

When I enable that flag and watch the SIP packets, I see that there is an additional "Privacy: id" header added (if I'm using P-Asserted-Identity or P-Preferred-Identity) and an additional "privacy=full" added on to the end of the "Remote-Party-ID" field, if I enable that (I know, I know, it's a legacy option that shouldn't be used).

Regards,

Jon Heese

Link to comment
Share on other sites

Any word on this?

 

Well, well...

 

It seems that you first have to dial a star code on the FXO line and then the number. This is almost two-stage dialling. IMHO the best solution would be if the gateway somehow can deal with the blocking. In theory, the SIP trunk should not know about the details of the termination.

 

I am not a Sangoma expert; maybe it is worth studying the documentation there to see if there is a way to block the caller-ID.

Link to comment
Share on other sites

Well, well...

 

It seems that you first have to dial a star code on the FXO line and then the number. This is almost two-stage dialling. IMHO the best solution would be if the gateway somehow can deal with the blocking. In theory, the SIP trunk should not know about the details of the termination.

 

I am not a Sangoma expert; maybe it is worth studying the documentation there to see if there is a way to block the caller-ID.

There are no FXO ports involved here, and as far as I know, star codes do not work on a PRI (and my testing bears this out).

 

However, I will take your advice and contact Sangoma and see if there is any more documentation on exactly how I should go about disabling caller-id.

 

Keep in mind that we're not talking about globally disabling outbound caller ID, but rather selectively disabling it for a specific call, or as a workaround, for a specific extension.

 

Regards,

Jon Heese

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...