Jump to content

Malformed XML Language TAG when setting IVR Language on extension


lance@YSL
 Share

Recommended Posts

Hi,

 

There is a malformed tag <language> when setting the IVR Language in the General settings for extension XXXXX feature.

If you leave it on Default System IVR Language then the Language tag is excluded form the SOAP CDR XML and the XML is formed correctly.

 

If you change it to English, the XML tag is malformed as the closing tag does not have the /.

 

If you view the output from the SOAP CDR without trying to parse it you will see: <Language>en<Language>... Obviously this should be <Language>en</Language>

 

I have tested this on two different implementations of PBXnSIP 2.0.3.1715 (Win32).. and both have this problem...

 

Solution... either do not change the default language OR parse the output of the SOAP CDR and "fix" the second <Language> tag before using XML tools.

 

Hope this is or will be corrected in 2.1

 

Cheers

 

Lance

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...