Jump to content

Multiple Domain Setup


Miguel Costa
 Share

Recommended Posts

I understand the use of the tel: alias is required to properly route incoming calls to the appropriate auto-attendant.

 

I have two separate domains > phones properly register on both sides.

 

Trunks work fine for both domains, in other words, outgoing calls are successful. Both trunks for each domain is registering to the same provider. I use the remote-explicit-ID setting to manage the caller-id number for each domain. Again, outgoing is working fine.

 

The issue I have is as soon as I configure a trunk in domain B, all incoming calls are directed to auto-attendent B, even if calling to domain A.

 

Both trunks have been set with no extension setting. I use the tel: alias in the autoattendant for each domain, and use the ANI assigned by our provider (example: tel:4164443333). This does not work. I'm used to having our trunks register with a username that consists of our telephone number, but our new provider does not require a user or pw to register on their side.

 

Questions:

1. Would a tel: alias work in my case?

2. If not, how the heck do I properly route the calls?

 

 

Hopefully someone can point me in the right direction.

 

-Miguel

Link to comment
Share on other sites

I understand the use of the tel: alias is required to properly route incoming calls to the appropriate auto-attendant.

 

Not neccessarily. If your provider properly handles the line parameter in the registration, the PBX can tell which domain the incoming request is using.

 

Both trunks have been set with no extension setting. I use the tel: alias in the autoattendant for each domain, and use the ANI assigned by our provider (example: tel:4164443333). This does not work. I'm used to having our trunks register with a username that consists of our telephone number, but our new provider does not require a user or pw to register on their side.

 

You probably have to use the "To" header for routing purposes. If you use "!(.*)!\1!t!" (which says: use the To-header to identify the extension) in the Extensions of the trunk, the PBX should route the call correctly by the DID.

Link to comment
Share on other sites

in the trunks under "extension" put !([0-9]*)!\1!t!4164443333

fyi .. the tel: may not even be necessary ... I just use the number ..

 

I have run into this a few times lately with providers that do not require registration ..

 

yori

www.brandywinetech.com

 

Yori,

 

Thanks for that info. What do I place under the alias field for the auto-attendant?

 

-M

Link to comment
Share on other sites

All I put is the actual number .. say 16035551212 ...some carriers send the 1 and some don't so usually you have to read the SIP traces a little and screw with it ... try to figure it out and stick with the same provider for all your customers ... all these softswitches do things just a little different ..

 

I actually just ran into a weird one and since the customer had XO using level3 and the new SIP provider I use had them on L3 it was crazy trying to figure out why my stuff didn;t work the same as all my other clients ..

a call to a switch tech at the ITSP will generally help you work through it ..

 

yoti

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...