Jump to content
Vodia PBX forum
Leonmeijer

SIP registrations get lost after 8 minutes timeout

Recommended Posts

Hello all,

 

I'm having troubles with my trunks, they disconnect every 8 minutes, I've set keep-alive to 2 minutes and the Proposed Duration (s) is set to it's default.

Actually, when I look at the connections in my FireWall I see the "age" of the connection is about e.g. 30 minutes, but the connection Timeout is reset to 8 minutes everytime, when these 8 minutes expires, the SIP registration is lost (the webinterface shows that it's just fine...) then, after the 2 minutes of " keep-alive" have expired, the connection is recreated but it looks like it's not really keeping them alive, now very often I have problems with the inbound calls, when e.g. I set the keep-alive to "blank" I can have inbound for 8 minutes only after the re-registering.

 

 

The registration of my Snom phone also gets the 8 minutes but it re-registeres directly when the connection is lost, what does the PBX doe to check if the connection is disconnected somehow? it looks like "nothing" in this case, or did I just miss an option somewhere?

I'm certain that it's not a firewall setting.

Share this post


Link to post
Share on other sites

Now what! A few days later, in my firewall I see NO SIP connections.

 

I log in to the PBX (I use the beta 4 btw, maye that's it... on A P3), I click Trunks and what I see is:

 

All 4 of my trunks, the status column for all trunks is "EMPTY!" then an edit button and a delete button, how is this possible, PBX just drops the connections or something... this is really strange, anybody got any ideas? I use 2 accounts of VoipCHeap.com and others of sipnl.net (both different providers).

 

Edit, the only sip connection in the firewall is a connection from the phone to the pbx...

Share this post


Link to post
Share on other sites

Well, I think overall this is a problem with the firewall...

 

I guess the registration that the PBX gets from the service provider is valid for something like an hour. Then the PBX will attempt to register after 30 minutes, meaning that you have 30 - 8 = 22 minutes no coverage.

 

Actually many service providers try to keep the connection alive by sending traffic from their SBC to the PBX. The problem with that is that some firewalls don't accept outside traffic as keep-alive traffic. Maybe you ran into such a combination here.

 

It works better with the phones because the PBX registers the phones for a relatively short time.

Share this post


Link to post
Share on other sites

As iv'e said, it's NOT the firewall but if you really think so, of cource I tried disabling the firewall but exact the same thing happens, even if I have the PBX as DMZ host without ANY firewall on the network this thing happenes.

 

What I see in the log is some 401 and 404 messages from INCOMMING connections from 1 of the IP's of the sip host, the sip.sipnl.nl and sip.voipcheap.com have more then 1 ip set and some times when I check the Access thing in PBX I see that the pbx has blocked one of these IP's so it looks like the pbx plays the firewall here, but I will do a reconfigure...

 

Let the snom connect the sip server and forward the calls to the pbx which forwards the calls back, quick and dirty but works fine, maybe in a stable release of V4 it will work again but I don't know why but it works bably.

When I worked for another company I had the same issue, for them I wrote a program that logs in the PBX webinterface and virtually "clicks" the register button, guess such a solution I will have to make again...

Share this post


Link to post
Share on other sites

Oh what version are you using? We actually had a early beta that such a 8-minute bug for TCP/TLS. This happens for example when both parties agree on outbound, but then the refresh does not make it. But there was only a few days when this version was available (and I remember it was not even public). But this problem should be gone with all subsequent versions. What is your refresh time for registrations? Does it make a difference if you are using TCP/TLS or UDP?

Share this post


Link to post
Share on other sites

I'm using version: 4.0.1.3438 (Win32) (Beta).

 

The sips are registering via UDP/TLS (I think also TLS...) I don't know where to set it to TCP but I guess UDP is ok for sip not?

 

I tried various refres times, 20 seconds, 2 minutes, 10 minutes, 20 minutes and 1 hour but after some ammount of time the refresh stops working and all the sip registrations are lost... the status shows a " 200 OK" message but the logfile (which is set to the maximum logging level) shows only SIP registrations from the phone, all the trunk data is not logged.

 

I've also seen once that the trunk status was "blank" after 1 day.

 

Also, if I kill the connections in the firewall the pbx shows "408 Request timed out (retry after 60 seconds)" somethimes but that message remains untill I manually click the "register" link, the 60 seconds do nothing...

 

It's very strange but can't find a way to solve this...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...