Jump to content

pbx.xml


UKenGB
 Share

Recommended Posts

Is it supposed to be like this, or should there be some line breaks somewhere? Presumably the pbx app can read it whether the line breaks are DOS, Mac or Unix?

 

This is XML. If you like, you can add line breaks either in CRLF format or just in LF. Or none. It does not matter.

 

There are XML readers available (for example Internet Explorer can do that) which can present you the file in better readable format. Because usually human does not read it, we thought it is not neccessary to beautify the output.

Link to comment
Share on other sites

This is XML. If you like, you can add line breaks either in CRLF format or just in LF. Or none. It does not matter.

 

There are XML readers available (for example Internet Explorer can do that) which can present you the file in better readable format. Because usually human does not read it, we thought it is not neccessary to beautify the output.

Well there are some settings only available within that file. Even the docs say you may have to edit it, so can I suggest that some proper formatting would make a lot of sense? As you say, it's easy enough to modify the format, except that when you (try to) start the pbx, it immediately re-writes the file as one single line again:-(

 

I realise that there should be no need for formatting, but all XML editors I've tried baulk at this lack of formatting.

 

However, it is obvious that this is not the reason why the pbx is so totally unable to run on my Mac Mini Server. Back to the drawing board:-(

Link to comment
Share on other sites

Usually there is no need to manually touch this configuration file. Only if you forget your system admin password for example you have to edit this file...

If that were the case I'd still recommend better formatting, but not only do things never work that well, but in this case we are instructed to modify the ports if they might clash with those already in use, before running the software, by editing this file.

 

It's a small point (and I have bigger issues as you are aware pbxnsip), but every other user of XML files that I've come across sees fit to format them.

 

Anyway, at least we know it doesn't cause a crash:-)

Link to comment
Share on other sites

  • 5 weeks later...

Hi,

 

I am new to this. Installed snomone today on a mac mini server (leopard 10.6.5). ports 80 and 443 are already occupied. Tried to find the 'pbx.xml' file on the server to change ports, but no luck. What went wrong?

 

thanks,

The pbx.xml file can be found in /usr/Applications/snomone. However, I think that whole folder gets created the first time the pbx runs although I'm not 100% on that.

 

In any case, as long as you're not running OSX Server's Web service, you can run the PBX on standard settings, log in (that would be on the default port 80) and change it to something else, restart the PBX and log in again using the new port.

 

If you ARE running OSX Server's Web service, just shut it down while you perform the above port change for the PBX and then restart the Web service. It'll only be down for a minute or 2 and this would undoubtedly be easier than having to wade through the unformatted XML of the config file.

 

I have to say there's a lot of room for improvement with regard to the documentation for the OSX install and general layout and basic control.

Link to comment
Share on other sites

The pbx.xml file can be found in /usr/Applications/snomone. However, I think that whole folder gets created the first time the pbx runs although I'm not 100% on that.

 

In any case, as long as you're not running OSX Server's Web service, you can run the PBX on standard settings, log in (that would be on the default port 80) and change it to something else, restart the PBX and log in again using the new port.

 

If you ARE running OSX Server's Web service, just shut it down while you perform the above port change for the PBX and then restart the Web service. It'll only be down for a minute or 2 and this would undoubtedly be easier than having to wade through the unformatted XML of the config file.

 

I have to say there's a lot of room for improvement with regard to the documentation for the OSX install and general layout and basic control.

 

On my mac mini the pbx file is found /Library/snomone.

And even after switching off the port 80 for server web the snom is not starting at all.

Safari and Firefox cannot detect the localhost?

 

Any other suggestions?

 

thanks for your advice

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...