Jump to content

After 1 correct incoming call, all next calls fail.


Dimitri
 Share

Recommended Posts

Hello,

 

I'm new to SNOM One and after a week of testing (I installed a 32bit version for Windows on a Windows Server 2003 Standard), I need to call in your help. I've 10 numbers with 3StarsNet (a belgian SIP provider). I've set-up a trunk and a dial-plan. I'm able to make outbound calls, but with the incoming calls I'm experiencing difficulties. I'm able to receive 1 call (see log below). After this call, when I tried to call one of the 10 numbers ... I hear a tone, but the PBX doesn't react. No extra lines in the log and no incoming call. If I reopen my saved trunk settings and click 'save' (without changing a thing). I'm again able to receive one call ... I don't understand. Thanks for the help

 

The log

[5] 2010/11/11 21:35:41: Identify trunk (line match) 2

[6] 2010/11/11 21:35:41: Sending RTP for 76b4228141d389812b7d74ba0d35c782@85.119.188.3 to 85.119.188.67:16706, codec not set yet

[5] 2010/11/11 21:35:41: Global trunk 3StarsNet@sip.test.com sends call to 20 in domain sip.test.com

[6] 2010/11/11 21:35:41: Codec pcmu/8000 is chosen for call id 76b4228141d389812b7d74ba0d35c782@85.119.188.3

 

My trunk settings

Name:3StarsNet

Type: SIP registration

Direction: inbound and outbound

Trunk Destination: generic sip server

State: enabled

 

Display Name:Test

Account: 02880xxxx

Domain: 85.119.188.3

Username: 02880xxxx

Password: xxxxxx

Password (repeat): xxxxxx

Proxy Address: 85.119.188.3

CO Lines: co1 co2 co3 co4 co5

Permissions to monitor this account: empty

 

Lock codec during conversation: Yes

Proposed Duration (s): 3600

Keepalive Time: 3600

Send email on status change: don't send email

Strict RTP Routing: Yes

Avoid RFC4122 (UUID): No

Generate unique extension identifier: No

Accept Redirect: Yes

Interpret SIP URI always as telephone number: Yes

Requires busy tone detection: No

Trunk requires out of band-DTMF tones: No

 

Prefix: empty

Global: Yes

Trunk ANI: empty

Remote Party/Privacy Indication: Remote-Party-ID

Rewrite global numbers: Check domain country code

Failover Behavior: No failover

Is Secure: No

Inter-Office Trunk: No

ICID (RFC 3455): empty

 

Explicitly list addresses for inbound traffic: empty

Send call to extension: empty

Assume that call comes from user: empty

Ringback: Media

Link to comment
Share on other sites

Thx pbxnsip for the reply.

 

I verified every parameter in my ZyXel ZyWall USG20. I've no keep alive in my NAT settings. There are SIP settings ... Those are SIP media timeout = 120s and Signaling inactivity timeout = 1800s.

 

But I'm afraid, the problem lies elsewhere. The firewall log is showing me that a connection is entering and forwarded to my server (PBX Snom One). But on the PBX software, I see no movement. Like I said before, when I start the system. The first call comes in on 1 of my 10 phone numbers. From the second call on, notting happens in the Snom One log. I see the providers IP connecting and my firewall forwards all the calls (the first, the second, ...) to the server IP (a Windows Server 2003 32-bit). I'm able to get an other incoming call when I click the save button (without changing a thing) in the trunk setup. What is restarted or reset when I click the save button?

 

To test the firewall settings, I configured a phone (I configured it with the same IP as the server) directly to my provider (3StarsNet) and tried numerous calls. Every call passed ...

 

Any other ideas? I'm willing to test every possible solution.

 

Thx, Dimitri

Link to comment
Share on other sites

Hmm. I would use the "divide and conquer" approach here and try to identify where the problem is. To make 100 % sure that the PBX does not receive anything you could install Wireshark on the PBX; you could instead use the port mirroring feature of the Ethernet switch to look at what is coming into the firewall and what is going out. If you have the chance to run the PBX behind another firewall (e.g. from home) and calls pass through then the problem is obviously the firewall. If you have the same problem then it is probably the trunk setup. Or if the firewall has settings that enable or disable SIP I would try flipping some switches there and see if that makes any difference. It would not be the first time where the firewall is causing trouble with reading SIP packets.

 

 

Link to comment
Share on other sites

Ah, the forum is back ;-) Thx for the reply.

 

Last 48h I tried different set-ups. I changed the firmware version of my ZyXel ZyWall USG 20. I connected the server (with Snom One on it) directly on one of the routers LAN ports. I tried different set-ups in Snom One versions 2011-4.2.0.3950 and 2011-4.2.0.3958. Last but not least, I made one change in the trunk. I changed 'Interpret SIP URI always as telephone number' to no.

 

At the moment, the service is up and running for over 12 hours. I hope I'm on the right trail ...

 

There is one thing left. All incoming calls (on one of the 10 numbers) are routed to my head extension. Direct calling is impossible. I've got all accounts set-up like 20 02xxxxx20 / 21 02xxxxx21/ ... In my trunk settings, 'send call to extension' is blank. What am I doing wrong?

Link to comment
Share on other sites

Yea, the forum host switched itself off because the "bandwidth limit has been reached". I take this as a good sign that the traffic is increasing...

 

Anyway, about inbound routing check out http://kiwi.pbxnsip.com/index.php/Inbound_Calls_on_Trunk (the good old Wiki is still up until the new one is complete).

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...