Jump to content

inbound calls fail


Hunding
 Share

Recommended Posts

I need some help.

 

Outbound calls via my voip trunk work perfectly. Inbound calls do come into the system and ring the correct extension, but as soon as the call is picked up the external side gets a hang up. I talked with my trunk provider and they provided the following information:

 

 

It appears that you are telling us to sending the call to VoipInno@192.168.0.29 :5060 in the contact of your 200 OK. We are sending a ACK to your address above, however it appears that your system is not seeing it and continues to send multiple 200 OKs. Please check your settings and verify that this contact is correct, and if so you will want to make sure you have your settings correct to allow this call to be sent to your internal IP. Try adding the following to your trunk settings if you do not already have it:

 

externip=xxx.xxx.xxx.xxx *

 

* this is my my public IP. I have tried to manually add this line to the trunk but the system will not accept it.

 

Any help would be greatly appreciated.

Link to comment
Share on other sites

Well, you probably experience the "NAT" problem in VoIP. There has been a lot written about this, and you might also check out these links: http://kiwi.pbxnsip.com/index.php/Office_with_private_and_public_IP_addresses, http://kiwi.pbxnsip.com/index.php/One-way_Audio. But in short, you have the following options:

  1. Get a routable IP address. In an ideal world, you just grab a IPv6 address and your service provider does support IPv6; but in the world we are living in lets be realistic and just get a IPv4 address, add the IP address to your server with the right routing, and you have a rock-solid setup.
  2. Change your service provider. Many service providers use a session border controller to help you making your life easier and the system more stable.
  3. Pretend that the PBX has a public IP address, but without having it. That can be very stable, but it is usually very tricky to set this up and you must be a master in configuring your firewall.

Many service providers recomment to use a STUN server. This is reasonably okay for softphones, but IMHO for a mission critical PBX with requirements for the uptime unacceptable. Because you dont know what your firewall is doing with STUN traffic when there is a lot of traffic, we have found this method extremly support intensive (and frustrating) and finally took it out from the PBX.

 

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...