Jump to content

IP Authenticated SIPs.


citytelecom
 Share

Recommended Posts

I am attempting to set up Gamma IP Authenticated trunks.

According to advice from Snom I have set up as follows:

Type: SIP Gateway.

No account, domain or password required.

Proxy Address: the gateway address.

Remote Party/Privacy Indication: No Indication.

 

The dial plan is set up correctly.

 

On I/C calls, I get one way speech, the caller can hear the Snom user but not visa versa.

O/G calls fail. On Snom phone display I see'Not Found02082662808' and I hear a busy tone.

Link to comment
Share on other sites

Sounds like you need a routable (public) IP address to get that service working in a stable way. For outgoing, you might have to check your dial plan again if it is goes to the Gamma trunk.

Thank you for your response.

You're correct a public IP is required, this is the IP address used for authentication and I have this, ie, the public IP allocated to my Snom One is the CPE IP address for my IP Authenticated SIP trunk. Also, my dial plan I think is OK, my test area shows the number I am dialling routing correctly.

Link to comment
Share on other sites

Is the PBX running behind NAT? Then it would not present the public IP, it would represent it's private IP which is not routable for the service provider.

Yes, it is running behind NAT, but I do not think you are correct. We have an identical SIP trunk on a different PBX using NAT (on the same router) and it works fine with no set up issues.

The question is what fields do I fill out and how in order to get Gamma IP Authenticated SIP trunks up and working.

Link to comment
Share on other sites

  • 2 weeks later...

It is possible, though not easy. A requirement is that the IP address on the public side does not change. You can configure the NAT router to forward the neccessary ports to the PBX (including RTP), and then use the IP Routing List in the Ports section of the admin settings to have the PBX change the packets that are being sent to the service provider.

Link to comment
Share on other sites

Go to Admin / Settings / Ports and use the IP Routing List.

 

I attached a Screen Shot...

 

 

Bill

Thank you Bill, good document to have and I did apply the settings according to our settings here.

Whilst it did not appear to address the issue I feel we're in the right territory. It does seem that the TO and FROM headers contain the private IP address and not the public IP (which is required for IP Authenticated SIPs). Do you know at what point this information is embedded in the SIP messages? It is this IP address I need to change in the SIP headers.

Link to comment
Share on other sites

Hi Bill, Rereading your document I can see that the IP Routing setting is referred to for embedding the public IP yet it does not appear to doing this. Do I need to make any changes elsewhere in the Snom Admin or Domain settings?

Peter

 

 

There is no need to change anything else in the Snom One.

 

Your local (LAN) IP Address is in the upper portion of the Invite. 10.10.1.13 in this example.

 

Look at the second part of the Invite.

 

This is known as the Session Description Protocol and it tells the receiving party where to reach you.

 

INVITE sip:13@10.10.1.13 SIP/2.0

Via: SIP/2.0/UDP 10.10.1.99:5060;branch=z9hG4bK343bf628;rport

From: "Test 15" <sip:15@10.10.1.99>;tag=as58f4201b

To: <sip:13@10.10.1.13>

Contact: <sip:15@10.10.1.99>

Call-ID: 326371826c80e17e6cf6c29861eb2933@10.10.1.99

CSeq: 102 INVITE

User-Agent: Snom One

Max-Forwards: 70

Date: Wed, 21 Dec 2011 14:12:45 GMT

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY

Supported: replaces

Content-Type: application/sdp

Content-Length: 258

 

(The Session Description starts here)

 

v=0

o=root 1821 1821 IN IP4 173.175.145.252 <<<--- Your Public IP Address should be here.

s=session

c=IN IP4 173.175.145.252

t=0 0

m=audio 11424 RTP/AVP 0 8 101

a=rtpmap:0 PCMU/8000

a=rtpmap:8 PCMA/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

a=silenceSupp:off - - - -

a=ptime:20

a=sendrecv

 

o= Owner/creator and session identifier. (This where your Public IP Address will appear)

c= Connection information. Optional. (It will appear here too)

Link to comment
Share on other sites

Hi Bill,

Thank you for sticking with me on this.

In your example is the embedded address a public IP?

 

 

Yes.

 

In this area:

o=root 1821 1821 IN IP4 173.175.145.252 <<<--- Your Public IP Address should be here.

 

Although it, 173.175.145.252, is just an IP Address I made up for demonstration purposes.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...