Jump to content

how to configure pbxnsip to a SIP proxy server?


pbxnew
 Share

Recommended Posts

Hello,

 

I'm new in this area. I've installed pbxnsip on my Linux PC. I want to set it up so that it can be a SIP proxy server. But from the wiki doc, it seems most of the configuration is based on Windows.

 

To have a SIP proxy server, how to configure pbxnsip on a Linux PC if it's possible?

 

I've got a demo key for one eth port MAC. But I couldn't figure out where to put it...

 

 

TIA for all the replies. :mellow:

Link to comment
Share on other sites

There is little difference between Linux and Windows... Once you got the service running and make it to the web interface, things are pretty much the same in Linux and Windows.

 

Did you see the Wiki yet? http://wiki.pbxnsip.com, it contains a lot of information about how to log in, how to create your first domain, extensions and so on...

Link to comment
Share on other sites

How to make it to the web interface? I've read some of the docs. All the info about how to log in;create domain;etc. are GUI based which I don't have it right now.

 

I have VNC server running on that PC so that I can get into it using VNC viewer but I still cannot see anything running like the one shown in the doc for Windows. How to do it?

 

Thanks.

Link to comment
Share on other sites

How to make it to the web interface?

 

Check out http://wiki.pbxnsip.com/index.php/Login.

 

I have VNC server running on that PC so that I can get into it using VNC viewer but I still cannot see anything running like the one shown in the doc for Windows. How to do it?

 

In Linux, you need to do some additional steps to run the PBX as a service. Check out http://wiki.pbxnsip.com/index.php/Installing_in_Linux. If you are not familar with Linux daemons, our suggestion is to get started with Windows first and then later consider using Linux. You can easily move the configuration from Windows to Linux.

Link to comment
Share on other sites

Check out http://wiki.pbxnsip.com/index.php/Login.

In Linux, you need to do some additional steps to run the PBX as a service. Check out http://wiki.pbxnsip.com/index.php/Installing_in_Linux. If you are not familar with Linux daemons, our suggestion is to get started with Windows first and then later consider using Linux. You can easily move the configuration from Windows to Linux.

 

I followed exact steps to start the service on my Linux PC. But how can I get the login window shown at http://wiki.pbxnsip.com/index.php/Login? That's the part I don't understand... :mellow:

Link to comment
Share on other sites

Is the PBX process running?

 

ps auxwww|grep pbxctrl

 

If not, start it as root in the directory where you installed the PBX with "./pbxctrl-* --dir .". Then you should be able to access it with the web browser.

 

Again, Windows makes your life easier herel...

 

Yes, it's running:

 

root 25234 0.3 1.8 96528 19568 pts/0 Sl 11:46 0:00 /srv/pbx/pbxctrl --dir /srv/pbx

 

but when I tried to access it on browser, http://localhost/, it got this page instead of PBX GUI:

 

This page is used to test the proper operation of the Apache HTTP server after it has been installed. If you can read this page, it means that the Apache HTTP server installed at this site is working properly.

 

I don't have a Windows PC available right now, I have to go the tougher way :mellow:

Link to comment
Share on other sites

screen cap on my Linux PC:

 

# ls /srv/ -tl

total 8

drwxr-xr-x 36 root root 4096 Jan 3 11:28 pbxnsip

drwxr-xr-x 35 root root 4096 Jan 2 16:17 pbx

 

# ls /srv/pbx/ -alg

total 144

drwxr-xr-x 35 root 4096 Jan 2 16:17 .

drwxr-xr-x 4 root 4096 Jan 2 16:14 ..

drwxr-xr-t 2 root 4096 Jan 2 16:17 acds

drwxr-xr-t 2 root 4096 Jan 2 16:17 adrbook

drwxr-xr-t 2 root 4096 Jan 2 16:17 agents

drwxr-xr-t 2 root 4096 Jan 2 16:17 attendants

drwxr-xr-t 2 root 4096 Jan 2 16:17 autocallback

drwxr-xr-t 2 root 4096 Jan 2 16:17 button_lists

drwxr-xr-t 2 root 4096 Jan 2 16:17 buttons

drwxr-xr-t 2 root 4096 Jan 2 16:17 callingcards

drwxr-xr-t 2 root 4096 Jan 2 16:17 calls

drwxr-xr-t 2 root 4096 Jan 2 16:17 cdr

drwxr-xr-t 2 root 4096 Jan 2 16:17 colines

drwxr-xr-t 2 root 4096 Jan 2 16:17 conferences

drwxr-xr-t 2 root 4096 Jan 2 16:17 dial_plan

drwxr-xr-t 2 root 4096 Jan 2 16:17 dial_plan_entry

drwxr-xr-t 2 root 4096 Jan 2 16:17 domain_alias

drwxr-xr-t 2 root 4096 Jan 2 16:17 domains

drwxr-xr-t 2 root 4096 Jan 2 16:17 extensions

drwxr-xr-t 2 root 4096 Jan 2 16:17 hoots

drwxr-xr-t 2 root 4096 Jan 2 16:17 hunts

drwxr-xr-t 2 root 4096 Jan 2 16:17 ivrnodes

drwxr-xr-t 2 root 4096 Jan 2 16:17 lamps

drwxr-xr-t 2 root 4096 Jan 2 16:17 messages

drwxr-xr-t 2 root 4096 Jan 2 16:17 mohs

lrwxrwxrwx 1 root 35 Jan 2 16:14 pbxctrl -> ../pbxnsip/pbxctrl-rhes4-2.1.4.2345

-rw-r--r-- 1 root 4090 Jan 3 11:46 pbx.xml

drwxr-xr-t 2 root 4096 Jan 2 16:17 pnp_parms

drwxr-xr-t 2 root 4096 Jan 2 16:17 recordings

drwxr-xr-t 2 root 4096 Jan 2 16:17 regidx

drwxr-xr-t 2 root 4096 Jan 2 16:17 registrations

drwxr-xr-t 2 root 4096 Jan 2 16:17 schedules

drwxr-xr-t 2 root 4096 Jan 2 16:17 srvflags

drwxr-xr-t 2 root 4096 Jan 2 16:17 trunks

drwxr-xr-t 2 root 4096 Jan 2 16:17 user_alias

drwxr-xr-t 2 root 4096 Jan 2 16:17 users

drwxr-xr-t 2 root 4096 Jan 2 16:17 wipers

Link to comment
Share on other sites

I've comment out default welcome page in /etc/httpd/conf.d/welcome.conf. But then http://localhost displays all the files under /var/www/html/. How to connect to the web port of the PBX to have that login window?

 

tcp 0 0 0.0.0.0:5060 0.0.0.0:* LISTEN 25501/pbxctrl

tcp 0 0 0.0.0.0:5061 0.0.0.0:* LISTEN 25501/pbxctrl

tcp 0 0 :::5060 :::* LISTEN 25501/pbxctrl

tcp 0 0 :::5061 :::* LISTEN 25501/pbxctrl

udp 0 0 0.0.0.0:32918 0.0.0.0:* 25501/pbxctrl

udp 0 0 0.0.0.0:161 0.0.0.0:* 25501/pbxctrl

udp 0 0 0.0.0.0:5060 0.0.0.0:* 25501/pbxctrl

udp 0 0 :::32919 :::* 25501/pbxctrl

udp 0 0 :::161 :::* 25501/pbxctrl

udp 0 0 :::5060 :::* 25501/pbxctrl

udp 0 0 :::69 :::* 25501/pbxctrl

Link to comment
Share on other sites

Oh obviously the Apache already took port 80. Just start the PBX with the option --http-port 8080, then the PBX will use that port instead of the default port 80. Once you made it to the web interface, you can set the http from there, so that after the next start it will automatically pick the right port.

Link to comment
Share on other sites

Yes, it works now with port 8080. Thanks.

 

But the log file displays the following messages when restarting pbxnsip service. Is this all right?

 

[1] 2008/01/03 15:49:50: Starting up version 2.1.4.2345

[1] 2008/01/03 15:49:50: Working Directory is /srv/pbxnsip

[5] 2008/01/03 15:49:50: Starting threads

[2] 2008/01/03 15:49:50: Set processor affinity to 1 failed

[0] 2008/01/03 15:49:50: Could not bind socket to port 443 on IP 0.0.0.0

[0] 2008/01/03 15:49:50: FATAL: Could not open TCP port 443 for HTTP/HTTPS

[0] 2008/01/03 15:49:50: Could not bind socket to port 443 on IP [::]

[0] 2008/01/03 15:49:50: FATAL: Could not open TCP port 443 for HTTP/HTTPS

[0] 2008/01/03 15:49:50: UDP: bind() to port 69 failed

[0] 2008/01/03 15:49:50: FATAL: Could not open UDP port 69 for TFTP

[5] 2008/01/03 15:49:50: Set scheduling priority to 1

 

I only want to set pbxnsip on my Linux PC as a SIP proxy server. I didn't get the same window showing under http://wiki.pbxnsip.com/index.php/General_User_Settings though...

 

Still learning... :mellow:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...