Jump to content

Bekommen Snom One mit SIP nicht zum laufen


stormwind81
 Share

Recommended Posts

Hallo,

 

Wir tüftlen nun schon seit Tagen zusammen mit unserem SIP Provider an dem Fehler.

 

Haben Snom One und testweise 2 Snom Softphone und ein snom 300 konfiguriert.

Der SIP Account geht zwar online aber ist weder erreichbar noch kann damit angerufen werden.

 

Logfile von Snom ONE wenn jmd wählt:

 

 

5] 2012/03/01 11:14:35:

 

Dialplan "Standard Dialplan": Match 006769702506@192.168.1.38 to <sip:006769702506@sip01.vie.xpirio.net;user=phone> on trunk PSTN Gateway

 

 

 

[1] 2012/03/01 11:14:35:

 

Could not allocate new ports!

 

 

 

[5] 2012/03/01 11:14:39:

 

INVITE Response 488 Not Acceptable Here: Terminate 63ddae1d@pbx

_____________________________________________________________________________________________________________________

 

 

Die LOG des Snom 300 = Snom Softphone:

 

[5]1/3/2012 17:13:31: sip::process_auth:Match challenge for user=44, realm=192.168.1.38

[2]1/3/2012 17:13:32: Registered at registrar as 44@192.168.1.38 (Expires: 359 secs)

[5]1/3/2012 17:13:33: sip::process_auth:Match challenge for user=44, realm=192.168.1.38

[2]1/3/2012 17:13:33: Registered at registrar as 44@192.168.1.38 (Expires: 360 secs)

[5]1/3/2012 17:13:49: Dialog 4/3 going to trying

[5]1/3/2012 17:13:49: Dialog 4/3 going to early

[5]1/3/2012 17:13:49: sip::process_auth:Match challenge for user=44, realm=192.168.1.38

[5]1/3/2012 17:13:49: Dialog 4/3 going to early

[5]1/3/2012 17:13:54: Settings applied!

[5]1/3/2012 17:13:54: Dialog 4/3 going to terminated

[5]1/3/2012 17:13:54: timeout::callback: Registering with timeout of 0 ms

[5]1/3/2012 17:13:54: timeout::callback: Registering with timeout of 0 ms

[5]1/3/2012 17:14:16: Settings applied!

[5]1/3/2012 17:14:55: Dialog 5/4 going to trying

[5]1/3/2012 17:14:55: Dialog 5/4 going to early

[5]1/3/2012 17:14:55: sip::process_auth:Match challenge for user=44, realm=192.168.1.38

[5]1/3/2012 17:14:55: Dialog 5/4 going to early

[5]1/3/2012 17:14:59: Dialog 5/4 going to terminated

[5]1/3/2012 17:14:59: timeout::callback: Registering with timeout of 0 ms

[5]1/3/2012 17:14:59: timeout::callback: Registering with timeout of 0 ms

 

 

_________________________________________________________________________________________________________________________________________

 

 

Das SIP Packet wird richtig mit externer IP gesendet. Nur kommt es zu keinem RTP-Sprachaufbau.

Es wird ein Codec Probem vermutet und der SIP Provider meint es muss an der Anlage liegen.

Die Firewall blockt nicht.

 

Bitte helfen Sie uns weiter.

 

 

mfG

Christian

Link to comment
Share on other sites

[1] 2012/03/01 11:14:35: Could not allocate new ports!

 

Das darf nicht passieren. Vermutlich ist der RTP port Range zu klein. Dort sollte man schon einige 100 Ports der PBX "spendieren" (Admin/Einstellnungen/Ports/Bereich Start und Ende). Jeder Call frisst mindestens 4 Ports und man sollte dort genügend Platz für eine freie (zufällige) Auswahl der Ports lassen. Default sind 16000 Ports, damit gibt es in der Regel keine Probleme.

Link to comment
Share on other sites

Das darf nicht passieren. Vermutlich ist der RTP port Range zu klein. Dort sollte man schon einige 100 Ports der PBX "spendieren" (Admin/Einstellnungen/Ports/Bereich Start und Ende). Jeder Call frisst mindestens 4 Ports und man sollte dort genügend Platz für eine freie (zufällige) Auswahl der Ports lassen. Default sind 16000 Ports, damit gibt es in der Regel keine Probleme.

 

Hallo,

 

Danke erstmal für die Antwort.

Die Einstellungen waren bereits vordefiniert mit "Port Range Start:49152" und "Port Range End:64512"

Trotzdem funktioniert es nicht.

 

Meldung:

 

[1] 2012/03/05 09:15:01:

 

Could not allocate new ports!

 

 

 

[5] 2012/03/05 09:15:08:

 

INVITE Response 487 Request Terminated: Terminate bfb5b5a6@pbx

 

 

 

 

 

 

Was kann ich noch überprüfen?

 

Meine Einstellungen sind noch folgende:

 

Follow RTP: on

Codec Preference: G.711U, G.711A, usw.

 

Lock codec during conversation: off

Always send packet size: yes

Multicast IP-Adresses: -

Bind to specific IP Address (IPv4): 19x.xx.xxx.xxx (<- unsere externe IP Addresse der Snom Anlage (NAT))

Bind to specific IP Address (IPv6): -

Link to comment
Share on other sites

Bind to specific IP Address (IPv4): 19x.xx.xxx.xxx (<- unsere externe IP Addresse der Snom Anlage (NAT))

 

Das würde ich mal rausnehmen. Wenn das keine lokale IP-Adresse ist, wird das Betriebssystem imme rmeckern dass der Port nicht auf die Adresse gebunden werden kann. Dieses Setting wird eh nur für Multicast-RTP verwendet.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...