Jump to content

remote call initiation on 4.5 swapping headers if connect=false


reco
 Share

Recommended Posts

hi there,

 

we are using an external crm app to dial numbers with the phones.

everything works great with the parameter connect=true. but if i set connect=false the pbx swaps the from with the to header.

 

 

 

 

caling number: 212xxxxxxx

from number: 646xxxxxxx

 

 

 

with connect=true:

 

INVITE sip:1212xxxxxxx@sbc.voxbeam.com;user=phone SIP/2.0

Via: SIP/2.0/UDP 98.113.181.115:5060;branch=z9hG4bK-8034daf0282de9eba073380ce4d03b42;rport

From: <sip:1646xxxxxxx@pbx.com;user=phone>;tag=2051986802

To: <sip:1212xxxxxxx@pbx.com;user=phone>

Call-ID: e555f022@pbx

CSeq: 28185 INVITE

Max-Forwards: 70

Contact: <sip:1646xxxxxxx@98.113.181.115:5060;transport=udp>

Supported: 100rel, replaces, norefersub

Allow-Events: refer

Allow: INVITE, ACK, CANCEL, BYE, REFER, PRACK, INFO, UPDATE

Accept: application/sdp

User-Agent: snomONE/4.5.0.1050 Coma Berenicids

P-Asserted-Identity: "COMPANY" <sip:1646xxxxxxx@pbx.com>

P-Preferred-Identity: <sip:1646xxxxxxx@pbx.com;user=phone>

Remote-Party-ID: "COMPANY" <sip:1646xxxxxxx@pbx.com;user=phone>

Content-Type: application/sdp

Content-Length: 341

 

 

with connect=false:

 

INVITE sip:1212xxxxxxx@sbc.voxbeam.com;user=phone SIP/2.0

Via: SIP/2.0/UDP 98.113.181.115:5060;branch=z9hG4bK-cc4749d9f448c0bcf3a006cdd6ae9113;rport

From: <sip:1212xxxxxxx@pbx.com;user=phone>;tag=1290790567

To: <sip:1646xxxxxxx@pbx.com;user=phone>

Call-ID: f838e904@pbx

CSeq: 1383 INVITE

Max-Forwards: 70

Contact: <sip:1212xxxxxxx@98.113.181.115:5060;transport=udp>

Supported: 100rel, replaces, norefersub

Allow-Events: refer

Allow: INVITE, ACK, CANCEL, BYE, REFER, PRACK, INFO, UPDATE

Accept: application/sdp

User-Agent: snomONE/4.5.0.1050 Coma Berenicids

P-Asserted-Identity: "COMPANY" <sip:1212xxxxxxx@pbx.com>

P-Preferred-Identity: <sip:1212xxxxxxx@pbx.com;user=phone>

Remote-Party-ID: "COMPANY" <sip:1212xxxxxxx@pbx.com;user=phone>

Content-Type: application/sdp

Content-Length: 341

 

bug?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...