Jump to content

Network Failure message


Recommended Posts

Hi,

 

I just came across to a new problem. A remote user is unable to call to other extensions.He can make calls outside the system (trunk calls), he can also receive calls from other extensions, but he cannot call other extensions. The pbx is a snom mini running 4.5.1 and the phone is a snom 710 with the latest firmware(8.7.3.19). Everything else is working fine. The weird thing is that two remote extensions that they have on softphones over iPhones do work properly in every scenario. The error message that thesnom 710 display when dialing an extension is: "Network failure: XXX" (whereXXX is the extension dialed).

 

I do notknow where to make adjustments. The phone is registered and can do every other thing. Just placing a call to an extension is what it cannot do. Has any one encountered this? What can I do to solve this?

 

Regards

Link to comment
Share on other sites

Hi

 

Thaks for answering. I just did a restore to factory defaults and a reboot (just to be dobule sure with that). Problem persists.

 

Out of desperation, I tried changing the parameters in the NAT region of the phone. I changed to "offer ICE" to on and added a stun server with an interval of 15 seconds and a keep alive of 10 and that did the trick.

 

I have been reading here in the forum that such a thing is a very last resort kind of option. So, I tried a Manual WAN Plug and Play. Unfortunately that did not work and I assume that such a thing did not work because we need to do first a port forwarding for the http port of the pbx.

 

I do not have control of the firewall (which is run by a Cyberoam) so I cannot do the port forwarding myself. As soon as the IT guys of the customer give me a green flag, I will attempt the Manual WAN based plug and play again, which hopefuly will be a cleaner and more reliable solution.

 

In the meantime, is there a guideline regarding how many seconds to use in the STUN interval and the keepalive?

 

Regards,

Link to comment
Share on other sites

Well if you use STUN then you obviously also use UDP--both a bad idea. Your router probably messes with SIP packets which is causing such hard to track problems. The easiest is to use plug and play, because that will set the phone up to use TLS and also sets also other important parameters so that the number of problems is minimized. If you can't use PnP (4.5 does not support snom 710 yet), then at least use TLS transport layer. This way you don't need STUN (there is a permanent TCP connection anyway) and the router cannot change the packets.

Link to comment
Share on other sites

Hi,

 

Following advice, I erased the stun thing and turned offer ICE to off (as was the default) and in the outbound proxy window of the Identity Login section I added the transport=tls and it worked! I had tried that before with no success but now I see that I had the syntax wrong. I was also spelling out the port number but now I see that I should not... <pbx public IP address>; transport=tls instead of <pbx public IP address>:5061; transport=tls

 

At this time I cannot call other extensions to have a conversation (for a test) but I did made a call and no error message was displayed and I could hear the voice mail message of the extension called (something I could not do before). It seems like the problem has been solved. One weird thing though. If I see the accounts list page on the pbx GUI and check the box for IP address I can see my test phone registered but it says udp:192.168.1.254:1025 and everybody elses is shown as tls:<their local address and port>. Why would that be?

 

Regarding Plug and Play. That snom mini has version 4.5.1 and I added the following code to the pnp.xml file that is listed on the HTML Templates section of the pbx GUI

 

 

<file name="snom_710.xml" encoding="xml">

<pattern>snom710.htm</pattern>

<vendor>snom</vendor>

<anonymous>true</anonymous>

<protocol>tftp,http,https</protocol>

<pnp-vendor>snom</pnp-vendor>

<pnp-model>snom710</pnp-model>

<pnp-version>^[78]</pnp-version>

<pnp-content-type>application/url</pnp-content-type>

<pnp-url>{https-url}/snom710.htm</pnp-url>

</file>

 

I was able to do plug and play of the 710 phones in the local network using multicast for the first batch of phones that I installed originally over there. I have not been able yet to do it manually for WAN based plug and play for the remote users. I believed that it was because a port forwarding for port 80 is needed in the local router so that the remote phone can find and reach the pbx, but now I wonder if I am missing something else, like another bit of code for the pnp.xml file or some other file. Am I?

 

Regards

Well if you use STUN then you obviously also use UDP--both a bad idea. Your router probably messes with SIP packets which is causing such hard to track problems. The easiest is to use plug and play, because that will set the phone up to use TLS and also sets also other important parameters so that the number of problems is minimized. If you can't use PnP (4.5 does not support snom 710 yet), then at least use TLS transport layer. This way you don't need STUN (there is a permanent TCP connection anyway) and the router cannot change the packets.

Link to comment
Share on other sites

Well, we changed a lot for the provisioning for snom phones between 4 and 5; this was done for a reason and to save precious time when rolling the phones out. That also required code changes on the PBX back-end; not only on the templates. If you run version 4, you could do the provisioning in the LAN then take a look at the files in the generated folder and then use the settings when provisioning over the WAN so that you don't miss anything.

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...