Jump to content

1+ Area Code Question


AG1
 Share

Recommended Posts

I am having trouble setting up a dial plan that allows me to dial local numbers with or without the area code or a 1 in front of the area code.

 

This is troubling because the cell phone numbers need to have the area code in front of them to call different city cell numbers. Any ideas?

Link to comment
Share on other sites

Does this problem relate to the PSTN termination or to the dial plan on the PBX?

 

If it is for the dial plan on the PBX: If you have a country code set, the PBX presents the number in a normalized format to the dial plan, in case this is a domestic number it is always in 10-digit format (no matter if the user dialed 10 or 11 digits).

 

As for the PSTN termination, the trunk has a settings that tells the PBX how the trunk provider would like to have it. Many POTS providers prefer to have the number in 11-digit format, so that they can know that this is a domestic call.

Link to comment
Share on other sites

I am having trouble setting up a dial plan that allows me to dial local numbers with or without the area code or a 1 in front of the area code.

 

This is troubling because the cell phone numbers need to have the area code in front of them to call different city cell numbers. Any ideas?

 

Here's one of my Dial Plans. In the Domain's General Settings, I have both the Country Code and Area Code set. Both CallCentric and Vitelity require numbers to be 11 digits, so the NANPA 11-digit setting is set accordingly on each trunk.

If I dial xxx-xxxx, the PBX will add 1608xxxxxxx;

If I dial 6089871234, the PBX simply adds a 1 and sends out 16089871234. Does this help?

 

20;-;;900*;;;false

25;-;;1900*;;;false

100;Vitelity;c;xxxxxxx;1608*;;false

110;CallCentric;c;xxxxxxx;1608*;;false

120;VoIP.ms;c;xxxxxxx;1608*;;false

140;Vitelity;c;xxxxxxxxxx;1*;;false

150;CallCentric;c;xxxxxxxxxx;1*;;false

160;VoIP.ms;c;xxxxxxxxxx;1*;;false

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...