Jump to content

Sending Out-of-Band DTMF to an IKON Gateway


PeterInFrankfurt
 Share

Recommended Posts

I need to send Out-of-Band DTMF to an extension, but the snomone appears to transcode the DTMF to in-band. (The "extension" is really an IKON gateway which only supports out-of-band DTMF.) Here's a part of the logfile:

 

[6] 2013/09/10 13:19:40: Call port 121: Different Codecs (local telephone-event/8000, remote PCMA/8000), callid f419f99b@pbx, falling back to transcoding

[6] 2013/09/10 13:19:40: Received DTMF *, call type attendant

[8] 2013/09/10 13:19:40: Attendant: Ignoring the DTMF * in the state connected

 

How can I make the pbx forward the DTMF as an RTP-event to the "extension"?

In case it's relevant, here's the INVITE etc.

 

2013/9/10 13:19:39 Tx: udp:172.27.66.105:5067 (959 bytes)

INVITE sip:240@172.27.66.105:5067 SIP/2.0

Via: SIP/2.0/UDP 172.27.66.106:5060;branch=z9hG4bK-abb91ea6476deec2bab243dd796c1b78;rport

From: "Svalbard MER1" <sip:401@localhost;user=phone>;tag=51546

To: "MSG Control Room" <sip:240@localhost>

Call-ID: 57a2ef9c@pbx

CSeq: 27025 INVITE

Max-Forwards: 70

Contact: <sip:240@172.27.66.106:5060;transport=udp>

Supported: 100rel, replaces, norefersub

Allow-Events: refer

Allow: INVITE, ACK, CANCEL, BYE, REFER, PRACK, INFO, UPDATE

Accept: application/sdp

User-Agent: snomONE/5.1.0

Alert-Info: <http://127.0.0.1/Bellcore-dr3>

Content-Type: application/sdp

Content-Length: 329

 

v=0

o=- 63349 63349 IN IP4 172.27.66.106

s=-

c=IN IP4 172.27.66.106

t=0 0

m=audio 41036 RTP/AVP 8 0 9 2 3 101

a=rtpmap:8 PCMA/8000

a=rtpmap:0 PCMU/8000

a=rtpmap:9 G722/8000

a=rtpmap:2 G726-32/8000

a=rtpmap:3 GSM/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

a=rtcp-xr:rcvr-rtt=all voip-metrics

a=sendrecv

 

and here's the OK back

 

2013/9/10 13:19:39 Rx: udp:172.27.66.105:5067 (820 bytes)

SIP/2.0 200 OK

Via: SIP/2.0/UDP 172.27.66.106:5060;branch=z9hG4bK-abb91ea6476deec2bab243dd796c1b78;rport

From: "Svalbard MER1" <sip:401@localhost;user=phone>;tag=51546

To: "MSG Control Room" <sip:240@localhost>;tag=802229

Call-ID: 57a2ef9c@pbx

CSeq: 27025 INVITE

Contact: <sip:240@172.27.66.105:5067>

Allow: REGISTER,SUBSCRIBE,NOTIFY,INVITE,ACK,PRACK,OPTIONS,BYE,CANCEL,REFER,INFO,UPDATE

Content-Length: 149

Content-Type: application/sdp

Server: (innovaphone H323/[unknown])

Supported: replaces,100rel,sec-agree,answermode

P-Preferred-Identity: <sip:240@172.27.66.105:5067>

Remote-Party-ID: <sip:240@172.27.66.105:5067>;party=called;screen=no;privacy=off

 

v=0

o=- 49 1 IN IP4 172.27.66.105

s=-

c=IN IP4 172.27.66.105

t=0 0

a=sendrecv

m=audio 8184 RTP/AVP 8 0

a=ptime:20

a=silenceSupp:off - - - -

Link to comment
Share on other sites

Thanks for the reply. I can find no relevant settings on the gateway. I noticed that a=fmtp:101 0-16 is not mentioned in the gateway's reply. However, RFC 2833 says:

Since all implementations MUST be able to receive events 0 through   15, listing these events in the a=fmtp line is OPTIONAL.

Are you saying the snomone pbx insists the gateway response explicitly includes a=fmtp... ?

Link to comment
Share on other sites

snom ONE does not need the FMTP line, but it needs a a-line like a=rtpmap:101 telephone-event/8000.

 

The FMTP line provides additional information about a codec (parameters). The one above looks like a telephone-event parameter (DTMF), and it says send everything from 0-9, #, *, A, B, C, D and also hook-flash (according to RFC2833).

 

But anyway this is the right corner. If it is sending the fmtp line, it actually must also send the a=rtpmap:101 line.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...