Jump to content

One Way Audio


Dale Weaver
 Share

Recommended Posts

I'm setting up a new SIP trunk with nexVortex.com. I can make and receive calls with them. However, I only ever have one way audio. Snom sends the audio out but I never receive any back. I called nexVortex and they think that the audio they are sending is going to my SnomOne's private ip address, 192.168.0.7. How do I change the SIP Packet to tell nexVortex to send audio back to our public IP address so the firewall can route it to SnomOne. Right now I don't have any of my public IP's being forwarded to SnomOne. With my previous SIP provider, this wasn't necessary.

 

 

Here is part of the SIP trace they send me from their end.

 

2013/10/02 18:38:55.958292 173.167.75.17:5060 -> 66.23.129.253:5060
SIP/2.0 200 Ok..Via: SIP/2.0/UDP 66.23.129.253:5060;branch=z9hG4bK7fe3.1c76
34.0..Via: SIP/2.0/UDP 208.94.159.10:5060;branch=z9hG4bK-fa339-524c6830-71d
e681f-2ba94f90..Record-Route: <sip:17172834883@66.23.129.253:5060;nat=yes;f
tag=c00080a-13c4-524c6830-71de681f-15d3a53;lr=on>..From: "WIRELESS CALLER"
<sip:15514043819@208.94.159.10:5060;isup-oli=61>;tag=c00080a-13c4-524c6830-
71de681f-15d3a53..To: <sip:17172834883@66.23.129.253:5060>;tag=04a10ec64c..
Call-ID: CXC-87-7a3d5780-c00080a-13c4-524c6830-71de681f-662e588d@208.94.159
.10..CSeq: 1 INVITE..Contact: <sip:Ai11163mLaK@192.168.0.7:5060;transport=u
dp>..Supported: 100rel, replaces, norefersub..Allow-Events: refer..Allow: I
NVITE, ACK, CANCEL, BYE, REFER, PRACK, INFO, UPDATE..Accept: application/sd
p..User-Agent: snomONE/4.5.0.1090 Epsilon Geminids..Content-Type: applicati
on/sdp..Content-Length: 274....v=0..o=- 20464 20464 IN IP4 192.168.0.7..s=-
..c=IN IP4 192.168.0.7..t=0 0..m=audio 60872 RTP/AVP 0 18 101..a=rtpmap:0 p
cmu/8000..a=rtpmap:18 g729/8000..a=fmtp:18 annexb=no..a=rtpmap:101 telephon
e-event/8000..a=fmtp:101 0-16..a=rtcp-xr:rcvr-rtt=all voip-metrics..a=sendr
ecv..

Link to comment
Share on other sites

Oh. Did not see the version in the text spaghetti above. It could be that the PBX has to suppress the call quality metric in the SDP to get it working; that was added in some 5.0.x version (many service providers actually have that problem). Maybe install a version 5 (free) on a test host and get the trunk working; then you can copy & paste the setting into the version 4 to see if that solves the problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...