Jump to content

Frozen fxo port & email strangness


russelln
 Share

Recommended Posts

Ok,

 

Other than the 3 errors that I can reproduce at will, (logs posted under hang up detects a ring, posts 14, 15, 16) I have one other problem that happens from time to time (like every 3 to 4 days), the fxo1 port locks into the line off hook state (green light is on and unhooking the cable from the port which should create another CPC pulse does not disconnect it), when this happens only my analog phone will ring on the second line, as line one is off hook, there is no dial tone, you see the fxo2 port flashing on the switch when a call comes in, but the switch does not respond in any way other than the flashing light, I have to do a hard reset (power off and on), and the system starts working again, I have not yet caught a log of this, but will the next time it happens...it is real frustrating, as I lose the CDR report for the day, I have been logging all the call features, so I get everything that transpires during the day, except while the port is locked..therefore you lose the AA also. The phones show to stay registered, but you cannot make any calls, untill resetting the system. Any one else seeing this? :blink: I have not yet figured out how to make this happen.

Also, I keep seeing this in my logs

 

8] 2008/04/12 12:07:35: DNS: Add dns_cname smtp.bizmail.yahoo.com smtp.bizmail.mail.yahoo4.akadns.net (ttl=1800)

[8] 2008/04/12 12:07:35: DNS: Add dns_a smtp.bizmail.mail.yahoo4.akadns.net 68.142.200.11 (ttl=300)

[8] 2008/04/12 12:07:36: SMTP: Connect to 68.142.200.11:25

[8] 2008/04/12 12:07:36: SMTP: Received 220 smtp106.biz.mail.mud.yahoo.com ESMTP

 

[8] 2008/04/12 12:07:36: SMTP: Received 250-smtp106.biz.mail.mud.yahoo.com

250-AUTH LOGIN PLAIN XYMCOOKIE

250-PIPELINING

250 8BITMIME

 

[8] 2008/04/12 12:07:36: SMTP: Received 334 VXNlcm5hbWU6

 

[8] 2008/04/12 12:07:36: SMTP: Received 334 UGFzc3dvcmQ6

 

[3] 2008/04/12 12:07:36: PSTN: Channel 0 going to IDLE

[8] 2008/04/12 12:07:36: SMTP: Received 235 ok, go ahead (#2.0.0)

 

[8] 2008/04/12 12:07:36: SMTP: Received 250 ok

 

[8] 2008/04/12 12:07:37: Last message repeated 2 times

[8] 2008/04/12 12:07:37: SMTP: Received 354 go ahead

 

[8] 2008/04/12 12:07:37: SMTP: Received 250 ok 1208020056 qp 4422

 

[8] 2008/04/12 12:07:37: SMTP: Received 221 smtp106.biz.mail.mud.yahoo.com

 

[8] 2008/04/12 12:07:37: Sucessfully sent email to <russell@thesoundshop-llc.com>

[3] 2008/04/12 12:07:37: SMTP: Cannot resolve smtp.mail.thesoundshop-llc.com

 

I keep seeing this email server(the one above) address in the logs, it is one I tried earlier and then changed to

smtp.bizmail.yahoo.com which works, but nowhere in anyplace in the gui's do I use the other...it is like it is comming from a leftover uncleared data register, that did not change when I changed the email server. Where would you find this in the appliance using the SSH to clear it out...?

 

 

thanks,

 

Russell :mellow:

Link to comment
Share on other sites

You should also update the DSP code since we make some changes. We updated the wiki page yesterday check out section two. cs410 wiki page

 

Hi,

 

pushed new DSP this morning, thanks for the heads up, checked the log this evening and still getting the cannont resolve error...that email server address is still hiding in there somewhere..

 

I will see how it went in the morning, system has not locked yet..

 

is this system available yet in 25 extensions? and when do you think the extended memory ones will be out?

 

all the best,

 

russell :mellow:

Link to comment
Share on other sites

Guest kevin

yes you can updgrade a cs410 to a cs425 by updating the key and paying the difference. We are expecting the units by the end of next month with 1GB of Flash. Kevin

Link to comment
Share on other sites

$ host smtp.mail.thesoundshop-llc.com

Host smtp.mail.thesoundshop-llc.com not found: 3(NXDOMAIN)

 

I am not really clear on this response, as I am not a programming guru... :mellow: I know the domain does not exist, that is why it was changed.

 

this "smtp.mail.thesoundshop-llc.com" is a mail server I address I used originally in the admin software in the CS410, it did not work (wrong guess)

 

email_server.bmp

 

this "smtp.bizmail.yahoo.com" is the mail server address I replaced it with, it works now,

 

I removed this "smtp.mail.thesoundshop-llc.com" and replaced it with this "smtp.bizmail.yahoo.com" (right one after reading POP3 info on my domain server)

 

if I replaced one with the other, why do I keep seeing the first...in the logs?

 

thanks

 

russell :blink:

Link to comment
Share on other sites

Well "host" is the command to find out what DNS would respond to the provided argument (in Linux). What I was trying to say - there is no DNS record...

 

that is what I thought you were saying...except what I am saying is why is it there in first place? I removed it, it should be gone..

 

I was just wondering where it could be hiding in the software..I would like to not see that error..

 

russell :mellow:

Link to comment
Share on other sites

Check the spool directory, there is probably an old email lingering. Just delete the file...

 

 

ah ha,,,thanks...

 

made almost a week without freezing the fxo port and the phones unregistering..crashed about 2:30 this afternoon, I have it logged will peel it out and post if wanted..still have the double line ringing thing happening also...but now it answers on the first line..a second phone will continue to ring..it has to be hooked to make it stop..

 

thanks

 

russell :)

Link to comment
Share on other sites

Check the spool directory, there is probably an old email lingering. Just delete the file...

 

Went to spool directory, there was about 30 emails in there, I guess the one had the others hung...opened the file and changed the email server in the file, saved it and they all dissappeared to the network, was kinda cool seeing them all go through on the log..

 

thanks again,

 

russell :)

Link to comment
Share on other sites

Well I had a few minutes this morning and got the log out and found this error, it's a 0,

 

v=0

o=- 1462283088 1462283088 IN IP4 127.0.0.1

s=-

c=IN IP4 127.0.0.1

t=0 0

m=audio 62252 RTP/AVP 0 101

a=rtpmap:0 pcmu/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

a=ptime:20

a=sendrecv

 

[5] 20080427233651: PSTN: Response code: 200

[0] 20080427233651: PSTN: Exit: VAPI_DisableConnection Failed

 

[5] 20080427233651: PSTN: enable_callerid 0

[9] 20080427233736: SIP Rx tls:192.168.1.101:2143:

SUBSCRIBE sip:40@localhost;user=phone SIP/2.0

Via: SIP/2.0/TLS 192.168.1.101:2048;branch=z9hG4bK-z9kx70z2hq2k;rport

From: <sip:40@localhost>;tag=xn7gpmapdq

 

fxo port is locked up when I get it, I have to hard start the switch to make it go away

sometimes I get two or three of these the same day and sometimes it goes 5 or 6 days before it happens,

 

I have the log of the last month saved I have started a new one..I will try to document how often now and when it happens, as I know now kind of what is going on and where to spot in the log, the log shows a reboot, after I see it, but sometimes, some time transpires before I know it is going on...

 

[8] 20080428131852: Packet authenticated by transport layer

[7] 20080428131852: UDP: Opening socket on port 55280

[7] 20080428131852: UDP: Opening socket on port 55281

[8] 20080428131852: Could not find a trunk (1 trunks)

[9] 20080428131852: Using outbound proxy sip:192.168.1.101:2143;transport=tls because of flow-label

[9] 20080428131852: Last message repeated 2 times

[9] 20080428131852: Resolve 6040: tls 192.168.1.101 2143

[9] 20080428131852: SIP Tx tls:192.168.1.101:2143:

SIP/2.0 100 Trying

 

by the way while this is going on you are just sitting there listening to comfort noise on the phone, and you can sit there all day if you do not know what is going on...

 

Via: SIP/2.0/TLS 192.168.1.101:2048;branch=z9hG4bK-0tjhtw64ufxq;rport=2143

From: "40" <sip:40@localhost>;tag=r0a09ki1al

To: <sip:18008212279@localhost;user=phone>;tag=71c159f893

Call-ID: 3c2a1ad432b6-ydk2soy9mx8v

CSeq: 1 INVITE

Content-Length: 0

 

 

[7] 20080428131852: Set packet length to 20

[6] 20080428131852: Sending RTP for 3c2a1ad432b6-ydk2soy9mx8v#71c159f893 to 192.168.1.101:57652

[1] 20080428132134: Starting up version 3.0.0.2899

[8] 20080428132134: Route: eth0 c0a80100 ffffff00

[8] 20080428132134: Route: eth1 01010100 ffffff00

[8] 20080428132134: Default Route uses 192.168.1.100

[7] 20080428132134: Found time zones AKDT AKST PDT PST MDT MST CDT CST2 EDT EST ADT AST NDT NST BST CET GMT+3 CST CAT IST AUS1 AUS2 AUS3 AUS4 AUS5 AUS6 GMT

[1] 20080428132134: Working Directory is /pbx

 

here I am trying to make a call and now I notice the fxo port is lit up, no call, and I restart the switch..

 

Hope this sheds some light on what is going on..

 

Also still have the 2 lines lighting up when a call comes and it is gotten random as to which button to hit to get the call.

 

All the best

 

Russell ;)

Link to comment
Share on other sites

Guest kevin

I wouldn't worry about the /pbx is the working directory and the can't find a trunk is an [8] so that is not an issue. The disconnect message looks suspect. If you unplug the fxo port from the box does it drop the line then? Any chance to put that scope on the line?

Link to comment
Share on other sites

I wouldn't worry about the /pbx is the working directory and the can't find a trunk is an [8] so that is not an issue. The disconnect message looks suspect. If you unplug the fxo port from the box does it drop the line then? Any chance to put that scope on the line?

 

Hi Kevin,

 

Thank you for the response,

 

the reason I put the "can't find trunk" in was that after the port locks up, you cant find a trunk, it wont even go to the next line which is available...

 

the reason I put in the working directory is that I was trying to show that I have to restart to get it to let loose the port

 

I have tried removing the cable from the box and the line goes on hook in a few seconds and I have a busy tone again, but the fxo light stays on and if you hook it back up the line is off hook again, I paralled a analog phone in front of the appliance and the analog phone is off hook also, when this is going on.

 

Hope this helps, if there is anything you want me to look for I will try..

 

thanks

 

Russell ;)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...