Jump to content
Vodia PBX forum
chrispopp

Incorrect time on phones Snom 720 & 760

Recommended Posts

chrispopp    0

Running a few phones snom760-SIP 8.7.5.35 with version on Vodia 5.2.5a.

 

This is what is generated for the auto-provision:

 

<timezone perm="RW">USA</timezone>^
<utc_offset perm="RW">-18000</utc_offset>^
<dst perm="RW">3600 3.2.7 2:0:0 11.1.7 2:0:0</dst>^
I believe the time zone value is incorrect, as depicted in this page:
In my case, it should be (USA-5)

Share this post


Link to post
Share on other sites
Vodia PBX    0

I don't understand why there would be a "USA". In the timezones.xml file there is a entry for snom:


<zone name="EDT">
<description>Eastern Time Zone</description>
...
<snom>USA-5</snom>
...
</zone>
In theory, it should render the "USA-5" there. Did you change the timezones.xml file or the snom_xxx.xml templates?

Share this post


Link to post
Share on other sites
chrispopp    0

 

I don't understand why there would be a "USA". In the timezones.xml file there is a entry for snom:


<zone name="EDT">
<description>Eastern Time Zone</description>
...
<snom>USA-5</snom>
...
</zone>
In theory, it should render the "USA-5" there. Did you change the timezones.xml file or the snom_xxx.xml templates?

 

No I did not. But seems to be a constant in the pnp xml files....

 

zYl14JaLIUc7MuH7QXJU6z97Anajxx.png

 

This is from the server wide snom_760_phone.xml file... what is the variable that this should be switch to?

 

Edit: The same seems to be in all the other xml files.

 

Edit 2: Checked another old server on version 4.5 and it has the same USA as the value...

Share this post


Link to post
Share on other sites
Vodia PBX    0

The fix was made on Feb 13, 2015 for the snom phones. snom also keeps improving their software, making that change necessary... So if you upgrade to a PBX build after that Feb 13 date, it should be fine.

Share this post


Link to post
Share on other sites
Vodia PBX    0

There are also other fields that determine the current time on the phone, just next to the timezone setting on the phone. What is their value? Do they make sense?

Share this post


Link to post
Share on other sites
Vodia PBX    0

How do I find this folder?

 

It is in the working directory of the PBX, unless you have disabled that feature in the phone provisioning settings on sysadmin level.

Share this post


Link to post
Share on other sites
chrispopp    0

Programmed some Cisco SPA509 and SPA525G and they are also one hour ahead. Used different NTP servers, and on different networks.


<Set_Local_Date__mm_dd_ ua="na"> 

</Set_Local_Date__mm_dd_>
<Set_Local_Time__HH_mm_ ua="na">
</Set_Local_Time__HH_mm_>
<Time_Zone ua="na"> GMT-04:00
</Time_Zone>
<Time_Offset__HH_mm_ ua="na">
</Time_Offset__HH_mm_>
<Daylight_Saving_Time_Rule ua="na"> start=3/2/7/2:0;end=11/1/7/2:0;save=1
</Daylight_Saving_Time_Rule>

Share this post


Link to post
Share on other sites
Vodia PBX    0

 

Programmed some Cisco SPA509 and SPA525G and they are also one hour ahead. Used different NTP servers, and on different networks.

<Set_Local_Date__mm_dd_ ua="na"> 
</Set_Local_Date__mm_dd_>
<Set_Local_Time__HH_mm_ ua="na"> 
</Set_Local_Time__HH_mm_>
<Time_Zone ua="na"> GMT-04:00
</Time_Zone>
<Time_Offset__HH_mm_ ua="na"> 
</Time_Offset__HH_mm_>
<Daylight_Saving_Time_Rule ua="na"> start=3/2/7/2:0;end=11/1/7/2:0;save=1
</Daylight_Saving_Time_Rule>

 

Are you sure that you have the right timezone for the domain and extension? The GMT-04:00 is generated for the Atlantic Time Zone.

Share this post


Link to post
Share on other sites
chrispopp    0

Fixed it on the Cisco, but the Snom's are still picking up the incorrect time. They boot up, pick up the right time. After the refresh (one hour), they go one hour ahead. Any fixes for this? The log and the SIP trace both show the incorrect time. Changed the NTP server, didn't help. Changed the DNS, also didn't help. The time on the server and PBX is showing the correct time.

Share this post


Link to post
Share on other sites
Vodia PBX    0

How can we make sure this is not a bug on the snom phones? If they have the right time after the boot up, well that cannot be a coincidence. How do you refresh? Sync the extension from the PBX web interface?

Share this post


Link to post
Share on other sites
chrispopp    0

How can we make sure this is not a bug on the snom phones? If they have the right time after the boot up, well that cannot be a coincidence. How do you refresh? Sync the extension from the PBX web interface?

I was looking at this:

NTdijXBKsAWGKaULAakTqAXKgJ67px.png

 

 

Currently playing around with the DHCP option 42.

 

This is a screenshot of my Snom 720. Moved the option 42 from ON to OFF.

 

wLqPa8nraQiC4gsNysBVVcB1b6DWGB.png

 

Whereas the Snom 370 has only these settings.

Wlp6gMKSKQwpaoIyeIs83h707s4Udq.png

 

 

I rebooted the phone and awaiting to see if this fixes the issue. Waiting for the NTP timer. Also considering issues with DST... I just can't find any settings relating to DST on these phones. The problem happened since the DST change here in Canada...

Share this post


Link to post
Share on other sites
Vodia PBX    0

DST should change next Sunday if I am correct... Maybe the problem is related to that because the phones have a week off? Although that would not explain why it is correct after starting up.

Share this post


Link to post
Share on other sites
chrispopp    0

Mar 8 14:45:08 [ERROR ] PHN: TPL: Socket Error: 317/50/connected, Tls error, closing
Mar 8 14:45:08 [NOTICE] CFG: read_xml_settings: found firmware-settings XML header
Mar 8 14:45:08 [NOTICE] CFG: read_xml_settings: found one byte encoding: 1
Mar 8 15:45:09 [NOTICE] PHN: DST start 03.02.2016 02:00:00 end 06.11.2016 02:00:00 offset 3600
Mar 8 15:45:09 [NOTICE] CFG: Std-Settings stored
Mar 8 15:47:07 [NOTICE] PHN: Executing timer driven automatic settings refresh
Mar 8 15:47:07 [NOTICE] PHN: Setting automatic settings refresh timer with 120 seconds
Mar 8 15:47:07 [NOTICE] PHN: Setting server prio 1, type redirection, url: >
Mar 8 15:47:07 [NOTICE] PHN: Fetching URL:
Mar 8 15:47:07 [NOTICE] CFG: read_xml_settings: found setting-files XML header
Mar 8 15:47:07 [NOTICE] CFG: read_xml_settings: found one byte encoding: 1

 

So it seems the DST is causing the issues. As you can see, as soon as the DST starts, it ruins the time and jumps it ahead an hour. Any ideas?

 

The DHCP option 42 did not help...

Share this post


Link to post
Share on other sites
Vodia PBX    0

Trying to understand how to read that date, but it seems this is really February 3rd (because November 6 is obviously the end date).

 

This is what is in there for EDT:

  <zone name="EDT">
    <description>Eastern Time Zone</description>
    <gmt_offset>-18000</gmt_offset>
    <dst_offset>3600</dst_offset>
    <dst_start_day_of_week>1</dst_start_day_of_week>
    <dst_start_month>3</dst_start_month>
    <dst_start_time>02:00</dst_start_time>
    <dst_start_week_of_month>2</dst_start_week_of_month>
    <dst_stop_day_of_week>1</dst_stop_day_of_week>
    <dst_stop_month>11</dst_stop_month>
    <dst_stop_time>02:00</dst_stop_time>
    <dst_stop_week_of_month>1</dst_stop_week_of_month>
    <ampm>12</ampm>
    <snom>USA-5</snom>
    <yealink>United States-Eastern Time</yealink>
    <grandstream>EST5EDT</grandstream>
  </zone>

What do you see in the "generated" folder for that phone? The time zone entry clearly shows March, it is hard to imagine that this changes to February somehow.

Share this post


Link to post
Share on other sites
Vodia PBX    0

I actually just checked with a phone over here:

  <utc_offset perm="RW">-18000</utc_offset>
  <dst perm="RW">3600 3.2.7 2:0:0 11.1.7 2:0:0</dst>

That looks like it should, at least as far as I understand those numbers.

Share this post


Link to post
Share on other sites
Vodia PBX    0

CAN-5? Did you add that yourself? I am not aware about that value in the time zones file. The dst settings look ok to me, but maybe the zone is confusing the phone.

Share this post


Link to post
Share on other sites
chrispopp    0

CAN-5? Did you add that yourself? I am not aware about that value in the time zones file. The dst settings look ok to me, but maybe the zone is confusing the phone.

 

I did add that to the config file. That seems to be the correct value.

 

Without adding the CAN-5, the timezone is simply USA and the value on the phone is the following:

LOYbJM7ZZUuEZu5sfn1Z8r7cKOgFFd.png

 

Adding CAN-5 gives you the following:

QvzIisOTRINXFtxS9xoirbaIM30mW1.png.

 

The automated generated file by Vodia seems to have an incorrect value, thus defaulting to Unused. See Snom wiki.

http://wiki.snom.com/wiki/index.php/Settings/timezone

 

At least that's what I understood from reading and dealing with this issue for the last month.

Share this post


Link to post
Share on other sites
Vodia PBX    0

Ehh ja the problem is that there are two conflicting entries in the phone. The CAN-5 is using an internal table from the phone (built-in and hard coded with the firmware), while the PBX provisions a rule that is independent from the firmware. Any reason why you don't use the one automatically generated from the PBX? Is CAN-5 different from the East Coast US time?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×