Jump to content
Vodia PBX forum
Sign in to follow this  
tobymac

Snom 821 transfer issue

Recommended Posts

tobymac    0

Hello

Here is the scenario. Caller A calls caller B and asks to be transferred to caller C. When caller B wants to transfer A to C he receives another call from caller D. So if caller B doesn't pay attention the last call that he received (is this case from caller D) becomes the active one. So instead of transferring caller A he will transfer caller D to C. Is there any option so caller A remains the last one? We looked at the wiki and normally the oldest call is the one being transferred by default and in our case it's the latest.
Thank you!
Kind regards

This is my problem which I've posted also on the SNOM forum.

Here are the replies:

1.You may wish to check your setting "always_show_active_call"

2.This feature is somewhat new, so it is advised to ensure the phone is on the latest firmware and has been 'reset' to factory defaults to ensure the values of the former setting configuration do not reside in the phone after update.

Thanks for your reply. I did a factory reset on all our phones last week but didn't test this yet. So probably this has been the issue.

Thanks again!

Best regards,

I've tested but no luck. Still the same issue. Where do I need to specify the syntax? In SnomOne/ Customise/ Templates/ Phone PNP / snom_820_phone.xml ?

I added this syntax: <always_show_active_call perm="PERMISSIONFLAG">on</always_show_active_call>

Is this ok?

Thanks!

Best regards,

3.The setting can be set in the provisioning file.

Or send an HTTP GET to the phone manually:

http:// <PhoneIP> /dummy.htm?settings=save&always_show_active_call=on

However, please note that this setting is in the latest firmware version, as specified in the wiki link.

Yes I've read that. But is strange though. I'll try to send the HTTP GET.

Thanks!

I've sent the HTTP GET but still not working. Any other solution?

Thanks!

Kind regards

4.This may be do to a Button Profile with the Snom ONE and it might be suggested to extend this inquiry to the http://forum.snomone.com threads.

I cannot reproduce the issue with my snom, yet I am not using the Button Profiles or PnP feature on our Snom ONE.

 

 

So I need your help now.

Thanks!

 

Best regards

Share this post


Link to post
Share on other sites

This is a phone issue 1st of all. Perhaps the phone does not retain it's logic when multiple calls are advertised on the phone while transferring a call.

 

Try adding the syntax again only things missing was the RW under the perm= reboot the phone after you make the change in the 8xx template.

<always_show_active_call perm="RW">on</always_show_active_call>

 

 

http://wiki.snom.com/Settings/always_show_active_call

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×