Jump to content

Outbound Caller ID


jlumby
 Share

Recommended Posts

I am attempting to use a calling card as a way to hide my cell phone caller ID, and send my office phone's caller ID. I am running 3.0.0.2976 (Win32) and am using your ANI fields to send caller ID to my ITSP. I find that nomatter what is filled in the trunk's account field, or in the ANI field, the calling card displays my cellphone's caller ID to whomever I am calling.

Link to comment
Share on other sites

I am attempting to use a calling card as a way to hide my cell phone caller ID, and send my office phone's caller ID. I am running 3.0.0.2976 (Win32) and am using your ANI fields to send caller ID to my ITSP. I find that nomatter what is filled in the trunk's account field, or in the ANI field, the calling card displays my cellphone's caller ID to whomever I am calling.

 

Hmm, yea that ANI field might have no meaning in the calling-card... At least in the way you are using it (SOAP might look different). Did you try to make an anonymous call? There is a flag for that.

Link to comment
Share on other sites

Switching the caller ID to Block on the calling card account had no effect.

 

Eh, you are right. Once that you punch in your extension number, the PBX will start the call from that extension. If that extension has caller-ID blocked, it will be blocked. But it would be better if the caller-ID can be surpressed by the calling-card account, makes sense to me.

Link to comment
Share on other sites

  • 1 month later...
I wish it was taking my extension number, and sending it. It is sending my cell phone number.

 

Okay, just another idea. When you call from your cell to an auto attendant, and that number is in your extension, then the PBX gives you the option to call out. In that case IMHO it would use the extension caller-ID. Maybe that solves the problem?

Link to comment
Share on other sites

Okay, just another idea. When you call from your cell to an auto attendant, and that number is in your extension, then the PBX gives you the option to call out. In that case IMHO it would use the extension caller-ID. Maybe that solves the problem?

 

It exibits the same problem as the calling card, where it sends my cell phone number as caller ID. I feel like it may be a bug in your implimentation of ANI with respect to the calling card service, since that is the method I am using to send my caller ID, and I doubt many other people are using both ani, and calling card together.

Link to comment
Share on other sites

It exibits the same problem as the calling card, where it sends my cell phone number as caller ID. I feel like it may be a bug in your implimentation of ANI with respect to the calling card service, since that is the method I am using to send my caller ID, and I doubt many other people are using both ani, and calling card together.

 

Okay, that would be a bug then. Needs to be fixed.

Link to comment
Share on other sites

  • 2 weeks later...
  • 7 months later...
  • 5 weeks later...
I think so. Tested with 3.3.1.3177 and it worked as expected.

 

I'm running 3.3.1.3177 and I can't get it to display they office phone number. Still shows my cell number...

 

On the calling card account, I have ANI set to my trunk. I've tried both Caller-ID Show and Block. My cell is displayed regardless.

 

Any thoughts?

Link to comment
Share on other sites

  • 1 year later...
I think so. Tested with 3.3.1.3177 and it worked as expected.

 

I am running Version: 3.4.0.3202 (Win32) and i still have this issue.

 

basically when the client calls in and it authenticates his cell with extension what is happening is it is using the same caller ID that is setup on his extension instead of using the dial plan that the calling card account has set!

 

please advise asap.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...