Jump to content

SMTP Mail Sending


andrewgroup
 Share

Recommended Posts

An installation is having troubles using the ISP mail server to send mail. This is a Nuvox Communications T1, with PSTN T1 data services. Nuvox offers a on-net SMTP server to send mail. SMTP.NUVOX.NET that accepts and relays mail from all On-Net Hosts. We have Nuvox on many clients and regularly us this mail server, (LINUX SENDMAIL) to smarthost exhange servers and to send management alerts from many devices.

 

The CS410 reports the following in the logs.

[6] 2008/08/26 18:00:04: Sending CDR email to <me@mydomain.com>

[8] 2008/08/26 18:00:08: SMTP: Connect to 70.43.63.17:25

[8] 2008/08/26 18:00:08: SMTP: Received 220 smtp02.atlngahp.sys.nuvox.net ESMTP Tue, 26 Aug 2008 18:00:07 -0400

[8] 2008/08/26 18:00:08: SMTP: Received 250-smtp02.atlngahp.sys.nuvox.net Hello 74.223.YYY.XXX.nw.nuvox.net [74.223.YYY.XXX], pleased to meet you

250-ENHANCEDSTATUSCODES

250-PIPELINING

250-8BITMIME

250-SIZE 52428800

250-DSN

250-ETRN

250-STARTTLS

250-DELIVERBY

250 HELP

[8] 2008/08/26 18:00:08: SMTP: Received 220 2.0.0 Ready to start TLS

[8] 2008/08/26 18:00:09: SMTP: Received

[8] 2008/08/26 18:00:09: Last message repeated 2 times

[5] 2008/08/26 18:00:09: SMTP: Connection refused on 70.43.63.17:25

 

The technical support group at Nuvox report the error message from the server is

Here is the error I see in the mail logs: did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA

 

Has something changed with the mail send tools, we have this on numerous ISP's an relay from On-Net Mail Servers.

 

A commercial SMTP tester on this same IP address works fine.

 

Has a new options been slipstreamed into release 2993 release?

Link to comment
Share on other sites

Has a new options been slipstreamed into release 2993 release?

 

We have added STARTTLS, which is probably causing the problem. It works with google, but that seems to be only half the battle. We have another case where it does not work, but maybe you can also send me (PM) a test account for that server and we can test it from the lab.

Link to comment
Share on other sites

  • 2 weeks later...
We have added STARTTLS, which is probably causing the problem. It works with google, but that seems to be only half the battle. We have another case where it does not work, but maybe you can also send me (PM) a test account for that server and we can test it from the lab.

 

Still trying to figure out how I can provide a VPN link to a location using the ISP in question. I'd rather not test on a live system.

Link to comment
Share on other sites

I think I am experiencing the same problem with some newer releases of PBXnSIP The following is what my mail server logs

 

Tue 2008-09-09 14:32:40: Accepting SMTP connection from [75.146.173.69:1303]

Tue 2008-09-09 14:32:40: --> 220-twincitytelephone.com ESMTP MDaemon 9.6.6; Tue, 09 Sep 2008 14:32:40 -0500

Tue 2008-09-09 14:32:40: --> 220-You are connecting to the Twin City Telephone Mail Server

Tue 2008-09-09 14:32:40: --> 220 Unauthorized use is prohibited!!!

Tue 2008-09-09 14:32:40: <-- EHLO localhost

Tue 2008-09-09 14:32:40: --> 250-twincitytelephone.com Hello localhost, pleased to meet you

Tue 2008-09-09 14:32:40: --> 250-ETRN

Tue 2008-09-09 14:32:40: --> 250-AUTH=LOGIN

Tue 2008-09-09 14:32:40: --> 250-AUTH LOGIN CRAM-MD5

Tue 2008-09-09 14:32:40: --> 250-8BITMIME

Tue 2008-09-09 14:32:40: --> 250-STARTTLS

Tue 2008-09-09 14:32:40: --> 250 SIZE 0

Tue 2008-09-09 14:32:41: <-- STARTTLS

Tue 2008-09-09 14:32:41: --> 220 Begin TLS negotiation

Tue 2008-09-09 14:32:41: SSL negotiation successful (TLS 1.0, 1024 bit key exchange, 128 bit RC4 encryption)

Tue 2008-09-09 14:32:41: <-- EHLO localhost

Tue 2008-09-09 14:32:41: --> 250-twincitytelephone.com Hello localhost, pleased to meet you

Tue 2008-09-09 14:32:41: --> 250-ETRN

Tue 2008-09-09 14:32:41: --> 250-AUTH=LOGIN

Tue 2008-09-09 14:32:41: --> 250-AUTH LOGIN CRAM-MD5

Tue 2008-09-09 14:32:41: --> 250-8BITMIME

Tue 2008-09-09 14:32:41: --> 250 SIZE 0

Tue 2008-09-09 14:32:41: <-- MAIL FROM: <PBXnSIP@twincitytelephone.com>

Tue 2008-09-09 14:32:41: Performing SPF lookup (twincitytelephone.com / 75.146.173.69)

Tue 2008-09-09 14:32:41: * twincitytelephone.com 75.146.173.69; matched to SPF cache

Tue 2008-09-09 14:32:41: * Result: softfail

Tue 2008-09-09 14:32:41: ---- End SPF results

Tue 2008-09-09 14:32:41: --> 250 <PBXnSIP@twincitytelephone.com>, Sender ok

Tue 2008-09-09 14:32:41: <-- RCPT TO: <jlumby@twincitytelephone.com>

Tue 2008-09-09 14:32:41: --> 530 Authentication required

Tue 2008-09-09 14:32:41: Connection closed

Tue 2008-09-09 14:32:41: SMTP session terminated (Bytes in/out: 440/1631)

 

I am sure the password is correct. If you are still interested in testing through someone else's email system, I would be happy to send the email account logon info to you via PM. Just send me a PM if you are interested

Link to comment
Share on other sites

I am having the same problem.

 

[1] 2008/09/12 15:31:20: No TLS session key in Server Hello Done

[5] 2008/09/12 15:31:20: SMTP: Connection refused on 192.168.192.6:25

 

It seems that TLS is tried automatically - we don't need it.

 

How can we disable that?

 

There is a setting called "smtp_starttls" (see http://wiki.pbxnsip.com/index.php/Global_Configuration_File on how to set it). If it is "false" the PBX does not try TLS. That might require a newer version, at least 3.0.1. Let me now what OS you need and we'll get you a link.

Link to comment
Share on other sites

  • 3 weeks later...
We have added STARTTLS, which is probably causing the problem. It works with google, but that seems to be only half the battle. We have another case where it does not work, but maybe you can also send me (PM) a test account for that server and we can test it from the lab.

 

 

hi there i am using google apps mail service to send all mails with pbxnsip.

 

most of the part this works pretty well. but sometimes its stuck in a loop where it repots in the logs that the connection got refused but the mail was sent. so i end up getting hundres of messages ;(

 

platform: mac os x 10.5.5

Version: 3.0.0.2998 (Darwin)

smtp server config in domain: smtp.gmail.com:587

 

log:

[8] 20080929140103: SMTP: Connect to 74.125.93.109:587

[8] 20080929140103: SMTP: Received 220 mx.google.com ESMTP 6sm218032qwk.1

 

[8] 20080929140103: SMTP: Received 250-mx.google.com at your service, [pbxip]

250-SIZE 35651584

250-8BITMIME

250-STARTTLS

250 ENHANCEDSTATUSCODES

 

[8] 20080929140103: SMTP: Received 220 2.0.0 Ready to start TLS

 

[8] 20080929140103: SMTP: Received

[8] 20080929140103: Last message repeated 2 times

[8] 20080929140103: SMTP: Received 334 VXNlcm5hbWU6

 

[8] 20080929140103: SMTP: Received 334 UGFzc3dvcmQ6

 

[8] 20080929140104: SMTP: Received 235 2.7.0 Accepted

 

[8] 20080929140104: SMTP: Received 250 2.1.0 OK 6sm218032qwk.1

 

[8] 20080929140104: SMTP: Received 250 2.1.5 OK 6sm218032qwk.1

 

[8] 20080929140104: SMTP: Received 354 Go ahead 6sm218032qwk.1

 

[8] 20080929140105: SMTP: Received 250 2.0.0 OK 1222711265 6sm218032qwk.1

 

[5] 20080929140105: SMTP: Connection refused on 74.125.93.109:587

Link to comment
Share on other sites

hi there i am using google apps mail service to send all mails with pbxnsip.

 

most of the part this works pretty well. but sometimes its stuck in a loop where it repots in the logs that the connection got refused but the mail was sent. so i end up getting hundres of messages ;(

 

platform: mac os x 10.5.5

Version: 3.0.0.2998 (Darwin)

smtp server config in domain: smtp.gmail.com:587

 

Yea, we found that one already. The workaround for time being is to use another email server. Not sure if we have a MacOS build ready right now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...