Jump to content

license activation after hardware switch (snomone mini to raspberry pi 2)


gifti
 Share

Recommended Posts

Hello,

 

I've tried to upgrade my snomone mini (default system) from 5.1.1 to 5.4.1 via xml update link.

http://vodia.com/downloads/pbx/version-5.4.1.xml

 

Now the mini isn't booting up. Reset button don't helps. Hardware is useless :-( ...

 

So I decided to switch my vodia S20 license to a raspberry pi 2.

Here are the steps that I've made:

  • installed raspberian (4.1 kernel) on raspberry pi 2
  • network and internet connection are still working
  • installed the pbx with the script install-mini3.sh
  • activated a S5 License (no problems)
  • reseted my old License (1 Reset left Button)
  • tried to activate the Licencse but nothing happend ...

 

What did I do wrong?

 

 

Link to comment
Share on other sites

If you have shell access, try to start the pbx with ./pbxctrl --version to see if the executable has the right format. Then make sure that there is a pbxctrl.dat file in the same directory and not empty. Then the executable should start up and you should be able to log in.

 

The license topic is independent from the executable topic. The "mini" licenses are different than the standard CPE licenses because they are bound to the specific MAC address of the device and cannot be changed. This is why the mini were cheaper than the standard licenses, even though they included the hardware. The other topic is the upgrade availability; for that the easiest is to check https://vodia.com/en/mplan which shows you to which version you can upgrade.

Link to comment
Share on other sites

The "mini" hardware is useless. No network, no shell access, hardware reset button don't work (maybe my fault).

But, is there any chance to save the license? You said, there is not a 1 x reset option, because of the mini pricing modell.

This should be displayed on the license management website!!!

 

However, it’s the second mini that I switched to other hardware.

Our production (...-VZS) system pbx2 was a mini before an is now running successfully on a CentOS VM host.

 

post-27088-0-68023700-1461671599_thumb.png

Link to comment
Share on other sites

Well the mini is at the end of a day using hardware originally designed for DVD players, TV and other home entertainment devices as far as I can tell. Although that still does not explain why it became unavailable. DVD end of life is typically because of mechanical failure. You could have a device that just broke down; considering that it became completely unresponsive is a sign that the hardware might have failed. What you could also double check if the power supply is still ok; when it come to hardware failures that is a typical problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...