Jump to content

Having hell getting Strato working


asterisk_nicht_mehr
 Share

Recommended Posts

Hello

 

I am having a lot of problems getting Strato as an ISP for VOIP telephoning to work.

 

[1] 2008/10/18 23:35:32: Last message repeated 4 times

[7] 2008/10/18 23:35:32: Set packet length to 20

[6] 2008/10/18 23:35:32: Sending RTP for 3c284de6d6f9-ocqyjai495w8#bf058bb268 to 192.168.1.106:60634

[5] 2008/10/18 23:35:32: Dialplan Standard Dialplan: Match 08213240@192.168.1.2 to <sip:08213240@strato-iphone.de;user=phone> on trunk Strato 3

[7] 2008/10/18 23:35:32: Set packet length to 20

[7] 2008/10/18 23:35:32: Call c3db4152@pbx#31941: Clear last INVITE

[5] 2008/10/18 23:35:32: INVITE Response: Terminate c3db4152@pbx

[7] 2008/10/18 23:35:32: Other Ports: 1

[7] 2008/10/18 23:35:32: Call Port: 3c284de6d6f9-ocqyjai495w8#bf058bb268

 

The Registration works but the handshake falls off. Because of the consolidation of the market here, it is just about impossible to get a tech on the ISP provider side who can understand this issue: Hotlines do not cut it. Everything is set up according to the pbxnsip standard.

 

I am beginning to think that the ISP Strato is having problems with the packet length. I also opened the Ports from the pbxnsip server I have. The carrier has a different set of values for some of their required port openings, but they also sell another Modem that acts as a Pbx (AVM Fritzbox) as standard for hooking up to their service.

 

I am at a standstill over how to troubleshoot this. Does anyone have suggestions?

 

Deutschesfach

Link to comment
Share on other sites

I am having a lot of problems getting Strato as an ISP for VOIP telephoning to work.

 

[1] 2008/10/18 23:35:32: Last message repeated 4 times

[7] 2008/10/18 23:35:32: Set packet length to 20

[6] 2008/10/18 23:35:32: Sending RTP for 3c284de6d6f9-ocqyjai495w8#bf058bb268 to 192.168.1.106:60634

[5] 2008/10/18 23:35:32: Dialplan Standard Dialplan: Match 08213240@192.168.1.2 to <sip:08213240@strato-iphone.de;user=phone> on trunk Strato 3

[7] 2008/10/18 23:35:32: Set packet length to 20

[7] 2008/10/18 23:35:32: Call c3db4152@pbx#31941: Clear last INVITE

[5] 2008/10/18 23:35:32: INVITE Response: Terminate c3db4152@pbx

[7] 2008/10/18 23:35:32: Other Ports: 1

[7] 2008/10/18 23:35:32: Call Port: 3c284de6d6f9-ocqyjai495w8#bf058bb268

 

The Registration works but the handshake falls off. Because of the consolidation of the market here, it is just about impossible to get a tech on the ISP provider side who can understand this issue: Hotlines do not cut it. Everything is set up according to the pbxnsip standard.

 

I am beginning to think that the ISP Strato is having problems with the packet length. I also opened the Ports from the pbxnsip server I have. The carrier has a different set of values for some of their required port openings, but they also sell another Modem that acts as a Pbx (AVM Fritzbox) as standard for hooking up to their service.

 

I am at a standstill over how to troubleshoot this. Does anyone have suggestions?

 

Well strato does not use a session border controller. That is making life difficult. For outbound traffic, you can set the registration time to 30 seconds to keep the NAT bilding alive.

 

The other problem is that for calls to the PBX the SER sends a UDP packet that exceeds the UDP fragmentation size. The below packet is bigger than 1600 bytes, which will be rejected by most cheap routers.

 

[7] 2008/10/19 15:47:57: SIP Rx udp:194.97.40.217:5060: 
INVITE sip:TESTACC@172.23.0.118:5060;transport=udp;line=c4ca4238 SIP/2.0
Record-Route: <sip:194.97.40.217;ftag=3srTHM2ah20004jR0B0Pu003qjW0wKjuX;lr=on>
Record-Route: <sip:194.97.96.19;ftag=3srTHM2ah20004jR0B0Pu003qjW0wKjuX;lr=on>
Record-Route: <sip:194.97.40.217;ftag=3srTHM2ah20004jR0B0Pu003qjW0wKjuX;lr=on>
Via: SIP/2.0/UDP 194.97.54.97;branch=z9hG4bKc916.8304ded2.1;recvip=194.97.40.217
Via: SIP/2.0/UDP 194.97.96.19;branch=z9hG4bKc916.8304ded2.1;recvip=194.97.96.19
Via: SIP/2.0/UDP 194.97.54.97;received=194.97.40.217;branch=z9hG4bK000423D4EB2601AB1EB5D8B227AE;r
ecvip=194.97.40.217
Via: SIP/2.0/UDP 194.97.45.169:5060;branch=z9hG4bK000423D4EB2601AB1EB5D8B227AE
From: <sip:0019787462777@strato-iphone.de;user=phone>;tag=3srTHM2ah20004jR0B0Pu003qjW0wKjuX
To: <sip:004921616371234@strato-iphone.de;user=phone>
Call-ID: 000423D4EB2601AB1EB58F5060F3@194.97.45.169
CSeq: 17404 INVITE
Contact: <sip:0019787462777@194.97.45.169:5060>
Allow-Events: refer
Max-Forwards: 14
Allow: INVITE, ACK, BYE, CANCEL, OPTIONS, PRACK, INFO, REFER, NOTIFY, SUBSCRIBE, UPDATE
Content-Type: application/sdp
Supported: 100rel, timer, replaces
User-Agent: TELES.MGC
Content-Length: 368
P-Trusted: yes

v=0
o=- 1721261723 0 IN IP4 194.97.100.170
s=session
c=IN IP4 194.97.100.170
t=0 0
m=audio 30200 RTP/AVP 8 0 18 18 2 36 4 80 101
a=rtpmap:8 PCMA/8000
a=rtpmap:0 PCMU/8000
a=rtpmap:18 G729/8000
a=rtpmap:18 G729/8000
a=rtpmap:2 G726-32/8000
a=rtpmap:36 G726-24/8000
a=rtpmap:4 G723/8000
a=rtpmap:80 G723/8000
a=rtpmap:101 telephone-event/8000
a=sendrecv

 

I am afraid if your NAT router does not support UDP fragmentation you will have no chance to get it working. Even other dirty "tricks" like STUN will not solve this problem.

 

Maybe someone can give ACME packet, Newport Networks or NexTone a tip there is a good customer waiting for them. Just installing a free SIP proxy does not make you a carrier...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...