Jump to content

App Jitter buffer?


Recommended Posts

Any one know if the app has a jitter buffer like a desk phone?

I don't recall the app being so bad, but I am trying to use it more and notice its very susceptible to getting audio glitches all most like its running with 0 buffer, and I cant find any obvious network problems. 

I don't get the same when using Bria Enterprise. What else could I look at to tune it more?

Generally the PCAP's look clean but the experience heard (inbound) at the app says otherwise. It sounds like I should see bad PCAPS but I don't and feel its happening at the app level.  

My network is rock solid and wifi on or off still the same. Bria is fine, using the user portal is fine, just the mobile app.  ¯\_(ツ)_/¯

I have a group setup that just plays MOH which is an an audio book and sit in there to hear the book, I do have external DID's on it as well for external testing but its on all levels. 

1.22 (65)

Link to comment
Share on other sites

Yes there is a jitter buffer. 

Most of the quality issues are because G711 sounds very bad when there is packet loss. In environments where there is no packet loss, G711 sounds best, simple because transcoding can never make audio sound better (unless there is some AI magic at play). But if there is packet loss, OPUS behaves dramatically better. So in a nutshell, if you have packet loss on the app, set the extension to OPUS. 

Link to comment
Share on other sites

I will give OPUS an experiment I have not spent any time with it yet. Like I said the network is good, should be no packet loss, and PCAP's look clean. 

I usually find the issue is at the start at call setup the first 2 seconds then its fine. Both sides normally hear glitchy bad audio then goes good. I some times hold off saying hello for a second as I know its better that way or I get the comment 'this sounds like a bad line' ... lol.

Maybe play more ring back locally to allow better establishment ? 

This also happens dialling into a attendant playing an audio book, so eliminating any carrier issue, 3 hops to pbx sub 5ms, zero loss. 

Maybe its a TLS thing 


Link to comment
Share on other sites

  • 3 weeks later...

I tired OPUS only and still the same the first few seconds of connected call on the app are broken / jittered then smooths out, every time. 711A/U or Opus.  Wi-Fi or LTE same.  Bria Enterprise seems to be fine with the same tests.

Confirmed with pcap that OPUS was being used. 

Link to comment
Share on other sites

6 hours ago, Vodia PBX said:

It might be because Bria does not use DTLS (SDES), in other words not end-to-end encrypted. You can see the keys in the SIP messages with SDES, which is becoming kind-of not-okay.

Apparently, they just updated something with Bria iOS and now TLS is broken and wont register with the PBX.

Apparently, something to do with this , RFC 5746 - Transport Layer Security (TLS) Renegotiation Indication Extension (ietf.org)



Link to comment
Share on other sites

In my messing around with Yealink and TLS and SRTP I have now reverted the system back from native TLS mode to TCP as whats the point if I cant encrypt all the streams, as I cant advertise as so.

Any way since going back to system level native TCP mode I noticed the app does not suffer the glitches in the initial call establishment. ¯\_(ツ)_/¯

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...