Jump to content

Grandstream BLF Issue


kcnd
 Share

Recommended Posts

We using Grandstream GXP-2000, GXP-2010 and GXP-2020 sip phones (with latest firmware version 1.1.6.46) with pbxnsip version 3.3.1.3177 and have them configured to use BLF keys. The pbxnsip extension setting for monitoring other extensions is set to * so it monitors all (never had to set this in pbxnsip version 2). The phones register with pbxnsip and also register the dialog entries for each BLF key fine. The BLF lamps will flash red when a monitored phone is calling and will change to solid red when in a call. However, the BLF lights will never change to green when the call ends. In fact, the BLF lamps will not light green even when the phone is first rebooted and we wait to see if the dialog registration picks up the status of idle extensions. Note that the phone BLF lamps work fine when connected to a Grandstream PBX appliance and the phones diagnostic test show all BLF lamps are good. Also, these same phones worked fine with pbxnsip version 2 software.

 

I'm aware that the BLF process in version 3 was changed, but apparently this change is not compatible or has some issue with GXP phones. IS there some way you can test the GXP phones with the latest pbxnsip software and figure out how to get the BLF lights working again? I've been unsuccessful at trying many different configuration options with the phones and pbxnsip. Is there some configuration that needs to be specifically set now for BLF to work with GXP phones?

 

Thanks!

Link to comment
Share on other sites

  • 2 weeks later...

After doing more testing it appears there is an error in the "Watch calls..." feature of the pbxnsip. The Grandstream phones, configured properly for BLF, work fine, however, pbxnsip does not set the BLF properly. To get any BLF to work, the pbxnsip web interface option of "Watch the calls of the following extensions (* for all):" must be set with something entered in it. Then the phones will register the dialog entries for each BLF, but the phones are receiving only the "off-hook" and "in-call" status - they do not receive the "on-hook" (green) status. The "Watch calls" field can contain an "*", a valid extension or an invalid extension like 999 that is not setup in the system to trigger the dialog registrations for all BLF keys set on the phone. Even if the "Watch calls" field is set to only one extension, the phone will register all dialogs and all BLF indicators will act as described above.

 

In version 2, the "Watch call" field defaulted to all extensions, so no special setup was required for the extension to handle BLF. If the phone was configure properly for BLF, it would work. Based on all I've seen, something is not working properly with the "Watch call" code in pbxnsip.

 

Can something be done to fix this? Our users are getting quite frustrated as this has been an issue for 4 months since we changed from version 2 to version 3.

 

Thanks for your help!

Link to comment
Share on other sites

After doing more testing it appears there is an error in the "Watch calls..." feature of the pbxnsip. The Grandstream phones, configured properly for BLF, work fine, however, pbxnsip does not set the BLF properly. To get any BLF to work, the pbxnsip web interface option of "Watch the calls of the following extensions (* for all):" must be set with something entered in it. Then the phones will register the dialog entries for each BLF, but the phones are receiving only the "off-hook" and "in-call" status - they do not receive the "on-hook" (green) status. The "Watch calls" field can contain an "*", a valid extension or an invalid extension like 999 that is not setup in the system to trigger the dialog registrations for all BLF keys set on the phone. Even if the "Watch calls" field is set to only one extension, the phone will register all dialogs and all BLF indicators will act as described above.

 

In version 2, the "Watch call" field defaulted to all extensions, so no special setup was required for the extension to handle BLF. If the phone was configure properly for BLF, it would work. Based on all I've seen, something is not working properly with the "Watch call" code in pbxnsip.

 

Can something be done to fix this? Our users are getting quite frustrated as this has been an issue for 4 months since we changed from version 2 to version 3.

 

The watch call setting only affects the provisioning and maybe the permissions (is employee A allowed to see the calls of employee B). If you set the BLF up manually on the phone, then that field does not play a role.

 

IMHO BLF is only good for "on" (connected) and "off" (not connected). As the name suggest, it is a "busy lamp"; you are busy (talking) or not. SIP phones do not tell the PBX when they go offhook. Therefore there is little hope that we can emulate that feature of the good old telecom system with dialog state.

 

The problem with dialog-state is that it does not have a "off-hook" state; and even states like alerting are "debatable" (no clear standard for this). That is why we promote the "buttons" document - it clearly and simply says that the PBX wants to turn a button on, and there is no complex XML scheme that needs to be discussed by IETF gurus.

Link to comment
Share on other sites

  • 2 weeks later...

UPDATE: For those who may need to setup BLF on Grandstream phones (f/w version 1.1.6.46) with pbxnsip version 3 software, these settings will work properly:

1) In pbxnsip on the extensions general tab, set the "watch calls for these extensions..." to "*" (an asterik) - this is required to "turn on" dialogs - without this, dialogs will not register.

2) On the Grandstream phone under the account tab, enter the account's extension in the "eventlist BLF URI" field - do not enter the domain, just the extension used in pbxnsip for that account

3) On the Grandstream phone under the basic tab, for each key to setup select "eventlist BLF" for the type and enter the extension along with the account from #1 above

This will cause a single dialog registration to record in pbxnsip for the BLF eventlist extension number and the BLF keys will light correctly.

 

This took quite a long time to figure out since version 2 of pbxnsip worked with Grandstream phones by simply selecting the normal BLF selection on the Grandstream phone (no changes were required in pbxnsip, and each BLF key would register a dialog in pbxnsip. Version 3 has somehow changed this so only the eventlist scenario will work. When trying the standard BLF selection, the "dialing" and "in-call" status would display but the key would never reset to "idle".

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...