Jump to content

Service Flag Day/Night not working


Leonmeijer
 Share

Recommended Posts

Hello,

 

I verified that the Time zone is set correctly and the PBX is showing the right time in the logfiles.

Though I have a problem setting up a service flag voor day/night service.

 

I've created 2 flags:

 

Flag1:

 

Holidays editbox empty.

Other day boxes filled:

 

12:00-18:00

 

Flag2:

 

Holidays editbox empty.

Other day boxes filled:

 

18:00-23:59

 

 

The current time was: 15:15

 

The PBX shows that flag2 is "Set" while flag1 should be set because 15:15 falls between 12:00-18:00 which is set in flag1, not in flag2.

 

 

I also have 2 other flags:

 

Flag3:

0:00-6:00 (in all days)

 

Flag4:

0:00-6:00 (in all days)

 

 

The time is still 15:15

and flag 3 and 4 are both "set", while it isn't between 0:00-12:00 nigt/morning.

 

I tried playing with the "P" behind the times but i'm not getting the result that I want, am I doing something wrong?

 

Regars,

 

Leon

Link to comment
Share on other sites

  • 4 weeks later...
Strange. I assume that the system time zone is the same as the domain time zone? Also, give the system a couple of minutes, because the flag states are not calculated every second.

 

Yes, the system time is the same as set in the PBX. I left the system alone for 24 hours, but nothing happened (I understand that the system won't check every second, that will be quit much load I think:) A suggestion might be to check/update the state on click of the Submit button when editting a flag).

Link to comment
Share on other sites

Yes, the system time is the same as set in the PBX. I left the system alone for 24 hours, but nothing happened (I understand that the system won't check every second, that will be quit much load I think:) A suggestion might be to check/update the state on click of the Submit button when editting a flag).

 

I am sure you have already taken a look at the http://wiki.pbxnsip.com/index.php/Service_...sic_rules_of_SF. 12:00 may be bit confusing, add an extra minute, say 12:01 (just for testing sake)

Link to comment
Share on other sites

I am sure you have already taken a look at the http://wiki.pbxnsip.com/index.php/Service_...sic_rules_of_SF. 12:00 may be bit confusing, add an extra minute, say 12:01 (just for testing sake)

 

Yes, I did all that... Now i've done it with a workarround by using SOAP, the only thing I need now is a kind of account that handles ONLY soap requests, and if the soap fails it should go to a default extention/account but that isn't possible right now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...