Jump to content

INVITE response 480 and call esteblished


asat232
 Share

Recommended Posts

When I dialing from first softphone (EyeBeam 1.5.19.5) to second one (EyeBeam too), and on second one I do HandUp, first EyeBeam is going to call established state. And I can see though web interface that this call is currently active. Looking to pbxnsip logfile page, INVITE response from softphone was 480. Is it a bug, or what is it?

Link to comment
Share on other sites

When I dialing from first softphone (EyeBeam 1.5.19.5) to second one (EyeBeam too), and on second one I do HandUp, first EyeBeam is going to call established state. And I can see though web interface that this call is currently active. Looking to pbxnsip logfile page, INVITE response from softphone was 480. Is it a bug, or what is it?

 

Can you post the log file?

Link to comment
Share on other sites

Here is a log

 

[7] 20090604185653: SIP Rx udp:192.168.0.157:60545:

SIP/2.0 480 Temporarily Unavailable

Via: SIP/2.0/UDP 192.168.0.13:5060;branch=z9hG4bK-a0e6b2d6677d3a7d018c095135fd955f;rport=5060

To: "Fourty One"<sip:41@pbx.company.com>;tag=5135583f

From: "LocalEyeBeam Test12"<sip:100014@pbx.company.com>;tag=31884

Call-ID: ea9ad6c9@pbx

CSeq: 3984 INVITE

User-Agent: eyeBeam release 1102u stamp 52345

Warning: 399 devnull "User reject"

Content-Length: 0

 

Well, it seems that the user rejected the call. That is defintively a feature!

Link to comment
Share on other sites

Our support sometimes is giving such an answer, this is not a bug, and this is a feature. But is it correct behavior when one part is rejecting call and another part is getting 200 ok, and establish call. And pbxnsip considering this call as an active. I think this feature is reproducible and can be easily fixed. What do you think about this matter? Or I somewhere on a wrong way?

Thanks in advance for your help.

Link to comment
Share on other sites

Our support sometimes is giving such an answer, this is not a bug, and this is a feature. But is it correct behavior when one part is rejecting call and another part is getting 200 ok, and establish call. And pbxnsip considering this call as an active. I think this feature is reproducible and can be easily fixed. What do you think about this matter? Or I somewhere on a wrong way?

Thanks in advance for your help.

 

What's is happening here is that, when the called party UA sends 480 error code, PBX is connecting the call to the user's mailbox, so that the caller can leave a message. Did you connect something and verified anything being played back?

Link to comment
Share on other sites

I disabled mailbox for both accounts but the same situation first one rejects call on another call esteblished.

 

 

Ok. There is another setting under Domain->Settings page that lets the user to "camp on" on the destination. You can set that to "No" (along with the mailbox disabled). With these 2 settings, PBX should send back the error code, instead of connecting the call to voicemail system.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...