Jump to content

IPv6 setup with linphone


Prashant
 Share

Recommended Posts

Hi,

 

I have installed pbxnsip on windows 2000 and enabled IPv6 support in the system. I was able to register two linphone softphones which support IPv6 to this pbxnsip server. But when I make a call I see this information.

1) Via and contact port encoded by pbxnsip while forwarding the INVITE request to callee has IP information as 0.0.0.0:5060

2) The connecction information in SDP is also 0.0.0.0

 

But then I added Ports|Bind to specific IP address (IPv6)| the IPv6 address. Then connection information in SDP wass sent properly. Still the Via and Contact information is incorrect. Please let me know what to do. Here is the log file.

 

>>>>>>>>Incoming Invite>>>>>>>>>>>>>>>>>

 

INVITE sip:41@[fe80::240:5ff:fe74:f12e]:5060 SIP/2.0

Via: SIP/2.0/UDP [::1]:5060;branch=z9hG4bK29138

From: <sip:43@[fe80::240:5ff:fe74:f12e]>;tag=24992

To: <sip:41@[fe80::240:5ff:fe74:f12e]:5060>

Call-ID: 24976

CSeq: 21 INVITE

Contact: <sip:43@[fe80::21c:23ff:fe31:d972]:5060>

Authorization: Digest username="43", realm="[fe80::240:5ff:fe74:f12e]", nonce="52cf4dce64b277b3f1ef4a5b30cdf84a", uri="sip:41@[fe80::240:5ff:fe74:f12e]:5060", response="8aa3e734473d9bac6fdebf98553b6ccf", algorithm=MD5

Content-Type: application/sdp

Max-Forwards: 70

User-Agent: Linphone/3.2.1 (eXosip2/3.3.0)

Subject: Phone call

Content-Length: 291

 

v=0

o=43 123456 654321 IN IP6 ::

s=A conversation

c=IN IP6 ::

t=0 0

m=audio 7078 RTP/AVP 8 111 110 0 3 101

a=rtpmap:8 PCMA/8000/1

a=rtpmap:111 speex/16000/1

a=rtpmap:110 speex/8000/1

a=rtpmap:0 PCMU/8000/1

a=rtpmap:3 GSM/8000/1

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-11

 

[8] 2010/04/07 00:38:34: Tagging request with existing tag

[6] 2010/04/07 00:38:34: Sending RTP for 24976#749e7695e1 to [::]:7078

[9] 2010/04/07 00:38:34: Resolve 79: udp fe80::21c:23ff:fe31:d972 5060

[7] 2010/04/07 00:38:34: SIP Tx udp:[fe80::21c:23ff:fe31:d972]:5060:

SIP/2.0 100 Trying

Via: SIP/2.0/UDP [::1]:5060;branch=z9hG4bK29138;rport=5060;received=fe80::21c:23ff:fe31:d972

From: <sip:43@[fe80::240:5ff:fe74:f12e]>;tag=24992

To: <sip:41@[fe80::240:5ff:fe74:f12e]:5060>;tag=749e7695e1

Call-ID: 24976

CSeq: 21 INVITE

Content-Length: 0

 

 

[7] 2010/04/07 00:38:34: Attendant: Calling extension 41

[8] 2010/04/07 00:38:34: Play audio_moh/noise.wav

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:54602

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:54603

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:53408

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:53409

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:49478

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:49479

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:50964

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:50965

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:50004

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:50005

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:60090

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:60091

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:62604

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:62605

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:50620

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:50621

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:57896

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:57897

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:59684

[9] 2010/04/07 00:38:34: UDP: Opening socket on 0.0.0.0:59685

[1] 2010/04/07 00:38:34: Could not allocate new ports!

[9] 2010/04/07 00:38:34: Using outbound proxy sip:[fe80::21c:23ff:fe31:da5a]:5060;transport=udp because of flow-label

[9] 2010/04/07 00:38:34: Resolve 80: url sip:[fe80::21c:23ff:fe31:da5a]:5060;transport=udp

[9] 2010/04/07 00:38:34: Resolve 80: a udp [fe80::21c:23ff:fe31:da5a] 5060

[9] 2010/04/07 00:38:34: Resolve 80: udp [fe80::21c:23ff:fe31:da5a] 5060

[7] 2010/04/07 00:38:34: SIP Tx udp:[fe80::21c:23ff:fe31:da5a]:5060:

INVITE sip:41@[fe80::21c:23ff:fe31:da5a]:5060;line=254fef6d183784e SIP/2.0

Via: SIP/2.0/UDP 0.0.0.0:5060;branch=z9hG4bK-bffbb9ccef010983980a78d9dcf7aa76;rport

From: "Fourty Three" <sip:43@pbx.company.com>;tag=23300

To: "Fourty One" <sip:41@pbx.company.com>

Call-ID: 3c35ce52@pbx

CSeq: 840 INVITE

Max-Forwards: 70

Contact: <sip:41@0.0.0.0:5060;transport=udp>

Supported: 100rel, replaces, norefersub

Allow-Events: refer

Allow: INVITE, ACK, CANCEL, BYE, REFER, PRACK, INFO, UPDATE

Accept: application/sdp

User-Agent: pbxnsip-PBX/3.4.0.3201

Alert-Info: <http://127.0.0.1/Bellcore-dr2>

Content-Type: application/sdp

Content-Length: 359

 

v=0

o=- 29657 29657 IN IP6 fe80::240:5ff:fe74:f12e

s=-

c=IN IP6 fe80::240:5ff:fe74:f12e

t=0 0

m=audio 59684 RTP/AVP 0 8 9 18 2 3 101

a=rtpmap:0 pcmu/8000

a=rtpmap:8 pcma/8000

a=rtpmap:9 g722/8000

a=rtpmap:18 g729/8000

a=fmtp:18 annexb=no

a=rtpmap:2 g726-32/8000

a=rtpmap:3 gsm/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

a=sendrecv

 

 

Look at the outgoing Invite (the above one)

Link to comment
Share on other sites

This is windows 2000 system which is having by default IPv4 enabled. After some 3rd party installation IPv6 can be enabled which I did (so it is in dual mode). I am not aware of any way to disable the IPv4 address and enable only IPv6.

 

Windows 2000 does not support IPv6. You should use Windows Server 2008 or Vista or Windows 7.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...