Jump to content

URI Settings


Friedom-Tech
 Share

Recommended Posts

Hi,

 

i am trying to setup a new trunk with a new carrier Broadview over a T1 but for some reason they are not accepting the calls i send them, they say the issue is that I am sending the same URI in the from and to header (see trace attached).

 

I have changed changing most of the settings in the trunk itself with no results.

 

please advise asap.

post-555-1279662073_thumb.png

Link to comment
Share on other sites

Hi,

 

i am trying to setup a new trunk with a new carrier Broadview over a T1 but for some reason they are not accepting the calls i send them, they say the issue is that I am sending the same URI in the from and to header (see trace attached).

 

I have changed changing most of the settings in the trunk itself with no results.

 

please advise asap.

 

To me, they do not look like the same URI.

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 months later...

I have a question along the same vein.

 

Is there a way to mangle the from header to force the from domain to be a specific domain instead of the PBX IP address?

 

The URI and To header can be done via the dial-plan. But how does one change the domain of the From header?

 

EX:

(numbers and IP's have been changed for protection)

 

INVITE sip:15554443333@mycompany.com SIP/2.0.

Via: SIP/2.0/UDP 10.1.1.55:5060;branch=z9hG4bK-baa1c6f86a3c3f8526a3bd6f7a7ed3bf;rport.

From: "Test Two" <sip:5552221111@10.1.1.55;user=phone>;tag=1887596257.

To: <sip:15554443333@mycompany.com>.

Call-ID: 100287b5@pbx.

Link to comment
Share on other sites

Is there a way to mangle the from header to force the from domain to be a specific domain instead of the PBX IP address?

 

The URI and To header can be done via the dial-plan. But how does one change the domain of the From header?

 

When using trunks, there is a setting "domain" in the trunk that should do this. You might have to play with the RFC3325 settings depending on your providers preference for the headers.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...