Jump to content

Selecting IVR language for extension does not work


PaulP
 Share

Recommended Posts

Every call has a field that tells the PBX what language it should play for this call. In the beginning, that field is empty. As soon as the PBX has to play back a message, it needs to make a decision what language to use. Once that decision has been made, the PBX does not change it any more. Exception: The auto attendant may change the language.

 

In other words: When selecting the language for the extension, this will influence the playback when that user calls his/her mailbox. But when someone else uses the mailbox, it will use either the other extensions language (when this is an internal call) or the language for the domain (trunks dont have language settings) or the language that was selected when the call goes through an auto attendant.

Link to comment
Share on other sites

Ok, I use IVR now because I can control the content a bit more.

 

I have the following structure.

800 IVR Node (Silence-2s)

801 IVR Node (Voor engels (bi_for_language))

802 IVR Node (Press 2 (bi_press2))

803 IVR Node (Silence-2s)

810 IVR Node (Welkom (aa_welcome_auto))

812 IVR Node (IVR Node (Silence-2s))

814 IVR Node (Uwordtdoorgeschakeld (pb_hold_redirect))

816 IVR Node (IVR Node (Silence-2s))

860 IVR Node (Welcome_en (aa_welcome_auto))

862 IVR Node (IVR Node (Silence-2s))

864 IVR Node (YouAreRedirected (pb_hold_redirect))

866 IVR Node (IVR Node (Silence-2s))

 

800 to 816 are Dutch

860 to 866 are English

 

A call on the trunk goes to 800. When pressing "2" is goes to 860.

the 800 chain ends in extension 41 that should have Dutch language for the mailbox.

the 860 chain ends in extension 42 that should have English language for the mailbox.

 

As this seems not be possible this way according to your reply, can you suggest a way to do this smart within the constraints of the system.

 

Regards,

Paul

Link to comment
Share on other sites

First of all, I would suggest to use a audio editor to put these file together so that the PBX does not hop from one account to another...

 

So far. the strategy was to provide one tree for each language path. The PBX was actually not aware about a language in this case, just dumb playback of the WAV files. The trick to have the language stick at the end would be to route the call finally (possibly after pressing a key) into an auto attendant which can set the language.

 

In the next version we'll make a new setting available that makes it possible to explicity specify the language for the call from the IVR node. That would avoid having this workaround.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...