Jump to content

SnomOne Free: trunk registrations and failover


dario
 Share

Recommended Posts

Hi,

I have those two problems on 2011-4.2.0.3958 (Linux):

 

- i have one trunk on sip.twt.it and sometimes the registration fails (but the internet connection is up). The PBX tries to re-register, but it takes several minutes. If I make a simple change on the trunk settings and i save it, it will change to register. Also if i restart the service, the status changes immediatly to 200 OK.

 

I have set the truk with:

Lock codec during conversation: no

Proposed Duration (s): 120

Keepalive Time: 20

Remote Party/Privacy Indication: Remote-Party-ID

 

All the other features are default.

 

- I have an external fxo gateway, so I want to configure the Failover Behavior on the sip trunk.

My settings are:

Failover Behavior: On all error codes

Request Timeout: 15

Then i configured the Standard Dialplan like this:

 

Pref Trunk C P Pattern Replacement Delete

100 Unassigned

60 twt * *

65 620 * *

 

So, if i disconnect the ADSL cable, the status of the sip trunk (twt) changes in 408, but the system don't match the second entry of the dialplan.

 

 

Can someone help me?

Thanks,

Dario.

Link to comment
Share on other sites

Registration and failover are two different things, we can say they are practically not related. The failover does not care if the registration is active or not, it is only about the question if the INVITE gets any response within the failover time. This is because registrations can be active for hours and the PBX then has no chance to see if the internet went down or not.

Link to comment
Share on other sites

Registration and failover are two different things, we can say they are practically not related. The failover does not care if the registration is active or not, it is only about the question if the INVITE gets any response within the failover time. This is because registrations can be active for hours and the PBX then has no chance to see if the internet went down or not.

Thank you for the reply, but, you know, i'm a newbie.

But my questions was:

- do you think that my parameters for trunk registration are right? How can I be better?

- in your opinion, why the failover doesn't work? I'm reading the 400 pages of manual and it said that i'm right. can you help me for this case?

 

Thank you in advance.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...