Jump to content

How to show the right number with the ClipSA service


bennyn
 Share

Recommended Posts

Hi peoble

I have asked my sip provider to enable the ClipSa feature

The feature make it possible to define the number who is showed to externals when a local user calls.

Another good thing, is when the user A calls user B, and user B has forwarded the phone external to User C - it shows the phone number from user A to C

 

Now to the problem

When I calls from a extention to an external number, only the two digits extention number are showed - and not the whole DID number. If I rename the extention to the same name as the DID -it shows the whole DID.

 

I would like it to show the number provided in the ANI field

How do I do that

Link to comment
Share on other sites

For outgoing calls, you should use the ANI to present the extension's identity.

 

For incoming calls, you can set the alias names for the extension so that the PBX can find the right extension.

 

Redirected calls are a long story as SIP does define how it works (use the "From" header), but most of the ITSP did not get it and use "From" for writing the bill. Sounds nice in the case of redirection, but the call will just not go through ...

Link to comment
Share on other sites

Hi there

Thanks for your help

With Clip sa enabled - the ANI have no function what so ever - its only with the CLIPSA Disabled

 

I Have no problem with incomming calls

 

Redirections works perfect - it presents the number of the incomming caller

 

The only problem I have - are that if I make a call, it present the localnumber (41) to the cell that I call, and not the ANI number

Link to comment
Share on other sites

Hi there. I have tried to apply a number with 8 digits in ANI with no result

If I rename the account from the two digits to a 8 digit main number, all 8 digits are showed at the reciever of the call

 

It seems like the pbx are sending the number listed as account - to the retriever of the call - and not the number listed as ANI

Link to comment
Share on other sites

As implied in the first reply, the call-id for the outgoing calls is controlled by the trunk page "Remote Party/Privacy Indication" field. Of course, there are other parameters that controls the formatting of the number, like the country code on the domain, "Rewrite global numbers" on the trunk page.

 

So if you, set the ANI on the extension that is making the call & play with the "Remote Party/Privacy Indication", you should be able control the caller id.

 

If you still have the trouble, please attach the SIP INVITE message that is going out to the provider for different settings of "Remote Party/Privacy Indication".

Link to comment
Share on other sites

Calls made from account 42

 

No Indication - shows the main(real) number of the trunk and not ANI

RFC3325 (p-asserted-identity) - shows 42

RFC3325 (p-preferred-identity) - shows 42

remote-Party-id - shows the main(real) number of the trunk and not ANI

rfc3325 - but dont hide - shows 42

 

 

How do I set log level for sip invite

Link to comment
Share on other sites

Calls made from account 42

 

No Indication - shows the main(real) number of the trunk and not ANI

RFC3325 (p-asserted-identity) - shows 42 (without landcode +45)

)

RFC3325 (p-preferred-identity) - shows 42 (without landcode +45)

remote-Party-id - shows the main(real) number of the trunk and not ANI

rfc3325 - but dont hide - shows 42 (without landcode +45)

 

I've just updated to the newest version - and it seems like the +45 started missing when choosing p-asserted, p-preferred and rfc3325 - but dont hide - but not when choosing no indication, and remote party id

 

the +45 displayed all times before the update

no identification.txt

remoteparity.txt

rfc3325donthide.txt

rfc3325passertedidentity.txt

rfc3325preferredidentity.txt

Link to comment
Share on other sites

IT shows only 42 when dialing

 

I've attached ext 41 - where the show number works (it shows 97153493)

ext 42 displays only 42 when dialing - not 88917736 (the mainnumber of the trunk - with additional 88917738 and 88917739

 

Hope it helps clearing the issue

 

I have not enough space to attach the image here - please follow my dropbox link

 

My dropbox

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...