Jump to content

Trunk incoming call set-up problem


Dimitri
 Share

Recommended Posts

Hello everyone,

 

i'm having some difficulties with a trunk (10 numbers). My trunk is registered and gives me status 200 OK. When I call one of the trunk numbers, my phone rings ... But the Snom One PBX gives me notting (no log, ...). This is strange, because I'm able to trace my incoming call in the firewall log and by a WireShark scan. One thing, the VOIP provider is using 3 different servers for incoming calls 85.119.188.67 - 85.119.188.31 - 85.119.188.2 and the address en proxy server is 85.119.188.3. Below I post a WireShark log and my trunk set-up. Some help would be greatly appreciated.

 

Thank you,

Dimitri

 

Below you find my WireShark log of an incoming call:

INVITE sip:02880xxxx@91.183.57.xxx:63221 SIP/2.0

Via: SIP/2.0/UDP 85.119.188.67:5060;branch=z9hG4bK78913e88;rport

From: "CreaVil" <sip:0288095xx@85.119.188.67>;tag=as568b832a

To: <sip:02880xxxx@91.183.57.xxx:63221>

Contact: <sip:028809582@85.119.188.67>

Call-ID: 353cdb4f41830d4742f4e2ee699cf5c4@85.119.188.67

CSeq: 102 INVITE

User-Agent: Integrics Enswitch

Max-Forwards: 70

Date: Thu, 24 Mar 2011 13:31:18 GMT

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY

Supported: replaces

Diversion: <sip:028809629@ast3>

Content-Type: application/sdp

Content-Length: 334

 

v=0

o=root 3737 3737 IN IP4 85.119.188.67

s=session

c=IN IP4 85.119.188.67

t=0 0

m=audio 18440 RTP/AVP 0 8 18 3 101

a=rtpmap:0 PCMU/8000

a=rtpmap:8 PCMA/8000

a=rtpmap:18 G729/8000

a=fmtp:18 annexb=no

a=rtpmap:3 GSM/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

a=silenceSupp:off - - - -

a=ptime:20

a=sendrecv

 

The Trunk config:

 

# Trunk 7 in domain sip.xxx.com

Name: FCD

Type: register

To: sip

RegPass: ********

Direction:

Disabled: false

Global: true

Display: FCD

RegAccount: 02880xxxx

RegRegistrar: 85.119.188.3

RegKeep: 60

RegUser: 02880xxxx

Icid:

Require:

OutboundProxy: 85.119.188.3

Ani: 02880xxxx

DialExtension:

Prefix: 32

Trusted: false

AcceptRedirect: false

RfcRtp: false

Analog: false

SendEmail:

UseUuid: false

Ring180: false

Failover: never

Privacy: rpi

Glob:

RequestTimeout:

Codecs:

CodecLock: true

Expires: 360

FromUser:

Tel: true

TranscodeDtmf: false

AssociatedAddresses: 85.119.188.31 85.119.188.67 85.119.188.2

InterOffice: false

DialPlan:

Colines: co10

DialogPermission: *

Link to comment
Share on other sites

Looks like you have to set the "Send call to extension" of the trunk (if you want to send all ten numbers to the same account, USA-auto-attandent-style) or use the alias names for the extensions. For example, set the alias names to "41 028809511" (space between the account number 21 and the alias). Also consider setting the country code so that the PBX can translate the numbers into a global format for easier matching.

 

More info here: http://wiki.snomone.com/index.php?title=Inbounds_Calls

Link to comment
Share on other sites

Thank you for the response SnomOne.

 

I already checked these settings a few times. But it's possible that I'm missing out something. My accounts are like these 29 02880xx29 Extension (admin@....com). So everything is mentioned. I already tried to forward all traffic to extension 29, but notting changes. My country code is 32 and encoded in the domain settings (we don't have an area code, so this is left blank).

On this same PBX, I've got a SIP registration account (one number), this one is coming in and matching the correct extension. When I try to contact one of the 10 numbers, I see traces in my firewall (ZyXel USG) and on my server (thanks to WireShark). I already called 3StarsNet (the VOIP provider) and the told me they see an error 404. Strange because my PBX log is on 9 and there is no mention of an incoming call being refused.

If there is indeed a 404 error, I suppose it has to see something with not recognizing the called number ... I just don't get were.

 

Thank you,

Dimitri

Link to comment
Share on other sites

I would start bumping up the log level to 9 and take a look at the logs in the web interface. The PBX tells you then step by step what it does to find the right extension and if the country code was in the right format. Because this is not a live system obviously you won't get flooded in log messages.

Link to comment
Share on other sites

Hello snom One,

 

Thanks for the reply ... My log levels are set on 9. But when I call in to a number of this trunk, notting happens. No extra logs ... Like I said, I hear a ring but the PBX gives notting (and de phone connected to the PBX stays dead). I don't understand why I'm seeing the call in my WireShark & firewall logs, and not in the PBX level 9 logs. It's like the PBX doesn't treat the incoming call although the trunk is correctly registered (outgoing calls are possible).

 

The help desk @3StarsNet, although they don't have Snom One experience, told me to start a search for an option present in Asterisk. I don't have a name, but the gave me a description of this option. The option makes it possible to receive SIP invites coming from other servers then the registered proxy or address server. I think this option is similar to the Snom One option 'Associated Addresses'. I already completed this field with the 3 servers sending me the SIP invites 85.119.188.31, 85.119.188.67 & 85.119.188.2. I'm I correct?

 

I've 2 other trunks on the Snom One. Those trunks have just 1 number and receive their SIP invites from the address & proxy server (85.119.188.3). Those trunks are working correctly. I see all activities of incoming calls in the log ... So the log is working.

 

Thank you,

Dimitri

Link to comment
Share on other sites

Associated address field help the PBX to allow the traffic from a particular source. So what you are doing is ok.

 

Did you check if the trunk provider's IP address is blocked in the Admin->Settings->Access page? Based on your description, it many not have been. But it is always better to check.

 

Also, do you need the CO lines field? If not delete it and see. Better yet, just delete the trunk and recreate with bare minimum settings.

Link to comment
Share on other sites

You need to see something in the log. Did you also turn the SIP logging on (for the SIP packets)? If you dont see anything, the packet source either was blacklisted (admin/settings/access) or did not make it at all to the PBX. If you are behind a firewall ("NAT"), then that is a big topic and the answer is not so easy. You must see something in the log. Do you see ICMP packets in the wireshark? Maybe the port is for whatever reason not open.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...