Jump to content

MSS07 Outbound Calls Works But...


Hiren Shah
 Share

Recommended Posts

I am able to make outbound call to the extension i created in the pbxnsip but i m facing problem in making outbound calls to normal pstn numbers.

 

Following is my setup

 

Pbx n sip server on one machine

Speech Server 07 with MS SQL 2005 DB and IIS 6 on the same Machine

USB phones with Eyebeam installed

Got a sip trunk from inphoenix for US call and configured in pbx with OK status.

 

 

Following is working fine

1) Created extensions 10001, 10002. Able to configure them. They are working fine.

2) Added US SIP trunk and able to make call from extension to outside number following is the log entry for the same.

 

[5] 2007/11/27 06:30:40: Identify trunk 5

[5] 2007/11/27 06:30:40: Dialplan: Match 9xxxxxx1225@192.168.0.125 to <sip:xxxxxx1225@sip.inphonex.com;user=phone> on trunk yyyyyyy

[5] 2007/11/27 06:30:40: INVITE Response: Terminate 87f04e2c@pbx

 

3) Added SIP as trusted sip connection in speech server.

4) Outbound call from speech server to this extension works fine. Following is the log entry for the same.

 

5] 2007/11/27 06:26:09: SIP port accept from 192.168.0.131:1675

[5] 2007/11/27 06:26:09: Identify trunk 5

[5] 2007/11/27 06:26:10: Trunk yyyyyyy sends call to 10001

a. 192.168.0.131 is a MSS07 server

 

4) Outbound call to other phone is not working. Following is the log file.

 

5] 2007/11/27 06:27:22: Identify trunk 5

[5] 2007/11/27 06:27:22: Trunk 6781660 sends call to xxxxxx1225

[5] 2007/11/27 06:27:22: Trunk call: Could not identify user

 

Any one please help me on how to configure this line so that i can make outbound call using speech server

Link to comment
Share on other sites

Hello Hiren,

 

please take a look here - and check if your version supports the described settings, if not try an update:

http://pbxnsip.invisionzone.com/index.php?showtopic=430

 

I guess you need this part of the short guide:

 

@pbxnsip:

Create a trunk to your SIP-provider, Type=SIP Registration, enter all account infos (username, domain, outbound proxy etc.) given by your provider.

Create a trunk to OCS-Mediation Server, Type=SIP Gateway, Domain=FQDN of OCSMediation Server (or IP), Username=Anonymous,Password=BLANK, Outbound Proxy=sip:FQDN of OCSMediation Server:5060;transport=tcp (example: sip:jb-ocs-md.ocsdemo.net:5060;transport=tcp), Assume that call comes from user=primary name of an existing pbxnsip-account (Type=extension) which will be charged for calls from OCS-Med-Server to the real world. This account must not be in use / registered.

Create or edit a dialplan, Pref=100, Trunk=TRUNK to SIP-provider, Pattern=*, Replacement=* or 0* or something like this (depends on your enviroment)

 

Best regards, good luck!

 

Jan Boguslawski

 

 

Jan Boguslawski

Consultant IT Infrastructure

MCSE

 

Telefon: +49 30 399 784-0

 

ITaCS GmbH

Friedrichstra?e 121

10117 Berlin

www.itacs.de

Link to comment
Share on other sites

Hello Hiren,

 

are you running pbxnsip and Speech Server on one machine? Maybe your run in the same problem, like people placing Mediation Server (or ExchangeUM) and pbxnsip on one machine?

The settings I have decribed are for pbxnsip. Especially the one or the SpeechServer-trunk are important: Assume that call comes from user=primary name of an existing pbxnsip-account (Type=extension) which will be charged for calls from OCS-Med-Server to the real world

 

Please tell your version of pbxnsip and check your SpeechServer-Trunk for the described setting!

 

btw.: I have not tested/deployed SpeechServer, but I guess it will not too different from ExchangeUM or OCS. You simply need to trust this strange trunks :(

 

Beware of Billing Risks :(

 

Best regards

 

Jan

 

Jan Boguslawski

Consultant IT Infrastructure

MCSE

 

Telefon: +49 30 399 784-0

 

ITaCS GmbH

Friedrichstra?e 121

10117 Berlin

www.itacs.de

Link to comment
Share on other sites

  • 1 month later...
  • 3 years later...

My issue is that for all outbound calls, SnomeOne PBX is requiring authentication.Any idea how to fix this?

 

My set up is as follows

 

1. speech server - Created a trusted peer to snomone pbx at localhost:5060 (speech server is listening on 6060)

2. pbxnsip - craeted a trunk (type - sip proxy) to speech server - Assume call comes from - extension 42.

3. 42 extension dial plan is set to hyprmedia, and the trunk for the dial plan is set to hypermedia gateway.

4. When I place an outgoing call from speech server, I can sed that the sip request is reachig the gateway. But Speech server is complaining as follows

 

An error occurred during call transfer: Microsoft.SpeechServer.SipPeerException: A SIP request has failed. The current operation is 'Opening'. The session state is 'Connecting'. The remote participant is 'sip:2012181444@192.168.1.13:5060;user=phone'. The response code was '401'. The response text was 'Authentication Required'. ---> SupportedAuthenticationProtocols=None

Realm=

FailureReason=None

ErrorCode=0

ResponseCode=401 ResponseText=Authentication Required

Microsoft.Rtc.Signaling.AuthenticationException: Peer to peer endpoint does not support authentication.

at Microsoft.Rtc.Signaling.SipAsyncResult.ThrowIfFailed()

at Microsoft.Rtc.Signaling.Helper.EndAsyncOperation[T](Object owner, IAsyncResult asyncResult)

at Microsoft.Rtc.Signaling.Helper.EndAsyncOperation[T](Object owner, IAsyncResult asyncResult, String operationId)

at Microsoft.Rtc.Signaling.SignalingSession.EndEnter(SipInviteAsyncResultWrapper asyncWrapper)

at Microsoft.SpeechServer.Core.TelephonySessionOutbound.ParticipateCallback(IAsyncResult result)

 

5. In Snomone log I see the following...

 

 

[8] 2011/06/10 10:38:51: Received SIP connection 255 from 192.168.1.13:53040

[9] 2011/06/10 10:38:51: SIP Rx tcp:192.168.1.13:53040:

INVITE sip:2012181444@192.168.1.13:5060;user=phone SIP/2.0

FROM: <sip:45@CommServer.creditfree.local:50681;user=phone>;epid=457BE1388F;tag=8b9960a8ed

TO: <sip:2012181444@192.168.1.13:5060;user=phone>

CSEQ: 1 INVITE

CALL-ID: 79644d90-3c04-4839-98a7-729c9b9a6b93

MAX-FORWARDS: 70

VIA: SIP/2.0/TCP 192.168.1.13:53040;branch=z9hG4bK641e3c71

CONTACT: <sip:CommServer.creditfree.local:50681;transport=Tcp;maddr=192.168.1.13;ms-opaque=b2dfee4fee6e4834>;automata

CONTENT-LENGTH: 335

USER-AGENT: RTCC/3.0.0.0

CONTENT-TYPE: application/sdp

ALLOW: UPDATE

ALLOW: Ack, Cancel, Bye,Invite,Message,Info,Service,Options,BeNotify

 

v=0

o=- 0 0 IN IP4 192.168.1.13

s=Microsoft Speech Server session

c=IN IP4 192.168.1.13

t=0 0

m=audio 6274 RTP/AVP 114 115 4 0 8 97 101

a=rtpmap:114 x-msrta/16000

a=fmtp:114 bitrate=29000

a=rtpmap:115 x-msrta/8000

a=fmtp:115 bitrate=11800

a=rtpmap:97 RED/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

a=ptime:20

 

[9] 2011/06/10 10:38:51: SIP Tx tcp:192.168.1.13:53040:

SIP/2.0 100 Trying

Via: SIP/2.0/TCP 192.168.1.13:53040;branch=z9hG4bK641e3c71

From: <sip:45@CommServer.creditfree.local:50681;user=phone>;tag=8b9960a8ed;epid=457BE1388F

To: <sip:2012181444@192.168.1.13:5060;user=phone>;tag=ea32e7f2fd

Call-ID: 79644d90-3c04-4839-98a7-729c9b9a6b93

CSeq: 1 INVITE

Content-Length: 0

 

 

[9] 2011/06/10 10:38:51: SIP Tx tcp:192.168.1.13:53040:

SIP/2.0 401 Authentication Required

Via: SIP/2.0/TCP 192.168.1.13:53040;branch=z9hG4bK641e3c71

From: <sip:45@CommServer.creditfree.local:50681;user=phone>;tag=8b9960a8ed;epid=457BE1388F

To: <sip:2012181444@192.168.1.13:5060;user=phone>;tag=ea32e7f2fd

Call-ID: 79644d90-3c04-4839-98a7-729c9b9a6b93

CSeq: 1 INVITE

User-Agent: snom-PBX/4.2.0.3950

WWW-Authenticate: Digest realm="commserver.creditfree.local",nonce="d2e7e6915156a03a81283494f153136a",domain="sip:2012181444@192.168.1.13:5060;user=phone",algorithm=MD5

Content-Length: 0

Link to comment
Share on other sites

Looks like the PBX did not associate the call with the trunk to the exchange server. Did you set the outbound proxy right? Maybe you should just set the explciit inbound addresses.

 

Also, make sure that the PBX has has the "assume call comes from user" set in the trunk. This is neccessary because the trunk needs to know which dial plan to use and which user to charge (you can't charge a trunk on the PBX).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...