Jump to content

Snom300 autoprovisioning


Arryxyz
 Share

Recommended Posts

Hello. We're implementing SnomONE PBX on a Linux machine. We created multiple instances, bound to NIC secondary addresses.

SnomONE version is 2011-4.2.0.3981 (Linux).

Every seems to be OK.

 

We start encountering problems implementing autoprovisioning. The TEST instance, bound to primary address of NIC, works perfectly and provisioning is OK.

The second instance, which is bound to a secondary address of NIC card, doesn't works: autoprovisioning process starts to fetch XML files, but nothing more happens and checking NAT table on Cisco Router, we can see NAT translation to primary server address, instead that secondary (the correct one).

 

 

 

Another thing: we set option 66 on DHCP section of Cisco router in this way:

 

ip dhcp pool LOCAL

option 66 ascii "tftp://ip.of.pbx.server"

 

Snom300 phones "out-of-the-box" have 7.3 firmware version. Autoprovisioning process passes parameter "tftp://ip.of.pbx.server" but it's not correctly interpreted. If we remove "tftp://" from option 66, leaving only "ip.of.pbx.server", it works. On the other side, with 8.4.32 version option 66 MUST have "tftp://", otherwise it doesn't work again.

 

Is there a way to set a common parameter which is OK for different FirmWare versions that we can find on new phones?

 

The alternative is manually upgrading firmware version before, but it would nullify autoprovisioning advantages.

 

 

Can anyone help us in solving these problems?

Thanks in advance.

 

Arrigo.

Link to comment
Share on other sites

Hello. We're implementing SnomONE PBX on a Linux machine. We created multiple instances, bound to NIC secondary addresses.

SnomONE version is 2011-4.2.0.3981 (Linux).

 

Why not version 4.5? A lot of bugs have been fixed since 4.2.

 

We start encountering problems implementing autoprovisioning. The TEST instance, bound to primary address of NIC, works perfectly and provisioning is OK.

The second instance, which is bound to a secondary address of NIC card, doesn't works: autoprovisioning process starts to fetch XML files, but nothing more happens and checking NAT table on Cisco Router, we can see NAT translation to primary server address, instead that secondary (the correct one).

 

Well, this is all about a proper routing table on the operating system. Most services run only on TCP where the routing table for server sockets is not so important. But for TFTP and RTP the routing table must be 100 % clean. The PBX must be able to open a UDP port, connect it to an IP address and then use the right IP source address when sending a UDP packet from that UDP port.

 

Another thing: we set option 66 on DHCP section of Cisco router in this way:

 

ip dhcp pool LOCAL

option 66 ascii "tftp://ip.of.pbx.server"

 

Snom300 phones "out-of-the-box" have 7.3 firmware version. Autoprovisioning process passes parameter "tftp://ip.of.pbx.server" but it's not correctly interpreted. If we remove "tftp://" from option 66, leaving only "ip.of.pbx.server", it works. On the other side, with 8.4.32 version option 66 MUST have "tftp://", otherwise it doesn't work again.

 

Is there a way to set a common parameter which is OK for different FirmWare versions that we can find on new phones?

 

The alternative is manually upgrading firmware version before, but it would nullify autoprovisioning advantages.

 

My recommendation is to just put the IP address of the PBX in there; by default the phones should use TFTP protocol. Version 8.4.32 is already somewhat outdated; seems like 8.4.35 is available for all devices. Though I did not verify that the 8.4.35 fixes the problems with the Option 66 URL; otherwise 8.7.3.10 might be your next best shot. If you take a phone out of the box with 7.30, it should be able to automatically update to the 8.4.35 or 8.7.3.10 version without touching anything then.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...