Jump to content

PnP - config change not applied


global_s
 Share

Recommended Posts

Hello,

I have seveal snom300 connected to a snomone 4.5 Delta.

 

I configured them with PnP (save to log) and setup server_setting: http://pbx_ip_address/prov/snom300.htm

 

If I reboot them I can see that they download the configuration, however, when I change a setting in the domain, the configuration file is always the same.

 

In the real scenario I wanted to change domain language from French to English, then I redirect my browser to the provisioning address using the same credential of the phone, and I can still see that the language passed is French.

Link to comment
Share on other sites

Right, instead of rebooting the phone all the time, you can just simulate the same in the web browser.

 

Did you overwrite the domain settings in the extension by accident? Language has three layers: system, domain and account. Only if the account is set to "domain default" it will take the language from the domain (or the system if the domain is also on default).

Link to comment
Share on other sites

Did you overwrite the domain settings in the extension by accident? Language has three layers: system, domain and account. Only if the account is set to "domain default" it will take the language from the domain (or the system if the domain is also on default).

 

I checked and every extension still has "domain default", in the snom_3xx_phone.xml file I have

 

<language perm="RW">{enum extension lang_audio English sp=Espanol de=Deutsch fr=Francais nl=Nederlands ru=Russian dk=Dansk it=Italiano pl=Polski tr=Turkce cn=Chinese}</language>

<web_language perm="RW">{enum extension lang_audio English sp=Espanol de=Deutsch fr=Francais nl=Nederlands ru=Russian dk=Dansk it=Italiano pl=Polski tr=Turkce cn=Chinese}</web_language>

<tone_scheme perm="RW">{enum domain lang_tones USA de=GER fr=FRA uk=GBR in=IND it=ITA jp=JPN mx=MEX nl=NLD no=NOR sp=ESP sw=SWD}</tone_scheme>

 

and the domain language is set to English, after the initial French. The language passed is still French

Link to comment
Share on other sites

You can see in the "generated" folder what the PBX sends to the phone. Maybe there you can see what the problem is.

 

I also remember that there was a change in the language names between the versions on the phone side. Maybe the text has to be now "Englais" for French English or something like that...

Link to comment
Share on other sites

You can see in the "generated" folder what the PBX sends to the phone. Maybe there you can see what the problem is.

 

I also remember that there was a change in the language names between the versions on the phone side. Maybe the text has to be now "Englais" for French English or something like that...

 

I can see that the value is "French" instead on English. My point is, why is the pbx creating file with the wrong language? I also tried to enable "save generated to log" as well as delete all the generated files. No change

Link to comment
Share on other sites

  • 2 weeks later...

I can see that the value is "French" instead on English. My point is, why is the pbx creating file with the wrong language? I also tried to enable "save generated to log" as well as delete all the generated files. No change

 

 

For info, I found the bug in snom_3XX pnp file

 

in the section <web_language> you can still see reference to language_audio

 

if anyone has the same issue, simply change the language_audio to language_web

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...