Jump to content

SnomOne linux routing with two NICs


htcom
 Share

Recommended Posts

I'm after a bit of help here please.

 

I am setting-up a debian SnomOne system for a customer who has two broadband circuits. One circuit is for his general lan - web, email etc. The second circuit is exclusively for VoIP.

 

The debian server running snomone has two NIC's. eth0 is set as static 192.168.10.10 for his Lan connectivity and eth1 is set as a dhcp client connected to the voip broadband router(it gets a dynamic public ip - no nat here).

 

The problem I'm seeing is that the sip trunk on the snomone is routing through eth0, whereas I really want it to route through eth1.

 

I have had a look at the SnomOne IP Routing List option, but can't see how to specify a routing list where the public ip is dynamic.

 

I suspect this may be a linux routing issue , but I'm not familiar with ip routing on Linux.

 

If any could advise I'd be grateful.

 

Thank you

Link to comment
Share on other sites

What is the output of "route"? Also, what Linux distribution are you using?

 

Thank you for replying snom ONE.

 

The Linux distribution is Debian Squeeze.

The SnomOne version is 5.0.3 (CentOS32)

 

The output from route is:

Destination Gateway Genmask Flags Metric Ref Use Iface

10.0.0.2 * 255.255.255.255 UH 0 0 0 tun0

lo0-central10.p * 255.255.255.255 UH 0 0 0 eth1

localnet * 255.255.255.0 U 0 0 0 eth0

10.0.0.0 10.0.0.2 255.255.255.0 UG 0 0 0 tun0

default lo0-central10.p 0.0.0.0 UG 0 0 0 eth1

default 192.168.7.1 0.0.0.0 UG 0 0 0 eth0

Link to comment
Share on other sites

Not being the biggest Debian expert, I would think that you have set a default gateway on your static IP, which is probably not a good idea. http://wiki.debian.org/NetworkConfiguration I would have the dhclient assign the default gateway, which seems to be the default. Next time, please use route -n; this is easier to read...

Link to comment
Share on other sites

Not being the biggest Debian expert, I would think that you have set a default gateway on your static IP, which is probably not a good idea. http://wiki.debian.org/NetworkConfiguration I would have the dhclient assign the default gateway, which seems to be the default. Next time, please use route -n; this is easier to read...

 

Thanks for that snom ONE. You are absolutely correct, when I remove the default gateway entry from the LAN statically assigned nic then the sip trunk uses the 'correct' nic connected to the voip broadand router.

 

Another thing that seems to fix the issue is to set a metric value to each of the nics. Using ifmetrics and setting the wan nic card to have a lower metric value than the lan nic also seems to work.

 

Every thing now seems to work as expected and thank you for your help on this snom ONE.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...