Jump to content

Grandstream GXW4104 FXO setup


Lexcom
 Share

Recommended Posts

I am having issues trying to setup a Grandstream GXW4104 FXO with snomone. I tried it a year ago with 4.5 and gave up. I ended up using an Audiocodes. I am now using 5.04 and am stuck due to Windstream screwing my client on a port. I need to put this FXO at their old location and then send it to their new location over the internet. I am comfortable with the networking, but am having issues on the analog trunk side. All I get is ringing. Status shows that someone tried to call. I am running it as 1 step like the Audiocodes. I have tried to copy the same settings over (or my version of translate) but still stuck on probably 1 or 2 settings.

Link to comment
Share on other sites

With the analog part I can not help you... However on the SIP side, if you can, use a VPN that makes the setup a lot more easier. Then you can just use a gateway trunk with full control over all headers, so that it should be easy to get the gateway working.

 

These are my updated notes on the grandstream 4104, I just had it working last week with 5.0.4 without a problem. I don't think there are any other changes needed from this but I will check my adapter tonight.

 

I worked through this with my adapter and here is how I set mine up:

 

Grandstream POTS Adapter:

 

Product Model: GXW4104

Software Version: Program--1.3.4.10 Loader--1.1.3.4 Boot--1.1.3.2 (The current firmware that is available today works fine also)

 

If your adapter is exposed to the internet change the password under advanced settings.

 

Settings:

 

FXO Lines: - Channel Dialing To PSTN

 

1. Wait for Dial-Tone(Y/N): ch1-4:N;

2. Stage Method(1/2): ch1-4:1;

3. Min Delay Before Dialing Out: ch1-4:500;

 

 

FXO Lines: - Channel Dialing to VoIP

 

User ID: ch1-4:1; ## Without a user ID the adapter would not call the pbx, it seems to work with any userid. I believe you can change the user ID on the individual lines to 888 (or something else you prefer ie an actual extension number) and route that to a hunt group or extension.

Sip Server: ch1-4:p1;

Sip Destination Port: ch1-4:5060;

 

 

 

Channels:

 

Make sure all the channels you are using are set to profile 1.

1. DTMF Methods(1-7): ch1-4:3;

1. DTMF Methods(1-7): ch1-4:2; Must be 1 or 2 depending on, In audio is probably better for analog.Experiment on what works best for you. (EDIT)

I noticed the audio in was kind of low so upped the RX to 7. Beware that all POTS lines I have dealt with are different and will have to be tuned to your liking. Sometimes the ringback tone is too low and may need to be increased.

 

 

Profile 1

SIP Server: xxx.xxx.xxx.xxx (PBX IP)

SIP Registration: No

 

 

 

 

snomONE PBX:

 

Type: SIP Gateway

Direction: Inbound and Outbound

Trunk Destination: Generic Sip Server

State: Enabled

Display Name: Grandstream

Domain: xxx.xxx.xxx.xxx "IP of your gateway"

No User Name Or Password

Accept Redirect: Yes

Interpret SIP URI always as telephone number: Yes

Send Call To Extension: "The Extension You Use" (if you set different user ID's you can route them to different parts of the snom PBX)

Explicitly list addresses for inbound traffic: xxx.xxx.xxx.xxx "IP of your gateway"

Message 180 to yes (A bad clicking sound will be on one side of the call if this is not enabled.)

 

 

Make sure you remove the area code out of your domain settings so it does not dial 10 or 11 digits

 

Make sure to have a 7 digit dial plan active that points to the pots adapter.

Link to comment
Share on other sites

Thank you for the help! What I am having a problem with is that I dont think the Grandstream is answering the call. I am seeing this with 2 of these devices. I even changed it to 2 stage dialing (just to test) and I am not hearing anything but endless ringing. At least with the Audio codes, it picks up and then gives a dial tone for 2 stage. I want it to send to extension 115 on the pbx which is an auto attendant.

Link to comment
Share on other sites

OK. It is now picking up but it is not hearing the keyed input/tones. It is also not showing caller ID.

Are the phones lines based in the USA? If so the the FXO page shows the caller ID scheme ok but you will probably need to change the "Number of rings to pickup" to 2 (ch1-4:2;), usually caller ID comes between ring 1 and 2 on pots lines. ON DTMF, click the channels page, and change DTMF Methods to 1 (ch1-4:1;), try it, if that didnt work then 2, try it or 4. I was told by grandstream not to use 3, it doesn't make sense to use because it is sent in one or the other not both. Also, don't change the progress tones, even if the test tells you to unless you know your provider needs something different and you know the info. The channel test gives the wrong settings.

 

I have attached a PDF of my channels page.

Grandstream Device Configuration.pdf

Link to comment
Share on other sites

Are the phones lines based in the USA? If so the the FXO page shows the caller ID scheme ok but you will probably need to change the "Number of rings to pickup" to 2 (ch1-4:2;), usually caller ID comes between ring 1 and 2 on pots lines. ON DTMF, click the channels page, and change DTMF Methods to 1 (ch1-4:1;), try it, if that didnt work then 2, try it or 4. I was told by grandstream not to use 3, it doesn't make sense to use because it is sent in one or the other not both. Also, don't change the progress tones, even if the test tells you to unless you know your provider needs something different and you know the info. The channel test gives the wrong settings.

 

I have attached a PDF of my channels page.

 

IF DTMF still gives you an issue, then you may want to set the PBX trunk to yes on out of band-DTMF tones and test the different DTMF Methods settings again.

Link to comment
Share on other sites

Thank You! I have tried your settings and still have an issue. I have tried 1,2, and 7 with DTMF...no luck. We have Windstream (KY)at this location. 1 ring can work with the Audiocodes unit with them, but all FXO units need 2 rings with Bell South ATT (around this area) from my experience. The caller ID is not that big of a deal, but the DTMF is. The audiocodes units need out of band here...FYI. I am getting the same result with both identical units. I even tried it on their 503 unit.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...