Jump to content

PBX adding a 1 to the 10 digit outbound CID


Steve B
 Share

Recommended Posts

I have a feeling this may be an easy one but need some help. I have my Snomone 5.10 connecting through a Vega 100 to a PRI with multiple rate centers. The Company I am working with has three locations, all with differnt 911 centers. When the PBX makes an outbound call either the PBX or the gateway is adding a 1 to the 10 digit CID. The carrier expects 10 digits on 911 calls to choose the right 911 center and defaults to the main BTN if it gets more. So my problem is that all 911 calls are ging to the default BTN because the carrier sees an 11 digit CID (they see this in their logs). Any help would be great, right now I am able to redirect calls to the Non emergency numbers until I can get this fixed.

Link to comment
Share on other sites

First of all, I would set the country code in the domain to "1", so that the PBX knows that 10 digits are the same like 1 + 10 digits.

 

On the trunk there is a setting called "Rewrite global numbers" where you can instruct the PBX to use a specific format for outbound calls. You can do this differently for each trunk. If you want to present only the 911 calls with 10 digits and all other with 11, you can for example set up two different trunks--one for 911 and another one for all other calls.

Link to comment
Share on other sites

First of all, I would set the country code in the domain to "1", so that the PBX knows that 10 digits are the same like 1 + 10 digits.

 

On the trunk there is a setting called "Rewrite global numbers" where you can instruct the PBX to use a specific format for outbound calls. You can do this differently for each trunk. If you want to present only the 911 calls with 10 digits and all other with 11, you can for example set up two different trunks--one for 911 and another one for all other calls.

 

Thank you. I have the country code set to 1 but anytime the PBX uses the extension ANI it sends 1+10 digit (extension ANI) as the caller ID even if i Have it set to 10 digit. What worked for me was making multiple outbound accounts liek you said, setting the Trunk ANI to the desired DID, and setting the from and remote party ID headers to Trunk ANI, worked perfectly. Thank you for your help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...