Jump to content
Vodia PBX forum
madis

Trunk not registering when using FQDN instead IP address

Recommended Posts

Hi

 

I have a problem that trunk is not registering when I use DNS names in proxy address field. With IP addresses everything works.

In log I only see:

[8] 2015/09/25 11:30:47: Trunk 5: sending discover message for crx.xxx.eu [2] 2015/09/25 11:30:47: Web interface triggered reregistration of trunk 5 [8] 2015/09/25 11:30:47: Trunk 5: sending discover message for crx.xxx.eu [2] 2015/09/25 11:30:48: Web interface triggered reregistration of trunk 5 [8] 2015/09/25 11:30:48: Trunk 5: sending discover message for crx.xxx.eu [8] 2015/09/25 11:30:49: Trunk 3: Preparing for re-registration

 

With tcpdump I do not see that it tries to resolve this address.

Within OS (CentOS) name resolving works perfectly.

 

PBX is SnomONE blue Version: 2011-4.3.0.5021 (Linux)

 

Thanks

Madis

Share this post


Link to post
Share on other sites

Do you have the DNS server set up properly in /etc/resolv.conf? That is what the PBX uses to determine the address. Also, anything in the log? I don't quite remember if the 4.3 already had a separate log level for DNS.

Share this post


Link to post
Share on other sites

Yes. resolv.conf is configured and I can resolve the names in Centos. There is no DNS logging option available. I had set other logging options to level 9 (SIP and audio levels are off).

 

[root@localhost ~]# dig -t SRV _sip._udp.proxy.pbx.xxx.ee

; <<>> DiG 9.7.3-P3-RedHat-9.7.3-8.P3.el6 <<>> -t SRV _sip._udp.proxy.pbx.xxx.ee
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 36310
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 6

;; QUESTION SECTION:
;_sip._udp.proxy.pbx.xxx.ee. IN SRV

;; ANSWER SECTION:
_sip._udp.proxy.pbx.xxx.ee. 300 IN SRV 20 0 5060 proxy1b.pbx.xxx.ee.
_sip._udp.proxy.pbx.xxx.ee. 300 IN SRV 10 0 5060 proxy1a.pbx.xxx.ee.

Share this post


Link to post
Share on other sites

Can you share with us (private message, possibly) the XML file for the trunk? Maybe there is something "stupid" like a space character behind the outbound proxy. I guess other DNS addresses work, for example for sending out emails?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...