Jump to content

Message Lamp on/off on snom


pmenico
 Share

Recommended Posts

Hello:

 

I tried sending a SIP NOTIFY message from my application to the snom phone to control the message waiting lamp:

 

NOTIFY sip:251@192.168.1.43:5060 SIP/2.0

t: ;tag=78923

f: ;tag=4442

Date: May 12, 2008 11:45:23 GMT

Call-Id: 3c268afd0ea6-tk5ueq9zigfb@snom360-000413230077

CSeq: 20 NOTIFY

Event: message-summary

Content-Type: application/simple-message-summary

Content-Length: 44

 

Messages-Waiting: no

Voicemail: 0/0 (0/0)

 

 

TcpClient tcpc = new TcpClient();

int port = 5060;

IPaddress = "192.168.1.43";

 

But I could not even open the port as the connection request is denied.

 

I also tried port 2051 as suggested in this example on the snom website but the result was the same (Connection rejected/denied).

 

INFO sip:123@192.168.4.185:2051;line=z6yxt6av SIP/2.0

v: SIP/2.0/UDP 192.168.0.8:5060;branch=z9hG4bK-c5036dd36491b35dba0953bcd912b2a7;rport

f: ;tag=24433

t: ;tag=ga2hjuhxot

i: 3c268afd0ea6-tk5ueq9zigfb@snom360-000413230077

CSeq: 1 INFO

Max-Forwards: 70

m:

c: message/sipfrag

l: 68

 

From:

To: 123

 

Can anyone explain what I am doing wrong or if there is another way to toggle the MWI on the snom phones?

 

Thank you.

Link to comment
Share on other sites

I made some progress today by using UDP (silly me):

 

but I still have a problem. Is there a way to bypass this? Some phone setting that I missed?

 

Below is the telephone trace:

 

Received from udp:192.168.1.44:2057 at 20/5/2008 19:52:49:680 (453 bytes):

 

NOTIFY sip:251@192.168.1.43:2057;line=m00xv4ly SIP/2.0

Via: SIP/2.0/UDP 192.168.1.44:2057;branch=z9hG4bK5e3acadf;rport

To: <sip:251@192.168.1.43:2057;line=m00xv4ly>

From: ;tag=4442

Date: Tuesday, May 20, 2008 5/20/2008 7:52:49 PM

Call-Id: 3c268afd0ea6-tk5ueq9zigfb@snom360-000413230077

CSeq: 102 NOTIFY

Event: message-summary

Content-Type: application/simple-message-summary

Content-Length: 45

 

Messages-Waiting: yes

Voicemail: 1/1 (1/1)

 

 

 

 

--------------------------------------------------------------------------------

 

Sent to udp:192.168.1.44:2057 at 20/5/2008 19:52:49:690 (424 bytes):

 

SIP/2.0 403 Use Proxy

Via: SIP/2.0/UDP 192.168.1.44:2057;branch=z9hG4bK5e3acadf;rport=2057

From: <;tag=4442>

To: <sip:251@192.168.1.43:2057;line=m00xv4ly>

Call-ID: 3c268afd0ea6-tk5ueq9zigfb@snom360-000413230077

CSeq: 102 NOTIFY

Allow: INVITE, ACK, CANCEL, BYE, REFER, OPTIONS, NOTIFY, SUBSCRIBE, PRACK, MESSAGE, INFO

Allow-Events: talk, hold, refer

Supported: timer, 100rel, replaces, callerid

Content-Length: 0

Link to comment
Share on other sites

Well the phone thinks that this is DoS. It wants you to send the request from the PBX IP address and port. There is a option to turn this off on the phone, but then the phone gets vulnerable for simple DoS.

 

Same thing for TCP. You can set the phone to accept TCP connections (which is off by default), but then again you risk that someone plays DoS with the phone in your network.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...