Jump to content

IVR playing system message instead of custom when called from PSTN


Michael
 Share

Recommended Posts

I am evaluating the system and have version 3.0.0.2998 with the 3 min. license. I am trying to duplicate our existing PBX system and I am getting a strange behavior with the IVR menu when called from the PSTN, but not from an extension on the pbxnsip server. I created an account with a primary name of 10 and an alias of a PSTN phone number that is being sent to the system. When I call 10 or the PSTN number from an internal extension it plays my recording and woks as expected (including my night/day service flag). However, when I call the PSTN number from my cell phone I get a message that says "To place an outbound call press 1, to go to your mailbox press 2, to go to the auto attendant press 3" instead of my recording. Besides that it should have played my recording instead of that system message, when I press 3 it plays my recording but it ignores the day night setting and never plays the other message. So it looks like I may have 2 things messed up in the config and I'm not sure what I am doing wrong. Any help would be appreciated.

 

Thanks!

Mike

Link to comment
Share on other sites

I am evaluating the system and have version 3.0.0.2998 with the 3 min. license. I am trying to duplicate our existing PBX system and I am getting a strange behavior with the IVR menu when called from the PSTN, but not from an extension on the pbxnsip server. I created an account with a primary name of 10 and an alias of a PSTN phone number that is being sent to the system. When I call 10 or the PSTN number from an internal extension it plays my recording and woks as expected (including my night/day service flag). However, when I call the PSTN number from my cell phone I get a message that says "To place an outbound call press 1, to go to your mailbox press 2, to go to the auto attendant press 3" instead of my recording. Besides that it should have played my recording instead of that system message, when I press 3 it plays my recording but it ignores the day night setting and never plays the other message. So it looks like I may have 2 things messed up in the config and I'm not sure what I am doing wrong. Any help would be appreciated.

 

Well, there is a special feature with the cell phone. When users are calling from their cell phone into the office, they get a "special treatment" (feature). It might be annoying for testing, but for the real life it is quite useful, especially when those users want to place international calls or just use the caller-ID of the PBX for outbound calls.

 

The feature kicks in when the cell phone is calling an auto attendant. For direct extension calls, that feature is not active.

Link to comment
Share on other sites

Well, there is a special feature with the cell phone. When users are calling from their cell phone into the office, they get a "special treatment" (feature). It might be annoying for testing, but for the real life it is quite useful, especially when those users want to place international calls or just use the caller-ID of the PBX for outbound calls.

 

The feature kicks in when the cell phone is calling an auto attendant. For direct extension calls, that feature is not active.

 

 

Ah I see, I *only* tried it from my cell phone and never tried it from another line that wasn't programmed in the system i.e. a land line. Interesting feature, but just so I know, is there a way to turn it off?

Link to comment
Share on other sites

Ah I see, I *only* tried it from my cell phone and never tried it from another line that wasn't programmed in the system i.e. a land line. Interesting feature, but just so I know, is there a way to turn it off?

 

There is no settings for that, but you can easily fool it by putting a prefix to the cell phone and then strip that prefix in the dial plan.

 

For example, if your cell phone number is 212-123-4567 you would put 999-212-123-4567 there and then have a dial plan entry with the pattern 999*.

Link to comment
Share on other sites

  • 3 months later...
There is no settings for that, but you can easily fool it by putting a prefix to the cell phone and then strip that prefix in the dial plan.

 

For example, if your cell phone number is 212-123-4567 you would put 999-212-123-4567 there and then have a dial plan entry with the pattern 999*.

 

I also think a simpler solution is to add "1-" No quotes to the beginning negates the need for dial plan changes and keeps cell phone redirects fuctional.

 

On a second note, since it detected the users CALLER-ID numbers, why force the PIN code and it seems this needs 10 digit dialing too.

Link to comment
Share on other sites

I also think a simpler solution is to add "1-" No quotes to the beginning negates the need for dial plan changes and keeps cell phone redirects fuctional.

 

On a second note, since it detected the users CALLER-ID numbers, why force the PIN code and it seems this needs 10 digit dialing too.

The need for the Pin code is very important, otherwise.

I can set my system to show your number as the caller ID, then I can call in and use your system, for long distance calls. I can also check any sprint cell phones voicemail unless they set it to use a pin.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...