Jump to content
Vodia PBX forum
olecoot

Agent Queue Statistics

Recommended Posts

I upgraded a server to 3.0.0.2998 Windows version. Since the upgrade, a large customer on the server has stopped getting statistics in the report that is emailed for his agent queues. I also have Linux versions 3.0.0.2998 that exhibit the same behavior. Is there currently a fix for this?

 

Thanks in advance.

Share this post


Link to post
Share on other sites
I upgraded a server to 3.0.0.2998 Windows version. Since the upgrade, a large customer on the server has stopped getting statistics in the report that is emailed for his agent queues. I also have Linux versions 3.0.0.2998 that exhibit the same behavior. Is there currently a fix for this?

 

You may have to move straight to 3.0.1.3017 (http://pbxnsip.com/protect/pbxctrl-3.0.1.3017.exe). There were a couple of problems with email servers, so I think it is better to upgrade to the above version. If you can, make a backup and give the new version a shot.

Share this post


Link to post
Share on other sites
You may have to move straight to 3.0.1.3017 (http://pbxnsip.com/protect/pbxctrl-3.0.1.3017.exe). There were a couple of problems with email servers, so I think it is better to upgrade to the above version. If you can, make a backup and give the new version a shot.

 

Do you have a Linux version? I have a test server that I will try it on and it is Linux.

 

This particular Windows server is in a production environment.

 

Thank you.

Share this post


Link to post
Share on other sites
OK. That corrected the problem. Now when is this going to become GA? :)

 

When I tested the release, it worked fine on our test system (RHEL5). Or customer (Windows server) ver 3.0.1.3023 however, still have an issue with no stats in the email. Any ideas? One suggestion was a time zone difference. Customer is set to Eastern and server is in Central timezone.

 

Contents of email Report:

Activity report of agents:

Agent Name Availability Calls Duration (Hold)

103 Ann 0

128 Shel xxxxx 1193032:38-1193038:40 1193038:48-1193039:26 0

132 Luisxxxxxxxx 0

135 Marixxxxxxxa 1193031:51-1193039:45 0

138 Jxxxxxxxxxx 0

151 Mexxxxxxxx 00:00-24:00 0

Share this post


Link to post
Share on other sites
When I tested the release, it worked fine on our test system (RHEL5). Or customer (Windows server) ver 3.0.1.3023 however, still have an issue with no stats in the email. Any ideas? One suggestion was a time zone difference. Customer is set to Eastern and server is in Central timezone.

 

Contents of email Report:

Activity report of agents:

Agent Name Availability Calls Duration (Hold)

103 Ann 0

128 Shel xxxxx 1193032:38-1193038:40 1193038:48-1193039:26 0

132 Luisxxxxxxxx 0

135 Marixxxxxxxa 1193031:51-1193039:45 0

138 Jxxxxxxxxxx 0

151 Mexxxxxxxx 00:00-24:00 0

 

Please wait one day/night. It could be that the last report is more than one day ago, and that would explain the strange availability times.

 

Was the starting time for Shel 16:38?

Share this post


Link to post
Share on other sites
Please wait one day/night. It could be that the last report is more than one day ago, and that would explain the strange availability times.

 

Was the starting time for Shel 16:38?

 

 

From this morning:

 

This email contains the summary of the operation of queue Air ACD on 2008/10/10.

 

Overview:

 

Number of calls: 0

Calls where user hung up while ringing: 0

Calls where user hung up while waiting: 0

Calls that have been redirected while ringing: 0

Calls that have been redirected while waiting: 0

Calls where callers navigated to other destinations: 0

Total duration spent in IVR:

Total duration ringing:

Total duration talking:

Total duration holding calls:

 

Activity report of agents:

Agent Name Availability Calls Duration (Hold)

103 Anna 0

128 Sheila 1193033:13-1193038:32 0

132 Luis 0

135 Marina 1193031:33-1193035:45 1193036:26-1193039:33 0

138 Jeannie 0

151 Melissa 00:00-24:00 0

 

List of calls to the queue:

From To Time Account IVR Ringing Talking (Hold)

 

Compared to my test server:

 

This email contains the summary of the operation of queue MGR PICK UP on 2008/10/09.

Overview:

Number of calls: 2

Calls where user hung up while ringing: 0

Calls where user hung up while waiting: 0

Calls that have been redirected while ringing: 0

Calls that have been redirected while waiting: 0

Calls where callers navigated to other destinations: 0

Total duration spent in IVR:

Total duration ringing: 0:00:24

Total duration talking: 0:01:16

Total duration holding calls:

 

Activity report of agents:

Agent Name Availability Calls Duration (Hold)

300 Joe Blow 00:00-24:00 1 0:00:35

450 Test-430 00:00-24:00 0

501 Test 501 00:00-24:00 1 0:00:41

 

List of calls to the queue:

From To Time Account IVR Ringing Talking (Hold)

300 4444 13:12:36 501 0:00:15 0:00:41

500 4444 13:13:26 300 0:00:09 0:00:35

 

From everything that I can see they are set up the same.

Share this post


Link to post
Share on other sites

There was one difference in the settings above and that would be the time zone. Both servers are in the central time zone. The domain that is issuing the report with the statistics is set for the same time zone as the server, i.e central TZ. The domain that is sending no statistics is set to eastern TZ.

 

As a test I set the domain that was sending stats in the report to eastern time zone while the server is set to central time zone and as a result the report came in with the statistics at zero. This does seem to have an affect on the stats. ????

Share this post


Link to post
Share on other sites

I think this is because the system time zone is not the domain time zone. When the system performs the mightnight events, it sets the timestamps for the agents in system time. Then when the statistics are being sent, the domain time zone is used. That explains the differences.

 

Workaround: Choose a system time that is the same as the domain time zone.

Share this post


Link to post
Share on other sites
I think this is because the system time zone is not the domain time zone. When the system performs the mightnight events, it sets the timestamps for the agents in system time. Then when the statistics are being sent, the domain time zone is used. That explains the differences.

 

Workaround: Choose a system time that is the same as the domain time zone.

 

Is there a fix for this in the next release, please? It did not seem to be broken in the 2.x release.

Share this post


Link to post
Share on other sites
Is there a fix for this in the next release, please? It did not seem to be broken in the 2.x release.

 

The next build will force the same timezones for midnight reset and reporting.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...