Jump to content

Snom One - after xx hours , bug and no sound (could not allocate sockets)


digiline_jg
 Share

Recommended Posts

Hi everybody,

 

recently i have 1 important problem.

 

after a few hours , when i call my customer , i don't hear sound (normally my customer has an auto attendant.

 

When i analyse in my config , i have in event log :

 

 

Port xxx : Could not allocate sockets !

Port xxx : Incomming call in domain on port xxx extension xx

Port xxx : New call created with number xx

Port xxx : Could not allocate sockets !

 

i restart the service , and after it's working for a few hours without problem ...

 

do you have any idea to resolve this ?

 

Jonathan Gressens

post-70009-0-46144500-1494416062_thumb.jpg

Link to comment
Share on other sites

Hi,

 

Missing audio or one way audio is generally associated with a firewall issue or the RTP unable to find ports on your system. And you arent able to hear the other party or you are not even able to hear the ringback tone when you call them?

Is this happening with only you and that customer or everywhere you call (or every call which your customer receives or makes?) ? Let's narrow down the problem.

Send us the screenshot of your RTP settings on Admin level and also check your firewall thoroughly.

488 error also suggests codec negotiation error.

Link to comment
Share on other sites

only when my client call or receive a call , no sound(audio) , no tonality , nothing.


before, "snomone" was installed on Windows xp , i upgraded this to Windows 10 , but the problem was the same.


this problem it's very important for my customer, yesterday i updated "Snom One" to "Vodia PBX" , and since , i don't have any more problems , i'm verry happy for this , but i activated a trial version (for 30 days to test it) of Vodia PBX ten (because my licence - snom one premium ten is not compatible with "vodia pbx" software)

Link to comment
Share on other sites

What are your settings for RTP ports? Maybe you have not enough ports there. Generally speaking you should choose a range of at least a few hundred ports, or better thousand. It also helps keeping those active port numbers random, which helps reduce problems with DoS.

Link to comment
Share on other sites

by default i use 200 ports in RTP ports config (10000 to 10200). maybe if i increases more ports , it will be better.


Since i updated the soft (Snomone 5.1.3) to the new version of VodiaPBX (Version 57) , I have no more problems... i see with my customer to sell a new licence.


thank you for your answers

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...