Jump to content

Does Snom C520 work on Vodia?


OND
 Share

Recommended Posts

Hello everyone. I was just wondering if anyone has ever setup a Snom C520 conference phone on the Vodia PBX. The GUI is totally different than other Snom phones and I haven't been able to get it going yet. Any help would be greatly appreciated. Thank you!

I'm running Vodia Multi-Tenant PBX version 67.0.4 hosted on Google

Link to comment
Share on other sites

This device is using a different code base than the other snom phones. The PBX don't automatically provision this phone. However because there are no buttons to configure the setup from the web browser is straightforward and if you install only one phone this should take just a few minutes.

Link to comment
Share on other sites

I've tried to copy the identity settings from a working D735 to the C520 as close as I can, but I still haven't been able to get it to register.

 

Here are the settings from the working D735:

Identity active: *on off
Displayname: West Conference Room
Account: 1110
Password: ••••••••
Registrar: office-by-airport
Outbound Proxy: sip:34.94.107.13:5060;transport=udp
Failover Identity: None
Hidden Identity: on *off
Authentication Username: 000413BC4D6D
Mailbox: *97
Mailbox Dial-in (if different from Mailbox):
Conference Server:
Display Text for Idle Screen: 1110: West Conference Room
Display Number for Idle Screen: 
Display Text for Call Forwarding Target:

 

Here are the settings from the C520:

Enable Account: yes
Account Label: 1110
Display Name: West Conference Room
User Identifer: 1110
Authentication Name: 000413A02A75
Authentication Password: ••••••••••••••
Dial Plan: x+P
Inter-Digit Timeout (secs): 3
Maximum Number of Calls: 6
Page Auto Answer: Manual
Feature Synchronization: Disable
Line Type: Private
DTMF Method: Auto
Unregister After Reboot: Disable

SIP Server
Server Address: 34.94.107.13
Port: 5060

Registration
Server Address: office-by-airport
Port: 5060
Expiration (secs): 3600
Registration Freq (secs): 10

Outbound Proxy
Server Address: 34.94.107.13
Port: 5060

Backup Outbound Proxy
Server Address:    
Port: 5060

Audio
Ringer Tone: 1
Codec Priority 1: G.711u
Codec Priority 2: G.711a
Codec Priority 3: G.729a/b
Codec Priority 4: G.726
Codec Priority 5: G.722
 Enable Voice Encryption (SRTP)
 Enable G.729 Annex B
Preferred Packetization Time (ms): 20

Quality of Service
DSCP (voice): 46
DSCP (signaling): 26

Signaling Settings
Local SIP Port: 5060
Transport: UDP

Feature Access Codes
Paging:
Call Park:
Parked Call Retrieval:
Voicemail: *97
DND ON: *78
DND OFF: *79
Call Forward All ON:
Call Forward All OFF:
Call Forward No Answer ON:
Call Forward No Answer OFF:
Call Forward Busy ON:
Call Forward Busy OFF:
Anonymous Call Reject ON:
Anonymous Call Reject OFF:
Anonymous Call ON:
Anonymous Call OFF:
Call Waiting ON:
Call Waiting OFF:
Group Call Pickup:
Direct Call Pick Up:

Voicemail Settings
 Enable MWI Subscription
Mailbox ID:    
Expiration (secs): 3600
 *Ignore Unsolicited MWI
 *Enable Stutter Dial Tone

NAT Traversal
 Enable STUN
Server Address:    
Port: 3478
 *Enable UDP Keep-Alive
Keep-Alive Interval (secs): 30

Music On Hold
 *Enable Local MoH

Network Conference
 Enable Network Conference
Conference URI:
    
Session Timer
 Enable Session Timer
Minimum Value (secs): 90
Maximum Value (secs): 1800

 

Is there anything that stands out as the reason why it may not be registering?

Thanks again!

Link to comment
Share on other sites

If you use the MAC address for authentication then you also need to use the MAC password for that MAC address. You can see that in the "VoIP phones" page. Alternatively, use the account name and the SIP password like you would register a soft phone. 

Link to comment
Share on other sites

That was it. I was using the MAC address for authentication, but using the SIP password. I swapped out the SIP password for the MAC password on the VoIP phones page and it came right up. Thank you for your help!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...