Jump to content

Inbound calls query LDAP address book


Recommended Posts

Well that depends on the phone... We generally try to provide the caller-ID information in the SIP header already so that there is no need for a query. The LDAP query is mostly for getting the photo of the caller, but the VoIP support is very weak.

Link to comment
Share on other sites

We have a query from a client who wishes to see the names of the caller on inbound calls.  We used to be able to do this on the Grandstream UCM 6200 series PBX.  I can get it to work if the contacts are local on the phone but not the LDAP address book.  We are using Grandstream phones and have incoming calls selected on the LDAP lookup... but nothing happens.   

... but I have a feeling it may have worked in the past.

 

"Change names in To/From-headers: Usually it is okay if the system changes the names in the To/From headers in the SIP packets. For example, this makes sense when the address book matches the caller-ID and the system should present the address book entry. "

Link to comment
Share on other sites

15 hours ago, RichardDCG said:

Think I have found it.  It was due to how numbers were being presented.  I had to set caller ID to remote party ID.  Also set to ignore other PAI and PPI.

Would it make sense to make any changes to the Grandstream template? Which one...

Link to comment
Share on other sites

these are for the GRP (GRP2634) series Grandstream phones.  Another area for them is the ringtones, we need to set the PBX to use Device Ringer explicitly, older GS phones seem to be ok.

is there a way for the system to match a partial string (similar to the last 7 digits for cell option)? i.e. some carriers present as 612XXXXYYYY and others 02XXXXYYYY  these are detected as different numbers by the LDAP lookup.  Ideally we would set look for XXXXYYYY ...

Link to comment
Share on other sites

The GRP because they don't require guessing Pxxx numbers. Do you remember what settings you changed in the template?

I would not go for partial number matching because this can cause ugly conflicts with other numbers. Its better to make sure they are all presented in the +xxx-form so that they are 100 % clear. 

Link to comment
Share on other sites

4 hours ago, Vodia PBX said:

The GRP because they don't require guessing Pxxx numbers. Do you remember what settings you changed in the template?

I would not go for partial number matching because this can cause ugly conflicts with other numbers. Its better to make sure they are all presented in the +xxx-form so that they are 100 % clear. 

I changed the LDAP setting:

        <item name="ldap">
            <part name="server">{domain}</part>
            <part name="port">2345</part>
            <part name="base">ou=people</part>
            <part name="username">{domain}\{account}</part>
            <part name="ldapNumberFilter">(|(sn=%)(gn=%)(telephoneNumber=%)(mobile=%))</part>
            <part name="ldapNameFilter">(|(sn=%)(gn=%)(telephoneNumber=%)(mobile=%))</part>
            <part name="version">version3</part>
            <part name="ldapNameAttributes">cn sn givenName</part>
            <part name="ldapNumberAttributes">telephoneNumber mobileTelephoneNumber</part>
            <part name="ldapDisplayName">cn sn</part>
            <part name="maxHits">50</part>
            <part name="searchTimeout">30</part>
            <part name="sortResults">Yes</part>
            <part name="outgoingCalls">Yes</part>
            <part name="ldapLookup">Yes</part>
            <part name="lookupDisplayName">cn sn</part>
            <part name="protocol">LDAP</part>
        </item>

I need to set exact match search to Yes, otherwise it matches partial numbers.  I also changed codec preferences.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...